Speakers only work if headphones are unplugged

As the title suggests. I’m not sure if this is intended behavior, and even though I’m a rather experienced Linux user for more than 2 years, I wonder if this is how it’s supposed to work as I didn’t use speakers before, but on Windows it does work the way I want it to.

Basically, I want to keep my headphones connected at all time but be able to switch between them and speakers via software when needed, but I can’t, if the headphones are plugged in, then switching to speakers results in no sound.

Here’s my wpctl status output:

PipeWire 'pipewire-0' [0.3.51, brandon@fedora, cookie:2978267734]
 └─ Clients:
        31. uresourced                          [0.3.51, brandon@fedora, pid:1611]
        32. WirePlumber                         [0.3.51, brandon@fedora, pid:1629]
        33. WirePlumber [export]                [0.3.51, brandon@fedora, pid:1629]
        52. librespot                           [0.3.51, brandon@fedora, pid:2]
        53. wpctl                               [0.3.51, brandon@fedora, pid:22682]
        54. GNOME Shell Volume Control          [0.3.51, brandon@fedora, pid:1669]
        55. GNOME Volume Control Media Keys     [0.3.51, brandon@fedora, pid:1974]
        56. GSConnect                           [0.3.51, brandon@fedora, pid:2056]
        57. xdg-desktop-portal                  [0.3.51, brandon@fedora, pid:2378]
        59. Firefox                             [0.3.51, brandon@fedora, pid:3395]
        83. Firefox                             [0.3.51, brandon@fedora, pid:3395]
        92. GNOME Settings                      [0.3.51, brandon@fedora, pid:20193]
        94. Mutter                              [0.3.51, brandon@fedora, pid:1669]

Audio
 ├─ Devices:
 │      41. Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT] [alsa]
 │      42. REDRAGON Live Camera Audio          [alsa]
 │      43. Family 17h (Models 10h-1fh) HD Audio Controller (PRIME B450M-A Motherboard) [alsa]
 │  
 ├─ Sinks:
 │  *   47. Family 17h (Models 10h-1fh) HD Audio Controller (PRIME B450M-A Motherboard) Analog Stereo [vol: 1.00]
 │  
 ├─ Sink endpoints:
 │  
 ├─ Sources:
 │  *   46. REDRAGON Live Camera Audio Analog Stereo [vol: 1.00]
 │      96. Family 17h (Models 10h-1fh) HD Audio Controller (PRIME B450M-A Motherboard) Analog Stereo [vol: 0.74]
 │  
 ├─ Source endpoints:
 │  
 └─ Streams:
        87. librespot                                                   
             50. output_FL       > ALC887-VD Analog:playback_FL
             79. output_FR       > ALC887-VD Analog:playback_FR

Video
 ├─ Devices:
 │      39. REDRAGON Live Camera Audio          [v4l2]
 │      40. REDRAGON Live Camera Audio          [v4l2]
 │  
 ├─ Sinks:
 │  
 ├─ Sink endpoints:
 │  
 ├─ Sources:
 │  *   44. REDRAGON Live Camera Audio         
 │  
 ├─ Source endpoints:
 │  
 └─ Streams:

Settings
 └─ Default Configured Node Names:
         0. Audio/Sink    alsa_output.pci-0000_0b_00.6.analog-stereo
         1. Audio/Source  alsa_input.usb-Sonix_Technology_Co.__Ltd._REDRAGON_Live_Camera_Audio_SN0001-02.analog-stereo

Would love to be able to get it working the way I want it to work. Please let me know if I’m doing something wrong. as I don’t really use forums that often (this is actually my first time using one)

1 Like

Historically for audio systems when a headphone was plugged in the speakers were physically disconnected (at the pre-amp level)

Most systems still do the same, but many are by software now and not a physical disconnect.

I have never known a means to have 2 different audio outputs from the same system, and that seems what you wish. Both headphones and speakers to work at the same time.

In fact, that seems to me to be a little bit difficult physically since the headphones (wired) are fed at pre-amp levels and the speakers are fed at power-amp levels. This means the headphones use the signal before it reaches the power amp.

I don’t know how your windows system is able to do that, but someone else may be able to assist.

Thank you for your reply!
I don’t want both to work at the same time, but I don’t want to have to unplug my headphones to use my speakers, I want to switch my output to the speakers via software, but when I try to, it doesn’t work unless I unplug the headphones. Sorry if I didn’t make myself clear, not a native English speaker haha.

Maybe I’m too late, but I had the same problem and I solved using alsamixer in a terminal, I selcted the correct soundcard and disabled auto-mute