SSD not recognized by the installer - Western Digital SN520 NVMe

Hi,

I have an Acer Aspire A315 with 8 GB Ram and a 250 Gb SSD currently running Windows 10 and Ubuntu 21.04 with dual boot.
It was very hard for me to get Ubuntu installed on my laptop because it seems there is a lack of support for the drivers of my SSD. I finally managed to install it with this : Boot problems with Ubuntu - boot hangs | Linux.org
(you basically need to write a few lines of code in GRUB on the boot screen).

Now I’d like to switch to Fedora (and totally erase both Ubuntu and Windows) but I’m stuck because the Fedora installer doesn’t recognize my SSD (no local disk). I had the solution for Ubutu, but I don’t know how to solve the problem with Fedora. Could someone help me ?

Have you tried doing the same thing with fedora you did with ubuntu?

Hi Albert, welcome to the forum.

Try booting from the Fedora USB as normal. When you get to the screen that gives the option to test the media or start Fedora, there’s a line that says ‘Press Tab for full configuration options on menu items’. When you press tab, you get the GRUB line and you just need to add a space and then ‘nvme_core.default_ps_max_latency_us=5500’ at the end.

That should enable the installer to see the SSD. I can’t test it myself but if it works for Ubuntu, it should work for Fedora, since it’s simply a linux kernel parameter.

Once Fedora is installed, you may need to add that same parameter to the installed GRUB - or it may be that the installer itself is clever enough to add the parameter. Might be worth checking on first boot to the installed Fedora by pressing ‘e’ (to edit the GRUB line) to see if the parameter is there.

1 Like

You can verify that in BIOS settings, you do not have a RAID option instead of AHCI. In my Dell OptiPlex computer I had to change this option because the Fedora installer did not see any disk.

https://www.dell.com/support/kbdoc/pl-pl/000131901/loading-ubuntu-on-systems-using-pcie-m2-drives?lang=en

1 Like

Yes I already checked the AHCI and everything was fine. The problem really comes from my SSD…

Thanks for your help !
I edited the entry on the boot screen and added “nvme_core.default_ps_max_latency_us=5500” at the end of “quiet” and it successfully booted up.
Now the problem is that this is a temporary solution : everytime I shut down or restart my computer, if I dont edit the entry on the boot screen my computer won’t boot up successfully (there is just a black screen).

On Ubuntu I had to edit a grub file in /etc/default ans then apply the change with “sudo update-grub”… but I’m a newbie with Fedora and I don’t know the equivalent of this command.

Update : I finally managed to update the grub file with “grub2-mkconfig -o /etc/grub2.cfg” and “grub2-mkconfig -o /etc/grub2-efi.cfg”.
I restarted my computer and it booted up successfully. Same after an update. I think the problem is fixed now. Thanks again for your help :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.