Sshd and PasswordAuthentication

So as per F32 docs, I went to disable password authentication on my new F32 Workstation. After changing its value from yes to no and also uncommenting it in /etc/ssh/sshd_config. I then restart the service using sudo systemctl restart sshd. Now on another client i run the command ssh username@hostl -o PubkeyAuthentication=no and the result should be that the client is denied, however in fact it asks me for my password. And the strange thing is on my other F32 Servers that have the same sshd_config those work accordingly. It is just F32 Workstation that is giving me the improper results. Anybody else running into this issue.

First thought: check if there are config files in /etc/ssh/sshd_config.d/ that might be overriding /etc/ssh/sshd_config.

No other configs in sshd_config.d. I did find a work around, but it is not ideal.
Added the following to sshd_config

Match User username
PasswordAuthentication no

Then when logging in with that user everything is working, but on multi user system have to do that per user basis. I want it to be global, where all users do not have password authentication.
Another side note, I noticed that this bug only happens on my Intel based system. All of my AMD systems which all use the same sshd_config settings work as intended. And more specifically it’s version 8.3p1-3 for Fedora 32. On same system I installed ArchLinux and FreeBSD 12.1 to test their versions of openssh and both work as intended.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.