Starting: hold until boot process finishesp -Blocked and boot never goes throug

Yesterday i upgraded 2 fedora boxes to f34, after issuing
sudo dnf system-upgrade reboot
it restarts, upgrade is done then it reboots but it gets stuck as you can notice in the snapshot for the 2 fedoras. What is strange is that I can RDP on both machines. Thanks for your help

Hi @eliassal Welcome back. Could you test when the boot stops? Read the logs?

Hi,

I guess you are running two Fedora in virtual machine which are hosted on remote server. If this what happen, may be you could remote your remote server and check the disk allocation of your virtual machine. Most likely you’re running out disk space allocation for your virtual machines.

1 Like

For VM1, which was upgraded to f35 successfully, it stops at

Started CUPS Schedueler as you can see in the snapshot. The other VM currently getting upgraded to f 35 as well which was also stuck at boot as in the 1st snapshpt i provided earlier

Yes, but I have no issue with space and thte 2 VMs are on 2 different Hyper-V hosts

@Jaap, 2nd VM finished upgrading to F35, it blocks at “Started OpenSSH server Daemon”

Is there any previous kernel version listed on your boot list and could you try to boot it?

I have experiences it’s ok to boot previous kernel from previous version Fedora (in my case booting Rawhide/f36 with kernel from Fedora 34).

@jaap I rebooted thiis morning, it crosses the step
Started CUPS Schedueler

and gets stuck at

Network Manager script dispatcher Service

snapshot

Here is screen copy of the boot and I chose F35

fedora2VMs-Boot

1 Like

Try the second line. If second line ok, maybe we could narrow down the problem.

Same thing happens. As I said, this started when I migrated f33 to f34, then again happening after upgrading to f35.
I rebooted again it gets stuck on
Started Nofify NFS peers of a a restart

fedora2VMs-NotifyNFS

Then try the third line where you last known works kernel. You’ll still boot on Fedora 35 but with older kernel.

unfortunately, last known was f32 which I removed after upgrading to F34. I used the 3rd line f33 and got stuck again on line
Notify NFS…

fedora2VMs-Boot

screenshot of the block point since I rebooted (3 hours) and what I said earlier is that I am able to RDP to the VM

fedora2VMs-NotifyNFS

Btw, if you have important file inside your virtual machine maybe you could backup it first by accessing the virtual drive.

1 Like

I said several times, I can RDP and have access to all files, this is not the problem, I need Fedora finsishes and not get stuck

I’m sorry, my bad.

On the boot list with kernel 5.15.6, press e then print screen. Let see what your kernel parameter do you have there. It will show something similiar like this:

title Fedora Linux (5.15.6-200.fc35.x86_64) 35 (Workstation Edition)
version 5.15.6-200.fc35.x86_64
linux /vmlinuz-5.15.6-200.fc35.x86_64
initrd /initramfs-5.15.6-200.fc35.x86_64.img
options root=UUID=1111-2222-3333-1111-2222 ro rootflags=subvol=@ quiet 
grub_users $grub_users
grub_arg --unrestricted
grub_class fedora
1 Like

I pressed e, here is the snapshot
fedoraBoot_PressE

1 Like

HI, the procedure that will I suggest it only temporary and will not be saved by your system. So if you reboot your system (in this case your virtual machine) the setting will be back as before.

With your arrow key, delete this value resume=/dev/mapper/fedora-swap then press ctrl+x to start booting. See if this work or not.

OK, but how do I delete it? There is no entry or key to delete