Steam doesn't start in Fedora 35

[ssr@ssr-fedora-c ~]$ steam
steam.sh[68350]: Running Steam on fedora 35 64-bit
steam.sh[68350]: STEAM_RUNTIME is enabled automatically
setup.sh[68425]: Steam runtime environment up-to-date!
steam.sh[68350]: Steam client's requirements are satisfied
[ssr@ssr-fedora-c ~]$

Exits every time after “Steam client’s requirements are satisfied”. Reinstall didn’t help. Started previously.

1 Like

The ONLY pertinent info here is fedora 35 and steam does not start.
What kernel?
Is fedora fully updated?
Is steam installed from rpmfusion or by flatpak?
What GPU?
What DE? Gnome? KDE? or?
Using xorg? or wayland?
What version of steam?

What was done between the last time it ran and now?
What version of steam? kernel? etc. when it last ran for you?

We cannot provide meaningful suggestions without detailed info on which to base those suggestions.

3 Likes

Thank you very much!

All latest updates. Kernel Linux ssr-fedora-c 5.16.16-200.fc35.x86_64 #1 SMP PREEMPT Sat Mar 19 13:52:41 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Yes

rpmfusion (dnf)

NVIDIA Corporation GP108 [GeForce GT 1030] (rev a1)

Cinnamon official spin

Xorg

steam.i686 1.0.0.74-2.fc35 @rpmfusion-nonfree-updates

Probably reboots and kernel updates as I suggest

Probably ran with current kernel. Steam version is updated with Fedora. Used to run with previous kernels, but was also erroring sometimes. Reboot to older kernel may work now, if I try now. Or may not. If works, this appears again after some time (and updates?).

1 Like

I see some items of difference and possible problems.

  1. You are running cinnamon and I am using gnome.
  2. I did not ask about the driver for the GPU, but I am using the nvidia driver installed from rpmfusion. akmod-nvidia.x86_64 3:510.47.03-2.fc35 @rpmfusion-nonfree-nvidia-driver This same driver should work for your GPU as it works for me with a Geforce GTX 1050 card.

I just started steam on both my systems (fedora 34 & 35) after letting it set idle for about a month and it works for me. I am not sure what is going on for you, but this is the terminal output when I launch it from the command line and it starts properly on fedora 34

$ steam
steam.sh[1962341]: Running Steam on fedora 34 64-bit
steam.sh[1962341]: STEAM_RUNTIME is enabled automatically
setup.sh[1962415]: Steam runtime environment up-to-date!
steam.sh[1962341]: Steam client's requirements are satisfied
max open descriptors set to 9216

This is the output from fedora 35 on my laptop. Note that it also starts up properly.

$ steam
steam.sh[7069]: Running Steam on fedora 35 64-bit
steam.sh[7069]: STEAM_RUNTIME is enabled automatically
setup.sh[7144]: Steam runtime environment up-to-date!
steam.sh[7069]: Steam client's requirements are satisfied
[2022-03-28 13:00:20] Startup - updater built Mar 14 2022 19:48:46
Installing breakpad exception handler for appid(steam)/version(1647446817)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2022-03-28 13:00:20] Loading cached metrics from disk (/home/jvian/.local/share/Steam/package/steam_client_metrics.bin)
[2022-03-28 13:00:20] Using the following download hosts for Public, Realm steamglobal
[2022-03-28 13:00:20] 1. https://cdn.cloudflare.steamstatic.com, /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2022-03-28 13:00:20] 2. https://cdn.akamai.steamstatic.com, /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2022-03-28 13:00:20] 3. http://media.steampowered.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
Installing breakpad exception handler for appid(steam)/version(1647446817)
[2022-03-28 13:00:20] Checking for update on startup
[2022-03-28 13:00:20] Checking for available updates...
[2022-03-28 13:00:20] Downloading manifest: https://cdn.cloudflare.steamstatic.com/client/steam_client_ubuntu12
Installing breakpad exception handler for appid(steam)/version(1647446817)
[2022-03-28 13:00:21] Download skipped: /client/steam_client_ubuntu12 version 1647446817, installed version 1647446817, existing pending version 0
[2022-03-28 13:00:21] Nothing to do
[2022-03-28 13:00:21] Verifying installation...
[2022-03-28 13:00:21] Performing checksum verification of executable files
[2022-03-28 13:00:21] Verification complete
Loaded SDL version 2.0.21-7140709

(steam:7213): Gtk-WARNING **: 13:00:22.002: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/main.rc:733: error: unexpected identifier 'direction', expected character '}'

(steam:7213): Gtk-WARNING **: 13:00:22.004: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/hacks.rc:28: error: invalid string constant "normal_entry", expected valid string constant
Gtk-Message: 13:00:22.007: Failed to load module "pk-gtk-module"
steamwebhelper.sh[7241]: Runtime for steamwebhelper: defaulting to /home/jvian/.local/share/Steam/ubuntu12_64/steam-runtime-heavy
steamwebhelper.sh[7241]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
CAppInfoCacheReadFromDiskThread took 29 milliseconds to initialize
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)

(steam:7213): Gtk-WARNING **: 13:00:22.686: gtk_disable_setlocale() must be called before gtk_init()
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
Connectivity test: result=Connected, in progress=0
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

Installing breakpad exception handler for appid(steam)/version(1647446817)
roaming config store loaded successfully - 379 bytes.
migrating temporary roaming config store
BRefreshApplicationsInLibrary 1: 4ms
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

Installing breakpad exception handler for appid(steam)/version(1647446817)
Failed to init SteamVR because it isn't installed
ExecCommandLine: "'/home/jvian/.local/share/Steam/ubuntu12_32/steam'"
System startup time: 2.72 seconds
BuildCompleteAppOverviewChange: 103
BuildCompleteAppOverviewChange: 104
RegisterForAppOverview 1: 8ms
RegisterForAppOverview 2: 8ms
Installing breakpad exception handler for appid(steam)/version(1647446817)
Installing breakpad exception handler for appid(steam)/version(1647446817)
[2022-03-28 13:02:02] Background update loop checking for update. . .
[2022-03-28 13:02:02] Checking for available updates...
[2022-03-28 13:02:02] Downloading manifest: https://cdn.cloudflare.steamstatic.com/client/steam_client_ubuntu12
[2022-03-28 13:02:03] Download skipped by HTTP 304 Not Modified
[2022-03-28 13:02:03] Nothing to do

Note that when I installed steam it created a startup icon in the activities menu and I normally use that to launch steam. There I saw the normal update progress bar and login popup but no other messages on either system.

Both my systems were updated during the night last night and were rebooted just prior to testing steam.

2 Likes

Thank you again! Here is what happened later:

I begin testing. With current kernel 5.16.16: steam fails from command line “steam” and from Cinnamon menu with “/usr/bin/steam %U”

Plain reboot back into kernel 5.16.16: steam starts from command line. Then I exit. Then I again am unable to start both from console and menu.

Plain reboot back into kernel 5.16.16 again. Successful start from command line. Exit. Start from menu with activated “Open in terminal” option. Terminal output:

steam.sh[2464]: Running Steam on fedora 35 64-bit
steam.sh[2464]: STEAM_RUNTIME is enabled automatically
setup.sh[2540]: Steam runtime environment up-to-date!
steam.sh[2464]: Steam client's requirements are satisfied
[2022-03-28 22:36:02] Startup - updater built Mar 14 2022 19:48:46
Installing breakpad exception handler for appid(steam)/version(1647446817)
[2022-03-28 22:36:02] Loading cached metrics from disk (/home/ssr/.local/share/Steam/package/steam_client_metrics.bin)
[2022-03-28 22:36:02] Using the following download hosts for Public, Realm steamglobal
[2022-03-28 22:36:02] 1. https://cdn.cloudflare.steamstatic.com, /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2022-03-28 22:36:02] 2. https://cdn.akamai.steamstatic.com, /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2022-03-28 22:36:02] 3. http://media.steampowered.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
Installing breakpad exception handler for appid(steam)/version(1647446817)
[2022-03-28 22:36:02] Verifying installation...
[2022-03-28 22:36:02] Verification complete
Loaded SDL version 2.0.21-7140709
/home/ssr/.themes/Adapta-Nokto/gtk-2.0/common-dark.rc:1425: error: unexpected identifier 'direction', expected character '}'
/home/ssr/.themes/Adapta-Nokto/gtk-2.0/3rd-party-dark.rc:475: error: invalid string constant "toolbar", expected valid string constant

At this point steam keeps silent and not running more. I close terminal. Again to command line and type “/usr/bin/steam %U”. Successful start. Exit. Run with “steam” - success. Exit. Again I go to menu. Unable to start from menu. Again stops on “expected valid string constant”. Summary: runs from command line, doesn’t run from menu.

Plain reboot back into kernel 5.16.16 again. Successful start from command line. Exit. Start from menu: failure.

Now I see that initial error - exit after “Steam client’s requirements are satisfied” - is diplayed in console when another process is running that hangs on “expected valid string constant”. I kill steam process. Console start works then.

Plain reboot back into kernel 5.16.16 again. Start from menu: failure. Kill process. Start from console: success.

Appears to be related to Cinnamon menu.

When failure, it stops on:

/home/ssr/.themes/Adapta-Nokto/gtk-2.0/3rd-party-dark.rc:475: error: invalid string constant "toolbar", expected valid string constant

When success, the next string is:

steamwebhelper.sh[5884]: Runtime for steamwebhelper: defaulting to /home/ssr/.local/share/Steam/ubuntu12_64/steam-runtime-heavy
steamwebhelper.sh[5884]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
1 Like

It sounds like the desktop theme you are using may be the issue. Consider trying different themes to see if there may be different behavior if your desktop is configured differently.

You may have noted that mine complained about the adwaita theme, but did actually start.

This may be time for a bug report against steam for the behavior you are seeing.

2 Likes

Thanks for the advice, I have filed the bug report: https://bugzilla.rpmfusion.org/show_bug.cgi?id=6250

No answer on this and some other bugreports concerning Fedora-Cinnamon. Looks like Fedora-Cinnamon is unmaintained.

Can you please try a new user with a clean Cinnamon environment and see how that goes?

It isn’t orphaned in the package database, so it’s not officially unmaintained. The maintainers may be busy at the moment (remember that we’re all volunteers).

https://src.fedoraproject.org/rpms/cinnamon/commits/rawhide

Can you please test in a new user to see how that goes? If it works there, it’s not a Cinnamon issue—there’s something wrong with the theme you are using (or another use customisation).

Thank you!

I have tried with new user “newuser”. Fedora generated new Cinnamon user with default “Mint-Y” theme (not “Adapta-Nokto” as before).

Same effect. Unability to start from menu. But can start from console. When unable to start, the last strings are:

Loaded SDL version 2.0.21-7140709

(steam:96165): Gtk-WARNING **: 07:33:58.425: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Mint-Y-Dark-Aqua/gtk-2.0/main.rc:1085: error: unexpected identifier 'direction', expected character '}'

Maybe have a look at Steam tray menu not using gtk theme · Issue #4428 · ValveSoftware/steam-for-linux · GitHub

Thanks.

Thank you, it definitely has something to do with that. I couldn’t fix yet, but renaming “libgtk-x11-2.0.so.0” changes the “final” output to

(steam:123363): Gtk-WARNING **: 15:51:58.197: Unable to locate theme engine in module_path: "murrine",

(steam:123363): Gtk-WARNING **: 15:51:58.198: Unable to locate theme engine in module_path: "murrine",

(steam:123363): Gtk-WARNING **: 15:51:58.199: Unable to locate theme engine in module_path: "murrine",

Playing around with themes showed that “Gtk-WARNINGs” probably don’t matter. With or without these warnings, Steam is able to start from console and unable to start from menu. Regardless of themes, it can’t go from “Loaded SDL version” to “Runtime for steamwebhelper: defaulting to /home/ssr/.local/share/Steam/ubuntu12_64/steam-runtime-heavy”.

Does this machine have an integrated GPU as well?
May want to try copying steam desktop file to ~/.local/share/applications/ and modify the file to remove PrefersNonDefaultGPU=true

ref: Steam not launching, not reporting any errors · Issue #8276 · ValveSoftware/steam-for-linux · GitHub

2 Likes

Great! Success! Thank you!

Integrated GPU is present, and “~/.local/share/applications/steam.desktop” is also present, commenting out “PrefersNonDefaultGPU=true” solved the problem!

1 Like