Steam no longer works (flatpak, nvidia graphics card)

Hi, I am new to Fedora and have troubles using Steam. It was working a while ago but is broken now, I believe I updated some packages.

When starting Steam via flatpak I get the following error message:

[rolf@dragonfly ~]$ flatpak run com.valvesoftware.Steam
https://github.com/flathub/com.valvesoftware.Steam/wiki/Frequently-asked-questions
Overriding TZ to Europe/Berlin
Running Steam on org.freedesktop.platform 18.08.30 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1556574584)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

If I understand the output correctly, Steam is trying to load software rendering libraries and failing. That looks like something with my proprietary Nvidia drivers may be wrong. But running nvidia-smi indicates to me that the proprietary drivers are installed:

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 418.67       Driver Version: 418.67       CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 107...  Off  | 00000000:07:00.0  On |                  N/A |
| 43%   38C    P2    34W / 180W |    351MiB /  8116MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

While trying to fix it, I already tried to uninstall the drivers using sudo dnf remove *nvidia* --noautoremove and then reinstall them via sudo dnf install cuda. I did that, because dnf update was unable to update some packages and I thought that might be related.

I did also try flatpak run com.valvesoftware.Steam --reset but the problem remains. This is not a general problem with flatpak as (for example) Spotify works.

What can I do to find out more about the problem and to solve it?

[rolf@dragonfly ~]$ dnf list installed | grep nvidia
dkms-nvidia.x86_64                                3:418.67-1.fc29                        @cuda                           
nvidia-driver.x86_64                              3:418.67-4.fc29                        @cuda                           
nvidia-driver-NVML.x86_64                         3:418.67-4.fc29                        @cuda                           
nvidia-driver-NvFBCOpenGL.x86_64                  3:418.67-4.fc29                        @cuda                           
nvidia-driver-cuda.x86_64                         3:418.67-4.fc29                        @cuda                           
nvidia-driver-cuda-libs.x86_64                    3:418.67-4.fc29                        @cuda                           
nvidia-driver-devel.x86_64                        3:418.67-4.fc29                        @cuda                           
nvidia-driver-libs.x86_64                         3:418.67-4.fc29                        @cuda                           
nvidia-libXNVCtrl.x86_64                          3:418.67-1.fc29                        @cuda                           
nvidia-libXNVCtrl-devel.x86_64                    3:418.67-1.fc29                        @cuda                           
nvidia-modprobe.x86_64                            3:418.74-1.fc30                        @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                        3:418.67-1.fc29                        @cuda                           
nvidia-settings.x86_64                            3:418.74-1.fc30                        @rpmfusion-nonfree-nvidia-driver
nvidia-xconfig.x86_64                             3:418.74-1.fc30                        @rpmfusion-nonfree-nvidia-driver

Hi,

From reading the github issue, it seems that flatpak update or installing the nvidia drivers within flatpak should resolve the issue.

Thanks Tom.

1 Like

Thanks, your solution did work. I had to do a bit more to get it working though.

I removed the cuda repo from where I originally got my cuda packages and removed the proprietary nvidia drivers. Then I reinstalled them using instructions from https://rpmfusion.org/Howto/NVIDIA and rebooted my PC. After that running flatpak update as suggested installed missing packages for flatpak.

2 Likes