Stopping PulseAudio Results in Automated Restart

While making my migration over to Fedora 30 with the KDE spin, I have been having trouble with trying to get pulseaudio to behave correctly, like how it did on my previous choice of distro. While trying to get to a point where I could debug pulseaudio to get a better picture of what is going on, I noticed that I cannot stop pulseaudio from respawning on F30. I so far have tried:

  • making a client.conf with autostart = no in ~/.config/pulse and killing pulseaudio after
  • editing the client.conf in /etc/pulse to include autostart = no and then restarting
  • Checking to what the parent of Pulseaudio is: SystemD
  • Attempting to disable pulseaudio via SystemD (pulseaudio.service doesn’t exist)
  • Noting SystemD is run in user mode for the service, but cannot find any entries in the usual ~/.config/systemd/ to remove/disable

I am personally stumped. I don’t have vast knowledge on how to use SystemD and it seems that normal functionality of pulseaudio is being shredded by it. How can I physically disable pulseaudio from automatically restarting when I kill it on F30?

1 Like

Hello @jrgd ! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Did you try with

systemctl --user status pulseaudio 

Then:

systemctl --user stop pulseaudio.socket
systemctl --user stop pulseaudio.service

Yep, this works, thank you.