Super+1 = Move window to workspace 1; is now not responding. Instead it lauches Firefox!

I use my own set of custom shortkey to move Workspace 1 as you can see:
image

And to open Firefox, I use Super + B as you can see:
image

But for some reason, whenever I try to jump to Workspace 1, it launches Firefox. I don’t understand why. All other custom shortkeys like the one mentioned below works fine:

  • Super + 2 = Move window to Workspace 2
  • Super + 3 = Move window to Workspace 3

When I open Gnome logs, I see a new issue saying:
image

I wonder if this is the real issue or not, but its new. Is there something that I can do other than obivous solution which is to restart. I want to find a cause for this and report to appropriate place if possible.

Those shortcuts overlap with favorites shortcuts, IE… super +1 Activates favorite Application 1. You can get the list by gsettings get org.gnome.shell favorite-apps

Info for filing a bug here:
https://docs.fedoraproject.org/en-US/quick-docs/howto-file-a-bug/

You should be able to look at : sudo dnf history --reverse and then look at the IDs sudo dnf history info ID#
And see if any of the gnome components updated (gdm, gnome-shell, etc … )

You should also look at disabling any extentions just to see if they’re contributing.

On a side note, you may not need to restart, just re-apply the shortcut so it disables the existing shortcut if it was re-activated.

1 Like

So this list of “favorites shortcuts” is created automatically and comes into action in a form of shortcuts sometimes?! Weird.

pranav@fedora ~> gsettings get org.gnome.shell favorite-apps
['firefox.desktop', 'org.gnome.Calendar.desktop', 'org.gnome.Music.desktop', 'org.gnome.Nautilus.desktop', 'org.gnome.Software.desktop']

Well, my DNF history looks like this.

From my understanding, I think I managed to uninstall all debugging packages which I had to install in order to get stack traces except for this:

224 | --enablerepo=*debug* install /usr/lib/debug/.build-id/e8/4e55b96ca7dd6655dc72fce14c4fda4f051537.debug | 2021-09-18 12:38 | Install  |1

dnf info libblkid command doesn’t tell me whether the installed package is the normal package or dev/experimental package. Is there a way to know this? Then please do let me know.

pranav@fedora ~> sudo dnf history info 224
[sudo] password for pranav:
Transaction ID : 224
Begin time     : Sat 18 Sep 2021 12:38:10 PM +0545
Begin rpmdb    : 2132:c7e53a1f9ef038637a7d3337119031a8ca050fa9
End time       : Sat 18 Sep 2021 12:38:11 PM +0545 (1 seconds)
End rpmdb      : 2133:340a64e921e619b9324843be8bd85f4fcba5b846
User           : shiboham <pranav>
Return-Code    : Success
Releasever     : 34
Command Line   : --enablerepo=*debug* install /usr/lib/debug/.build-id/e8/4e55b96ca7dd6655dc72fce14c4fda4f051537.debug
Comment        :
Packages Altered:
    Install libblkid-debuginfo-2.36.2-1.fc34.x86_64 @fedora-debuginfo

You should also look at disabling any extensions just to see if they’re contributing.

I have tried this. The issue arises regardless of whether I enable or disable extensions.

just re-apply the shortcut so it disables the existing shortcut if it was re-activated.

I know this painful process. It would be better to resolve this issue altogether.

Looks like an existing bug, Super+number key combos can't be overriden in GNOME 3.32 (#1250) · Issues · GNOME / gnome-shell · GitLab

Fixed in gnome 41

On a side note, you may not need to restart, just re-apply the shortcut so it disables the existing shortcut if it was re-activated.

Would only work in f35 based on the bug.

OMG, that really old bug. Suprised to see it.

Anyway thanks for your finding. Waiting for stable Fedora 35 release.