Suspend and login screen issues with NVidia drivers

Hi,

I freshly installed Fedora 33 workstation some weeks ago on my desktop machine and do have some trouble using it with my GTX 970.

I’m using XFCE as my DE. And GDM as display manager.
I installed the nvidia drivers the RPM fusion repository with sudo dnf install akmod-nvidia.

And I’m experiencing some issues:

  • When enabling suspend and trying to wake up, I get a black screen.
  • I cannot switch to a different terminal (e.g. by using CTRL+Alt+F2), I get a black screen when trying to do that
  • I needed to disable plymouth, otherwise I get a black screen instead of the login screen
  • During boot my display goes to sleep twice. First before showing the the login screen, and directly after entering my password. After ~10 seconds my desktop is shown.

Anything I can do to fix these issues?

Same issues with Gnome with a GTX1070, what I have found reliable to wake the computer is to press the power button which is set for suspend.

Yes, when pressing the power button the fans spin up and the PC apparently wakes up. Unfortunately the screen stays black, and I can’t do anything to see my login screen.

You’re commisioning memory here beyond the basic requirement with the use of GDM even when you could have done with the likes of LightDM as the former service is at four times as heavy as the latter. That’s not what the issue is about but I thought that you could use this advice.

Coming to your question, X11 or Wayland?

EDIT -> Welcome to Fedora, @perfex and @cliff. Feel free to pay a visit to the Code of Conduct which you can find at the top right part of your screen. (Visit this link if you don’t see it https://docs.fedoraproject.org/en-US/project/code-of-conduct/)

From what I have been able to ascertain this issue has been ongoing for a while now, supposed solutions included increasing swap size (pre 33) to changing the kernel.

Nvidia uses X11 by default as far as I’m aware

@cliff I would have the same result if I attempted to wake from keyboard or mouse first, rather I now just use the power button, oddly enough the same issue presents it self with blank screen enabled in Gnome.

I’d like to use LightDM but I only get a black screen with it. No login screen at all with it. I think this is the same issue I’m describing in my first post.

I’m using X11. AFAIK XFCE and NVidia only support X11.

I’d understand this if I’d have an issue with Hibernation, but suspending the system shouldn’t use swap at all. And I already assigned 20 GiB of swap to my system.

Same issue if I don’t touch my keyboard or mouse at all after suspending and waking it up with the power button.

Wow. This would require investigation. I was not aware that NVIDIA no longer sets things right with LightDM.

The last time I checked, XFCE did have an support for X11, though limited in nature. Did they just give up on it?

Also, NVIDIA does support Wayland (in an Optimus setup) but yours is a PC so that it needs to have X11 unconditionally as there’s no fallback to render the desktop environment.