Synergy not working in server mode

Fedora 30 MATE
synergy 2.0.0-5.fc30 from fedora’s repo

Attempting to run synergy in server mode gives this error popup:

Failed to get local IP address. Please manually type in server address on your clients

and then the log shows the following output with errors and automatically restarting the process every second:

2019-05-05T17:14:01] DEBUG: starting process
[2019-05-05T17:14:01] INFO: starting server
[2019-05-05T17:14:01] INFO: command: /usr/bin/synergys -f --debug DEBUG --name [HOSTNAME] -c /tmp/qt_temp.TJ9183 --address :24800
[2019-05-05T17:14:01] INFO: config file: /tmp/qt_temp.XM9183
[2019-05-05T17:14:01] INFO: log level: DEBUG
[2019-05-05T17:14:01] DEBUG: opening configuration "/tmp/qt_temp.TJ9183"
warning: synergys is deprecated. instead, use: synergy-core --server
[2019-05-05T17:14:01] ERROR: process exited with error code: 4
[2019-05-05T17:14:01] INFO: detected process not running, auto restarting
[2019-05-05T17:14:02] DEBUG: starting process
[2019-05-05T17:14:02] INFO: starting server
[2019-05-05T17:14:02] INFO: command: /usr/bin/synergys -f --debug DEBUG --name [HOSTNAME] -c /tmp/qt_temp.Lh9183 --address :24800
[2019-05-05T17:14:02] INFO: config file: /tmp/qt_temp.nS9183
[2019-05-05T17:14:02] INFO: log level: DEBUG
[2019-05-05T17:14:02] DEBUG: opening configuration "/tmp/qt_temp.Lh9183"
warning: synergys is deprecated. instead, use: synergy-core --server
[2019-05-05T17:14:02] ERROR: process exited with error code: 4
[2019-05-05T17:14:02] INFO: detected process not running, auto restarting

Client mode words without problem.

Also, the system tray applet is not behaving. Left clicks on the icon do nothing, while right clicking brings a menu with one entry, but the text is invisible.

Is anyone else having the same problems?

Any clue if this is a MATE issue, Fedora issue, or just something unique to my system?

It would be nice if someone running Fedora and/or MATE could confirm if they have this issue.

A Synergy developer has issues with how synergy-2.0.0-5.fc30.src.rpm has been packaged in Fedora’s repo:

Is anyone willing to try sudo dnf install synergy and synergy to see if they get the same errors in server mode?

It could be just the issue with the package in repositories. For synergy I would recommend downloading official release from there site and installing that.

They provide rpm package under “CentOS 7.5” download option. Should work normally on Fedora.

Though, to be honest, ever since they’ve released 2.x software dipped down in quality quite substantially and I was never able to get it working to my liking. Always some issues with it. While 1.x worked flawlessly :slight_smile:

I tried installing the synergy package on Gnome Shell, and can confirm the problem is not just on MATE.

Compiling 1.10 from source worked without issue, but the problem is present when compiling 2.0.0.