System Freeze after upgrading from Fedora 32 to 34

Hello everyone,

I new in the community although i have been using Fedora for more than 10 years now. I never needed help beside the documentation until now. I upgraded my system few week-end ago and i suddendly get whole system freeze with no acces to other terminal (like tty3), but the sound keeps working. Everytime i have to do a hard shutdown.
This happend when playing video on youtube, opening maps in firefox (google maps for exemple), or doing some video conference.

My CPU is an Intel i3 skylake with i.915 integrated graphic who are known to cause some freeze similar to the one i have. Indeed in the system log i have some error message just before the crash.

 kernel: i915 0000:00:02.0: [drm] Resetting rcs0 for preemption time out
 kernel: i915 0000:00:02.0: [drm] Renderer[2517] context reset due to GPU hang
 kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 9:1:85df1eff, in Renderer [2517]
 kernel: GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
 kernel: Please file a _new_ bug report at https://gitlab.freedesktop.org/drm/intel/issues/new.
 kernel: Please see https://gitlab.freedesktop.org/drm/intel/-/wikis/How-to-file-i915-bugs for details.
 kernel: drm/i915 developers can then reassign to the right component if it's not a kernel issue.
 kernel: The GPU crash dump is required to analyze GPU hangs, so please always attach it.
 kernel: GPU crash dump saved to /sys/class/drm/card0/error
 kernel: rfkill: input handler enabled
kernel: i915 0000:00:02.0: [drm] GPU HANG: ecode 9:0:00000000
kernel: i915 0000:00:02.0: [drm] Resetting rcs0 for stopped heartbeat on rcs0
kernel: i915 0000:00:02.0: [drm] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
kernel: i915 0000:00:02.0: [drm] Resetting chip for stopped heartbeat on rcs0
nautilus[13406]: connect() failed
kernel: i915 0000:00:02.0: [drm] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
kernel: i915 0000:00:02.0: [drm] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}

In other forum i have see that adding i915.enable_psr=0 in the grub config could help solve the problem but that is not the case for me. Did anyone know if there is another grub option, to help prevent this freeze to happening ?

Here is some documentation i read :

Tanks in advance for your help,

Hi there, this sounds not so good.

Does echo $WAYLAND_DISPLAY give an output? If yes, you could try to start an x-session, like described here:

https://docs.fedoraproject.org/en-US/quick-docs/configuring-xorg-as-default-gnome-session/

1 Like

Hi Huben, thanks for your reply.
echo $WAYLAND_DISPLAY give me : wayland-0
I switched to x-session and after 2 day of testing I had at leat 2 or 3 whole system freeze. They happen when watching youtube video or using election app. The only thing taht changed is that there is no longer traces of the freeze in journalctl -b-1.

So logging just stopped at all because of the freeze or logging continues but the error messages disappeared?

Did you also change the default session, like in point “Changing the default GNOME session via configuration file”?

1 Like

Yes i have change the default GNOME session.

For the logging it stopped because of the freeze. So there no trace of any log or warning message after the freeze. The logs only restart at boot after the hard shutdown.

Sorry, I have no further idea.
Did you do all those suggested thinks in your link, including building kernel modules etc?

1 Like

running skylake i5 and i915 (with bootparam “i915.enable_guc=2” => FW gets loaded).
all I can say you’re not alone with this bug.
I’ve seen bug reports, but I currently can’t find them anymore.
slightly remembering it was discussed on kernel mailling lists.
So I guess/hope it’s fixed with kernel 5.13.
it seems to me the occurence of this hang gets lower with higher version of 5.12.
currently running homebrewed vanilla 5.12.11

1 Like

@huben I have not try to build kernel modules, it’s too complicated for me (I don’t have any experience in building kernel). If you have an easy tutorial i will try.

@sixpack13 For sure the update have improved the situation but it still occuring on a daily basis for me. It will be good if it’s fixed in 5.13. Does “i915.enable_guc=2” can deacrease the freeze occurence ?

I don’t know cause I’m running it all the time mostly for power save feature which the FW also activates - IIRC-
see:

I only can say: it seems to get better with newer 5.12-kernels and likely mesa updates.
when I have had 1 or 2 hungs with ~5.12.1 each day I now see none or 1 per week with 5.12.12 running xorg (not wayland)

+++ EDIT +++
running 5.13-rc7 since a week and 5.13 since yesterday: NO hung so far - knock(ing) wood -

2 Likes