Terminator Windows Not Visible in Gnome Activities

I need some advanced terminal emulator features for my work so I use Terminator. I’ve setup a custom keyboard shortcut to launch a new instance (super + enter).

When I use this keyboard shortcut or launch a new terminator window from the activities overview, the first window I open does not appear in the activities overview, and cannot be selected via for alt + tab.

However, if I open multiple windows using the keyboard shortcut (activities won’t launch additional instances by default), the second window and beyond does appear in the activities overview. If I close a window, this restarts so the next window will not be visible, but subsequent window will be visible.

Is there something I’ve misconfigured on my system? Is this a known bug I just can’t seem to find? I’m happy to pull logs and/or provide more detail if my current description is not adequate.

I also use terminator .

For Alt-tab, gnome only cycle between “Programs”. To cycle between different windows of the same program, at least for terminator, I need to use

alt-`

It is the same to start second terminator window by “Activities, new windows”, or using terminator's default shortcut Ctrl-Shift-I .

1 Like

The issue I’m having is not switching between Terminator windows. The issue I’m having is that the first terminator window I open does not appear as an option for alt+tab or activities preview.

I just defined “Super+Enter” as gnome-shell shortcut to run terminator.

I can see terminator in activities after using “Super+Enter” to launch it.
Same if I launch with Activities.

I do not have third party gnome plugins installed, not sure if it makes a difference.

I did try to reproduce your problem, but I could not.
Have you tried to go thru the setting of terminator? There it has an option “hide from taskbar” could it be that this option causes the problem?

As I mentioned I can’t reproduce your problem. Try to create a new profile for the terminator and use this as default. Does this change something?

Creating a new user and check if you have the same behavior would prove if you have a problem with your profile who causes this “hiding first terminator window”…

1 Like

Wow. Sure enough “hide from taskbar” was the issue. I didn’t consider a Terminator setting. While I don’t recall enabling that setting it’s possible It was something I did in the past.

Thanks for the solution.

1 Like