TKL keyboard function keys not detected

Sooo I got myself a nifty new little keyboard and I am having a bit issues getting some of the keys to work; more specifically, the function keys (F1-F12).

The keyboard model is a Keychron K3 and this keyboard is layered (you have to press the Fn button to access some keys). The factory setting is that you have to hold the Fn key to enable a function key, or else it will adjust e.g. brightness/sound etc. If you press Fn + X + L for four seconds, it will set the default to the function keys. Now, on the backside of the keyboard there are a two switches: one to toggle between modes and the other one to choose the OS. Needless to say, Linux is not one of the options (:angry:).

Here is what happens: if I set the layout to ‘Win/Android’ the function keys do not work, neither if I press Fn, nor if I switch the layout to have the function keys as default.
If I choose Mac/iOS, turn off the keyboard and turn it back on, the function keys work, but then the Super-key does not work. I have tested this out using an online keyboard detector.
I have thought about setting the keyboard to Mac in the OS itself, but I do not know how to do this. I’m using Fedora 33 Workstation

Any help is greatly appreciated :blush:

Are you using Gnome-Desktop ?

1 Like

Yes, I do.

Maybe this helps:

/dev/schnouki – How to use a Keychron K2/K4 USB keyboard on Linux

2 Likes

This worked! Thanks a lot :partying_face:

1 Like