Touchpad functions are missing after every cold-start

,

I didn’t even boot windows when I got the laptop :sweat_smile:.

I don’t remember having this issue when I had Manjaro installed, but i was on 5.14 or 5.15 kernel

the latest Manjaro Gnome release works on 5.15.x

Windows are the things to look out of or am I wrong? :stuck_out_tongue_winking_eye:

Since I’ve been busy renovating and refurbishing for the last three quarters of a year, I dug into my memories a bit.

Eventually I installed Fedora 35 and went kernel version by kernel version with dozens of cold starts, ending up with the following.

Fedora 35 with kernel version ‘5.16.20’ works great, the next version ‘5.17.2’ immediately kills the touchpad with the aforementioned phenomenon.

Only a “reboot” or a switch to “standby” brings the function back.

That’s a good find, at least we know its 100% a kernel issue now.

try to boot up with a fedora vanilla-kernel,
i try to perceive every possibility for a solution :face_with_diagonal_mouth:

[coffee@coffeepad ~]$ uname -a
Linux coffeepad 5.19.0-0.rc3.27.vanilla.1.fc35.x86_64 #1 SMP PREEMPT_DYNAMIC Mon Jun 20 18:56:14 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

without success.

[coffee@coffeepad ~]$ dmesg -t |grep elantech
psmouse serio1: elantech: synaptics_send_cmd query 0x01 failed.

directly went from “Suspend” after the “cold-start”.

[coffee@coffeepad ~]$ dmesg -t |grep elantech
psmouse serio1: elantech: synaptics_send_cmd query 0x01 failed.
psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x7f3001)
psmouse serio1: elantech: Synaptics capabilities query result 0x90, 0x18, 0x0f.
psmouse serio1: elantech: Elan sample query result 00, 80, c9
psmouse serio1: elantech: Elan ic body: 0x10, current fw version: 0x3
psmouse serio1: elantech: Trying to set up SMBus access
psmouse serio1: elantech: SMbus companion is not ready yet

Have you created a bug report at https://bugzilla.redhat.com/ ?

Yes!

1 Like

Just replied on there, reporting I’ve got the same problem.