Touchpad issues on Lenovo IdeaPad 5 14IIL05 2-in-1

First-time Fedora user. Setup dual-boot Win-10 & Fedora-34. Initially all appeared fine, but now the touchpad is misbehaving. I’ll try to describe what I do know.

  1. When I boot to the login prompt, here the touchpad (at least the cursor/pointer) is working. Since there’s nothing to scroll at login prompt, full touchpad operation not verified.
  2. After login is complete, touchpad is not responding. Thankful for the 2-in-1 touch-screen capability! :wink:

Let me take a step back. After initial success with Fedora dual-boot setup, I installed a few apps - Chromium, Citrix Workspace (so I can also connect to work from Fedora). Then I was keen to try tablet mode while in Fedora, and thereafter touchpad ceased functioning (except during login). I then noticed that there were software updates available (about 27) and was hopeful the updates would address my touchpad issues. Updates were installed and then I rebooted. I will add that on one occasion when awoke my laptop from sleep mode, the touchpad was once again operational. I have been unable to repeat this so far.

As a newbie, I appreciate any pointers to diagnose and restore my touchpad to normal functionality.

Note: None of this touchpad (mis)behaviour is exhibited in the Win-10 image.

Following some other hits related to touchpad issues, I attempted (unsuccessfully) to manually enable the touchpad & mouse:

[root@fedora ~]# xinput enable “$tp”
WARNING: running against an Xwayland server. See xinput man page for details.
unable to find device MSFT0001:00 04F3:3140 Touchpad
[root@fedora ~]# xinput enable “$mouse”
WARNING: running against an Xwayland server. See xinput man page for details.
unable to find device MSFT0001:00 04F3:3140 Mouse
[root@fedora ~]# grep -i name /proc/bus/input/devices

N: Name=“MSFT0001:00 04F3:3140 Mouse”
N: Name=“MSFT0001:00 04F3:3140 Touchpad”

Given the Xwayland warning msg & associated xinput man page blurb, what is the appropriate way to approach this situation?

An old Wayland entry (Fedora 24!) hinted that the setup icon available at boot login password prompt allows for selectable Wayland (just ‘Gnome’ mode) or ‘Gnome on Xorg’. Trying the Xorg mode allowed the above xinput cmds to work, but seemingly to no effect. However, I forced toggle of laptop mode to tablet mode (folding screen back) & returning to laptop mode again. Now touchpad is functional once more!

It seems I may have struck a random (hardware? software?) glitch that resulted in the keyboard operating in laptop mode while the touchpad remained in tablet mode (ie. off). Would be nice if there was a valid explanation for entering this inconsistent state. But, for now, it’s a relief for some normality to return.