Touchpad stops responding at random

Hello everyone,

My touchpad stops responding at random. I’m using, whether I’m working, or just browsing, the touchpad stops responding, for 10-30 seconds, and then goes back to normal. It’s an annoyance more than anything. Not sure if this happens in other distros, I often try other distros, but end up back at Fedora again, and I have a mouse for most of the time.

I don’t know exactly how to debug this, journalctl doesn’t show anything in particular related to it.

OS: Fedora 33 (Workstation Edition) x86_64
Host: 81FV Lenovo Legion Y530-15ICH
Kernel: 5.10.19-200.fc33.x86_64
Uptime: 11 hours, 11 mins
DE: GNOME 3.38.3
WM: Mutter
WM Theme: vimix-laptop-ruby
Theme: vimix-laptop-ruby [GTK2/3]
Icons: Ruby [GTK2/3]
Terminal: tilix
CPU: Intel i5-8300H (8) @ 4.000GHz
GPU: Intel CoffeeLake-H GT2 [UHD Graphics 630]
GPU: NVIDIA GeForce GTX 1050 Mobile
Memory: 3827MiB / 15876MiB

The machine is fully updated. The only extras I installed related to the system/drivers, as far as I remember, were the nvidia drivers, and virtualbox akmod. As you may guess, secure boot is off.

Can you help me track down this bug?

1 Like

Your not alone with your problem … might be a good idea to look also in the Lenovo community.

https://support.lenovo.com/us/en/solutions/ht506481-touchpad-becomes-nonfunctional-and-the-mouse-may-disappear-from-the-screen-yoga-720-12

It seams that there is needed a firmware update. Is your device up to date with this touchpad firmware ?

1 Like

I forgot to mention, this isn’t an issue in Win10. I have dual boot and I don’t have this in it, and looking at my laptop’s page, there’s no drivers for the touchpad, nor even for win10. On windows, under pc components, it says it’s a “HID-compliant touch pad”.

On linux, I see this on /proc/bus/input/devices:

I: Bus=0018 Vendor=06cb Product=cd5f Version=0100
N: Name=“SYNA2B46:00 06CB:CD5F Touchpad”
P: Phys=i2c-SYNA2B46:00
S: Sysfs=/devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-1/i2c-SYNA2B46:00/0018:06CB:CD5F.0001/input/input8
U: Uniq=
H: Handlers=mouse1 event5
B: PROP=1
B: EV=1b
B: KEY=e520 30000 0 0 0 0
B: ABS=2e0800000000003
B: MSC=20

Digging around, I found a guy suggesting to install xserver-xorg-input-synaptics, but given there’s no such package on Fedora, I’ve installed xorg-x11-drv-synaptics-legacy. Now I’ll see if this does the trick or not. It happens at random, and in short intervals, so I can’t tell right away. The packages xorg-x11-drv-libinput and xorg-x11-drv-evdev were already installed by the way.

So this seems to be the fix, installing xorg-x11-drv-synaptics-legacy. At least for the entire day today I didn’t had that bug.

With that said, the default config is rather bad. It’s functional, granted, but not ideal, so here’s my config:
/usr/share/X11/xorg.conf.d/70-synaptics.conf

Section “InputClass”
Identifier “touchpad catchall”
Driver “synaptics”
MatchIsTouchpad “on”
MatchDevicePath “/dev/input/event*”
#Added lines:
Option “TapButton1” “1”
Option “TapButton2” “3”
Option “TapButton3” “2”
#Option “VertEdgeScroll” “on”
Option “VertTwoFingerScroll” “on”
#Option “HorizEdgeScroll” “on”
Option “HorizTwoFingerScroll” “on”
Option “EmulateTwoFingerMinZ” “40”
Option “EmulateTwoFingerMinW” “8”
Option “MaxTapTime” “125”
#Negative values for natural scrolling
Option “VertScrollDelta” “-51”
Option “HorizScrollDelta” “-51”
#Coasting
Option “CoastingSpeed” “5”
Option “CoastingFriction” “31”
EndSection

I only edited the first section, left the rest untouched. I might fiddle with options a bit more, but as it is here, it satisfies my needs.

For future reference for others, here’s a couple links that can help:
https://www.x.org/releases/X11R7.6/doc/man/man4/synaptics.4.xhtml
https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Natural_scrolling

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.