Tpm error on booting

Hi, after install fc 37 rc, but I got the same problem also with 36, on booting I have error on tpm and fedora doesn’t start

Press e for edit grub and add:

rmmod tpm

in this way I may boot in order to add to /boot/grub2/grub.cfg following line:

rmmod tpm

in this way I may reboot without any problem, but if I update grub I return to 1st point.

is there any solution for fix permanent this?

At the moment I’m using Endeavours as only system, I would like to switch to Fedora but not at this conditions

My notebook is Asus VD753 (I think) and in bios there isn’t any reference on how disable tpm and I can’t update bios, secure boot is disabled.

I hope there’s a solution.

Rob.

I don’t know about the tpm and bios. Most UEFI bios I have looked at have the option under the security tab to disable tpm but of course I cannot see yours to know.

I did a quick search on how to prevent kernel modules from loading and found several links.

Blacklisting modules on Linux | Network World.
fedora - Unable to disable kernel module - Unix & Linux Stack Exchange

Based on those and on what I already knew you should be able to do
sudo echo "blacklist tpm" > /etc/modprobe.d/blacklist-tpm.conf then reboot.
It may require that you also run sudo dracut --force to recreate the initramfs so the entry is available in the initrd image for the boot before the root file system is mounted.

Thank you for your answer, I’ve tried as you told me but after reboot I’ve the same problem,
I don’t how permanent add to /boot/grub2/grub.cfg :
rmmod tpm

for avoid that at every grub update that line is removed.

Do you know how do it?

sudo grubby --args="rd.driver.blacklist=tpm modprobe.blacklist=tpm" --update-kernel=ALL

Edit:
For your blacklist-tpm.conf did you also add:

"install tpm /bin/false"
1 Like