Trouble with nvidia on Dell M4800 laptop and Fedora 35

Had no problems with nvidia on fedora 33 and 34 recently i upgraded to fedora 35 (clean install of kde version) and after driver install at boot i get message nvidia kernel module not found falling back to …
So far tried removing it all and using automatic driver install tool and that didn’t work …forcing akmods as some posts have suggested to no avail. Specific card is NVIDIA GK106GLM [Quadro K2100M] (rev a1)…if anyone can provide some idea on maybe why the kernal module does not build or why driver does not work i would be greatfull…i have only been using linux a few years now so still a lot of learning for me.

Please post the output of dmesg | grep -E 'secure|nvidia'

There have been changes in the kernel and with secure boot enabled f35 will not load the nvidia drivers. F33 & 34 mostly ignored secure boot. This will tell us if secure boot is the issue.

There have also been changes in the latest nvidia driver version in f35 that dropped support for some older cards, but we need to look at the boot issue first.

Heres the output minus thin hyperlinks

[    0.000000] Command line: BOOT_IMAGE=(hd2,gpt2)/vmlinuz-5.14.16-301.fc35.x86_64 root=UUID=a6efccef-fd38-4728-9e77-a7748f769b30 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[    0.000000] secureboot: Secure boot disabled
[    0.007622] secureboot: Secure boot disabled
[    0.117635] Kernel command line: BOOT_IMAGE=(hd2,gpt2)/vmlinuz-5.14.16-301.fc35.x86_64 root=UUID=a6efccef-fd38-4728-9e77-a7748f769b30 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[   16.784899] nvidia: loading out-of-tree module taints kernel.
[   16.784915] nvidia: module license 'NVIDIA' taints kernel.
[   16.800682] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[   16.821944] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
            
[   16.822852] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   17.120398] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
            
[   17.128055] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   34.764286] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
             
[   34.765093] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   34.814515] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
              
[   34.815226] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   52.580716] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
             
[   52.581307] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   52.741935] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
           
[   52.742663] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   52.998285] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
           
[   52.999235] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   53.312967] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
              
[   53.313806] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   53.810522] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
            
[   53.811297] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   53.872405] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
             
[   53.873329] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   55.861476] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
            
[   55.863683] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   56.298832] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
           
[   56.299748] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   56.355556] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
         
[   56.357981] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   56.402174] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
        
[   56.402955] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[   56.440901] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
             
[   56.441563] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[  262.552635] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
               
[  262.553508] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[ 1609.018820] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
            
[ 1609.019595] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[ 1609.627758] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
         
[ 1609.628838] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[ 1609.689821] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
           
[ 1609.690823] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235
[ 2476.167621] CIFS: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3.1.1), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3.1.1 (or even SMB3 or SMB2.1) specify vers=1.0 on mount.
[ 2778.226288] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
            
[ 2778.226924] nvidia-nvlink: Unregistered the Nvlink Core, major device number 235

So we know secure boot is disabled. That is good.

What is your gpu? inxi -Gzx
What driver version is installed? sudo dnf list installed *nvidia*
Are any of the nvidia modules loaded? lsmod | grep -E 'nvidia|nouveau'

output requested

$ inxi -Gzx
Graphics: Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0
Device-2: NVIDIA GK106GLM [Quadro K2100M] vendor: Dell driver: N/A bus-ID: 01:00.0
Display: wayland server: X.Org 1.21.1.3 compositor: kwin_wayland driver: loaded: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2) v: 4.6 Mesa 21.2.5 direct render: Yes

Installed Packages
akmod-nvidia.x86_64 3:495.44-1.fc35 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-5.14.16-301.fc35.x86_64.x86_64 3:495.44-1.fc35 @@commandline
nvidia-persistenced.x86_64 3:495.44-1.fc35 @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64 3:495.44-1.fc35 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64 3:495.44-4.fc35 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64 3:495.44-4.fc35 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64 3:495.44-4.fc35 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64 3:495.44-4.fc35 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64 3:495.44-4.fc35 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64 3:495.44-4.fc35 @rpmfusion-nonfree-nvidia-driver

lsmod | grep -E ‘nvidia|nouveau’
nouveau 2400256 0
mxm_wmi 16384 1 nouveau
drm_ttm_helper 16384 1 nouveau
i2c_algo_bit 16384 2 i915,nouveau
ttm 86016 3 drm_ttm_helper,i915,nouveau
drm_kms_helper 303104 2 i915,nouveau
drm 630784 21 drm_kms_helper,drm_ttm_helper,i915,ttm,nouveau
wmi 36864 6 dell_wmi,wmi_bmof,dell_smbios,dell_wmi_descriptor,mxm_wmi,nouveau
video 57344 4 dell_wmi,dell_laptop,i915,nouveau

That info tells me you are on F35, have all the nvidia 495.44 driver packages installed but only have nouveau drivers active.

I also see the kernel command line does not have the normal parts that block nouveau and load nvidia so that is likely the issue.

Since this was a clean new install of f35 I have to ask how you installed the nvidia drivers? I see they appear to have come from rpmfusion but normally when they are installed from rpmfusion they make all the changes needed for proper operation. In your case that seems to have not fully occurred.

We can try to fix that with a reinstall of the nvidia drivers sudo dnf remove kmod-nvidia && sudo dnf reinstall *nvidia* then a reboot
If that fails then we can do the repairs manually.

If the reinstall fixes the problem the kernel command line seen above with the output of the dmesg command you posted should have 3 additional option segments added. Those should be

rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 

We can manually insert that, but hopefully the reinstall of the nvidia drivers will fix that for you.

After the reinstall please post the output of cat /etc/default/grub so we can see if the mods that should take place actually did.

Also, when posting text please use the button above ( </> ) to surround the text with the preformatted text symbols to keep it formatted as seen on your screen.

I installed the drivers as described as the Nvida how to from the rpm fusion website via DNF.

and the grub command did seem to get updated as expected during the process.
currently it looks like this:
GRUB_CMDLINE_LINUX=“rd.driver.blacklist=nouveau modprobe.blacklist=nouveau rhgb quiet rd.driver.blacklist=nouveau mo
dprobe.blacklist=nouveau nvidia-drm.modeset=1”

The question then arises, ‘Does the machine now load the nvidia drivers at boot?’

You can see if it is attempting to, and if the command line from /etc/default/grub is passed to the kernel at boot time by holding the shift key at power on until the grub menu displays. Then press ‘e’ for edit and look at the text displayed. If the line that begins with ‘linux’ contains the portions that we just discussed then it should load the nvidia modules and not load the nouveau modules during boot.

If it has that portion in the ‘linux’ line of grub but still fails to load the nvidia modules then it may be a bit deeper issue.

Let us know please.

ok I think its working now…kind of

so i removed everything and manually installed a different version.

For kernel version 5.14 the drivers must be patched so i followed instructions from here.
inttf NVIDIA 435.xx, 390.xx, 418.xx, 340.xx Patcher for Kernel 5.14/5.13/5.12 [BASH Script] – If Not True Then False and then for the install i followed Fedora 35/34/33 NVIDIA [495.44 / 470.86 / 390.144 / 340.108] Drivers Install Guide – If Not True Then False

fedora ~]$ sudo dnf list installed *nvidia*

Installed Packages
akmod-nvidia-390xx.x86_64                                                                                             3:390.144-3.fc35                                                                      @rpmfusion-nonfree              
kmod-nvidia-390xx.x86_64                                                                                              3:390.144-3.fc35                                                                      @rpmfusion-nonfree              
kmod-nvidia-390xx-5.14.16-301.fc35.x86_64.x86_64                                                                      3:390.144-3.fc35                                                                      @@commandline                   
nvidia-persistenced.x86_64                                                                                            3:495.44-1.fc35                                                                       @rpmfusion-nonfree-nvidia-driver
nvidia-settings-390xx.x86_64                                                                                          390.144-2.fc35                                                                        @rpmfusion-nonfree              
xorg-x11-drv-nvidia-390xx.x86_64                                                                                      3:390.144-2.fc35                                                                      @rpmfusion-nonfree              
xorg-x11-drv-nvidia-390xx-cuda.x86_64                                                                                 3:390.144-2.fc35                                                                      @rpmfusion-nonfree              
xorg-x11-drv-nvidia-390xx-cuda-libs.x86_64                                                                            3:390.144-2.fc35                                                                      @rpmfusion-nonfree              
xorg-x11-drv-nvidia-390xx-devel.x86_64                                                                                3:390.144-2.fc35                                                                      @rpmfusion-nonfree              
xorg-x11-drv-nvidia-390xx-kmodsrc.x86_64                                                                              3:390.144-2.fc35                                                                      @rpmfusion-nonfree              
xorg-x11-drv-nvidia-390xx-libs.x86_64                                                                                 3:390.144-2.fc35                                                                      @rpmfusion-nonfree              

fedora ~]$ lsmod | grep -E 'nvidia|nouveau'
nvidia_drm             57344  3
nvidia_modeset       1060864  2 nvidia_drm
nvidia_uvm            929792  0
nvidia              15884288  85 nvidia_uvm,nvidia_modeset
drm_kms_helper        303104  2 nvidia_drm,i915
drm                   630784  8 drm_kms_helper,nvidia_drm,i915,ttm
ipmi_msghandler       118784  2 ipmi_devintf,nvidia


after the reboot hit the black screen wall so i switch to tty and attempted startx …didnt work

so next i did sudo nano /etc/X11/xorg.conf
and deleted all lines inside now startx brings up plasma.

still cant boot into graphical mode so i added a 3 to the end of the grub command to force booting to text mode for now and then i use startx after logon to start the desktop

seems like driver is not working with wayland only x11

when i start wayland from tty via “dbus-run-session startplasma-wayland” the nvidia settings panel says the driver is not loaded.

not sure why i get the black screen when trying to boot into the graphical environment but booting into tty and starting desktop command line is work around for now.