Troubles with dnf / python dependencies or dnf is brocken

Glad to hear! :smile:
Now we should be able to restore most of the missing files like this:

sudo dnf --refresh upgrade
sudo dnf reinstall python\*
1 Like

That’s done :blush: So now it should be everything okay?

2 Likes

Check again to be sure:

sudo rpm --verify --all
1 Like

It’ s almost fine with sudo dnf --refresh upgrade, just some packages with conflicts:

Проблема 1: package glibc-headers-2.29-9.fc30.i686 requires glibc = 2.29-9.fc30, but none of the providers can be installed

  • cannot install both glibc-2.29-22.fc30.x86_64 and glibc-2.29-9.fc30.x86_64
  • cannot install both glibc-2.29-9.fc30.x86_64 and glibc-2.29-22.fc30.x86_64
  • cannot install both glibc-2.29-22.fc30.i686 and glibc-2.29-9.fc30.i686
  • cannot install both glibc-2.29-9.fc30.i686 and glibc-2.29-22.fc30.i686
  • cannot install the best update candidate for package glibc-headers-2.29-9.fc30.i686
  • cannot install the best update candidate for package glibc-2.29-9.fc30.x86_64
  • cannot install the best update candidate for package glibc-2.29-9.fc30.i686
    Проблема 2: problem with installed package glibc-headers-2.29-9.fc30.i686
  • glibc-headers-2.29-9.fc30.i686 has inferior architecture
  • cannot install both glibc-headers-2.29-22.fc30.x86_64 and glibc-headers-2.29-9.fc30.x86_64
  • cannot install both glibc-headers-2.29-9.fc30.x86_64 and glibc-headers-2.29-22.fc30.x86_64
  • cannot install the best update candidate for package glibc-headers-2.29-9.fc30.x86_64
    ================================================================================
    Package Architecture Version Repository Size
    ================================================================================
    Пропуск пакетов с конфликтами:
    (добавьте «–best --allowerasing» к командной строке для их принудительного обновления):
    glibc i686 2.29-22.fc30 updates 3.9 M
    glibc x86_64 2.29-22.fc30 updates 4.0 M
    glibc-headers x86_64 2.29-22.fc30 updates 473 k
1 Like

Try this way:

sudo dnf clean all
sudo dnf --refresh --best --allowerasing upgrade

If the issue persists, you can temporary remove it as it is not critical:

sudo dnf remove glibc-headers

Then show the output:

sudo dnf check all
1 Like

It’ s no output sudo dnf check all

But there are probably some missing packages: https://paste.fedoraproject.org/paste/~qUvEQqhz8OZJiM24XnUagQ

Is it critical output to sudo rpm --verify --all? Or is it not that critical?

1 Like

This is fine.

Sorry, the link doesn’t work for some reason.
Could you repost it?

1 Like

Here is a link again:
https://paste.fedoraproject.org/paste/sFMGbcl4t4sdgOisO-6qlg

1 Like

To be able to restore the files, we need to make sure that we have the latest package versions, otherwise the reinstall command may fail.

sudo dnf --refresh --best --allowerasing upgrade

What does this say?

1 Like

Output to sudo dnf --refresh --best --allowerasing upgrade:

Updated:
adwaita-qt4-1.1.0-4.fc30.x86_64
adwaita-qt5-1.1.0-4.fc30.x86_64
kernel-headers-5.2.13-200.fc30.x86_64
kernel-tools-libs-5.2.13-200.fc30.x86_64
libmodulemd-2.8.0-1.fc30.x86_64
libselinux-2.9-3.1.fc30.i686
libselinux-2.9-3.1.fc30.x86_64
libselinux-utils-2.9-3.1.fc30.x86_64
minizip-compat-1.2.11-18.fc30.x86_64
python2-libselinux-2.9-3.1.fc30.x86_64
python3-libselinux-2.9-3.1.fc30.x86_64
sos-3.8-1.fc30.noarch
zlib-1.2.11-18.fc30.i686
zlib-1.2.11-18.fc30.x86_64
zlib-devel-1.2.11-18.fc30.x86_64
Installed:
kernel-5.2.13-200.fc30.x86_64
kernel-core-5.2.13-200.fc30.x86_64
kernel-devel-5.2.13-200.fc30.x86_64
kernel-modules-5.2.13-200.fc30.x86_64
kernel-modules-extra-5.2.13-200.fc30.x86_64

Deleted:
kernel-5.1.19-300.fc30.x86_64
kernel-core-5.1.19-300.fc30.x86_64
kernel-devel-5.1.19-300.fc30.x86_64
kernel-modules-5.1.19-300.fc30.x86_64
kernel-modules-extra-5.1.19-300.fc30.x86_64

1 Like

Now we can try to reinstall the python-related packages:

sudo dnf reinstall python\*
1 Like

It’s done! Thank you very much again :slight_smile:

1 Like

There were also some missing files unrelated to python in your last verification log:

Summary

You can restore them as well:

for FILE in \
/var/lib/clamav/daily.cvd \
/var/log/audit \
/var/log/blivet-gui \
/var/log/cluster \
/var/log/firebird \
/var/log/firebird/firebird.log \
/var/log/glusterfs \
/var/log/httpd \
/var/log/libvirt \
/var/log/libvirt/qemu \
/var/log/lightdm \
/var/log/pluto \
/var/log/pluto/peer \
/var/log/ppp \
/var/log/samba \
/var/log/samba/old \
/var/log/speech-dispatcher \
/var/log/squid \
/var/log/sssd \
/var/log/swtpm/libvirt/qemu \
/var/log/tor \
/var/log/vbox;
do sudo dnf -y reinstall "${FILE}"; done

It might be critical for the services which need the proper place to save the logs.
Also make sure you have enough free space for the root file system to avoid problems in the future.

2 Likes