Troubleshooting graphics card

It seems like my (NVIDIA GTX 1650) graphics card isn’t working on my fedora laptop while trying to play games. They’re unplayably slow and appear to be running on integrated graphics.

I get: nvidia-smi -L
GPU 0: GeForce GTX 1650 (UUID: GPU-2da4c1a8-df32-67f2-778c-a228dc038123)
[bharland@localhost ~]$

nvidia-settings gives me:
(nvidia-settings:10003): GLib-GObject-CRITICAL **: 22:02:20.093: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

ERROR: nvidia-settings could not find the registry key file. This file should have been
installed along with this driver at
/usr/share/nvidia/nvidia-application-profiles-key-documentation. The application
profiles will continue to work, but values cannot be prepopulated or validated, and
will not be listed in the help text. Please see the README for possible values and
descriptions.

Can anybody suggest a next step?

Hi @bharland welcome to the community

Can you provide the followed extra information so that the members of the community can provide a better help.

  • How did you install the Nvidia driver and from Where?

  • Did the installation of the driver succeed rightly or this did show some warnings/errors?

  • Do you have a hybrid CPU+GPU and what one?

Post here the output of these commands with the option “preformatted text”

Open a terminal and follow i order

dnf list --installed *nvidia*

lscpu

lspci -vnn | grep -i VGA\ compatible\ controller -A 12

Now let’s install a package to provide a bit more information called lshw with the command

sudo dnf install lshw

Now continue providing the information:

Let’s see the GPU is in use

sudo lshw -c display

Let’s see hardware acceleration:

glxinfo | grep -i OpenGL

Extra information too

glxinfo -B

Once you have provided the information we will have a better starting point.

Regards.

Thanks for your response, xtym!

I installed the Nvidia driver from RPM fusion. I’m afraid my answer to your other two questions is a bit vague – the driver installation wasn’t smooth but I can’t remember what errors I encountered and I hadn’t heard of hybrid GPU/CPU’s but I think I don’t have one.

**dnf list --installed nvidia **
nstalled Packages
akmod-nvidia.x86_64 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia.x86_64 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-5.3.12-200.fc30.x86_64.x86_64 3:440.36-1.fc30 @@commandline
kmod-nvidia-5.3.15-200.fc30.x86_64.x86_64 3:440.36-1.fc30 @@commandline
kmod-nvidia-5.3.6-200.fc30.x86_64.x86_64 3:440.36-1.fc30 @@commandline
nvidia-persistenced.x86_64 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.i686 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64 3:440.36-1.fc30 @rpmfusion-nonfree-nvidia-driver

lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 39 bits physical, 48 bits virtual
CPU(s): 8
On-line CPU(s) list: 0-7
Thread(s) per core: 2
Core(s) per socket: 4
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 158
Model name: Intel® Core™ i5-9300H CPU @ 2.40GHz
Stepping: 10
CPU MHz: 919.291
CPU max MHz: 4100.0000
CPU min MHz: 800.0000
BogoMIPS: 4800.00
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 8192K
NUMA node0 CPU(s): 0-7
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse3
6 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc
art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulq
dq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2api
c movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid
_fault epb invpcid_single pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid ep
t_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid mpx rdseed adx smap clflushopt in
tel_pt xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window
hwp_epp md_clear flush_l1d

lspci -vnn | grep -i VGA\ compatible\ controller -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b] (prog-if 00 [VGA controller])
DeviceName: Onboard - Video
Subsystem: Dell Device [1028:08ea]
Flags: bus master, fast devsel, latency 0, IRQ 129
Memory at a2000000 (64-bit, non-prefetchable) [size=16M]
Memory at 80000000 (64-bit, prefetchable) [size=256M]
I/O ports at 5000 [size=64]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities:
Kernel driver in use: i915
Kernel modules: i915

00:04.0 Signal processing controller [1180]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem [8086:1903] (rev 07)

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1f91] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Dell Device [1028:08ea]
Flags: bus master, fast devsel, latency 0, IRQ 150
Memory at a3000000 (32-bit, non-prefetchable) [size=16M]
Memory at 90000000 (64-bit, prefetchable) [size=256M]
Memory at a0000000 (64-bit, prefetchable) [size=32M]
I/O ports at 4000 [size=128]
[virtual] Expansion ROM at a4000000 [disabled] [size=512K]
Capabilities:
Kernel driver in use: nvidia
Kernel modules: nouveau, nvidia_drm, nvidia

01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:10fa] (rev a1)

sudo lshw -c display

*-display
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:150 memory:a3000000-a3ffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:4000(size=128) memory:a4000000-a407ffff
*-display
description: VGA compatible controller
product: UHD Graphics 630 (Mobile)
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:129 memory:a2000000-a2ffffff memory:80000000-8fffffff ioport:5000(size=64) memory:c0000-dffff

glxinfo | grep -i OpenGL

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel® UHD Graphics 630 (Coffeelake 3x8 GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.1.8
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 19.1.8
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.1.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

glxinfo -B
name of display: :1
display: :1 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: Intel Open Source Technology Center (0x8086)
Device: Mesa DRI Intel® UHD Graphics 630 (Coffeelake 3x8 GT2) (0x3e9b)
Version: 19.1.8
Accelerated: yes
Video memory: 3072MB
Unified memory: yes
Preferred profile: core (0x1)
Max core profile version: 4.5
Max compat profile version: 3.0
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel® UHD Graphics 630 (Coffeelake 3x8 GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.1.8
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 19.1.8
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.1.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

Many thanks again!
Ben

I have a similar config as you. (9300H/UHD620/GTX1650) and I’m facing the same error.

nvidia-settings could not find the registry key file

I think somehow games are running on the UHD620. However, CUDA is running perfectly.

Well the problem of you bad graphic performance in games is because it:

Your system is using software acceleration via your integrated GPU (hybrid intel CPU) your system is not taking the nvidia driver don’t worry about this, it can be changed.

First let’s try see why this error you did commented before, I think it can come from secure boot because nvidia driver can not sign the modules of the kernel, Did you disable secure boot before you installed the driver?

Check it with this command:

dmesg | grep -i secure\ boot

You should see an output like this one where it is blaming as disable:

[jorge@f31 ~]$ dmesg | grep -i secureboot
[    0.000000] secureboot: Secure boot disabled

if you have secure boot enable you need disable secure boot to go one right installation of the driver.

So the first step is disable the secure boot and after if you see still issue remove the driver and reinstall this again you can uninstall accord rpmfusion indications https://rpmfusion.org/Howto/NVIDIA#Uninstall_the_NVIDIA_driver

And to reinstall you know how do it , always with secure boot disable don’t forget it ok?.

Your driver is the 400.31+ like you can in the link below that you should have optimus support by default https://rpmfusion.org/Howto/Optimus

What does it mean? It means than if you did an right installation, automatically the nvidia driver should is active to high loads (like games) and automatically change to intel integretad GPU to low load without that you need do something extra.

Let’s think that you did all ok but your OpenGL render is still Mesa DRI Intel® UHD Graphics 630 (Coffeelake 3x8 GT2) when you are running a game and you are having the same troubles in that case you can force the system to use the nvidia GPU as your primary GPU read it :

§ NVIDIA PrimaryGPU Support
https://rpmfusion.org/Howto/Optimus

NVIDIA PrimaryGPU Support

Before the Full optimus support, the only way to enable the NVIDIA driver was to set the NVIDIA GPU to be used by default. To recover this previous behaviour, you can use:

cp -p /usr/share/X11/xorg.conf.d/nvidia.conf /etc/X11/xorg.conf.d/nvidia.conf

And edit the file to use: Option “PrimaryGPU” “yes”

I think that it should solve your issue sorry I can not give any exemple about modification of files personally because i am not using a nvida card (amd user here).

One thing more that is very important before you install the nvidia driver is read the special notes to don’t miss anything:

https://rpmfusion.org/Howto/NVIDIA#Special_notes

Regards.

1 Like

Thanks again. I have:

dmesg | grep -i secure\ boot
[ 0.000000] secureboot: Secure boot disabled
[ 5.141036] Bluetooth: hci0: Secure boot is enabled

I looked at your Optimus link but I’m afraid I can’t quite make sense of it. Do I not have “full optimus support” on my Fedora 30? Just like you mentioned, I would love the GPU to become active under load while using integrated graphics when it isn’t. It this possible?

Looks like there it is unsure you have “disabled” secure boot. Did you disable it through of the bios? if you didn’t it is highly probably you have it enable. Look for your BIOS model and try disable, you will need go into the Bios to disable secure boot sometimes this option is hide under some submenu.

Look this picture is from a hp laptop (internet capture):

You should have it out the box, but looks like you can have a bad installation of the driver maybe caused for secure boot enable

NVIDIA PRIME Support

On Fedora 30 and later, with NVIDIA driver 440.31+, there is nothing else to be done beyound normal driver installation. But you can opt-in to enable Dynamic Power Management until this is set as the default in the NVIDIA driver.

Dynamic power management just does reference to different profiles of work in your Nvidia card. Because the nvidia card can work in more levels that only performance, one can fix low/medium/performance profile too. But it is something than you don’t need change.

Check for secure boot stuff.

Regards.

Ok, when I first enter UEFI it flashes “Secure Boot: OFF” and in the settings I have the “Secure Boot Enable” box unchecked, “Secure Boot Mode” is “Deployed Mode” and “Expert Key Management” has an “Enable Custom Mode” box unchecked. Is any of this helpful?

If my Nvidia driver was installed improperly, would you recommend uninstalling and reinstalling through dnf?

This one has a lot of options more than the mine, Secure boot is off and should be ok but it doesn’t should show the secure boot enable than we saw in the report before about the bluetooth (at least It is my thinking but not can be sure at all)

Deployed mode is the more secure mode of them but it doesn’t should take care from secure boot looks like disable.

https://qrl.dell.com/Files/en-us/Html/Manuals/T640/SystemSecuritySettings_Details=GUID-31B04039-7E2B-460A-820F-DA8E9B23A9A3=4=en-us=.html

It is reporting problem to register the key so it does my think that there was some problem trough it but looks like it is not a problem because the profiles will continue working.

If you did install via gnome-software it shouldn’t change anything if you did follow all indications from rpm fusion. I can not recommend it except if you wish check if all transitions goes ok. maybe the best solution is just fix the system to use how primary GPU the nvidia like indicated before whiler another users can contribute in this case, maybe they did solved it before (note than i have amdgpu not nvidia)

One last thing that i didn’t ask before is than you are running your session in xorg and not in wayland mode right?

Sorry I can not be more useful at this point, but lets see than others members can say about it.

Thanks xtym, I really appreciate the help you gave me. I couldn’t come close to installing the driver through Gnome softare. I would love to see that working, but I’ve never been able to get it to do anything right for me. I primarily run kde in xorg (I log into Gnome only to try to use Gnome software) – wayland working well is another thing I’m eager to see happen.

If I understand you correctly, I might try to get this profile key problem fixed some day when I have a lot of time and energy. A temporary solution would be to set the Nvidia GPU as my primary GPU which would be a power management problem, but I could play games.

Sure or maybe another user come here with one solution (I will still continue checking it out because I am interested and would like can help you more)

Exact but after than you did fix your Nvidia GPU as primary you can does it too if you have energy:

https://rpmfusion.org/Howto/Optimus

NVIDIA PRIME Support

On Fedora 30 and later, with NVIDIA driver 440.31+, there is nothing else to be done beyound normal driver installation. But you can opt-in to enable Dynamic Power Management until this is set as the default in the NVIDIA driver.

sudo -s dnf update cat > /etc/modprobe.d/nvidia.conf <<EOF # Enable DynamicPwerManagement # http://download.nvidia.com/XFree86/Linux-x86_64/440.31/README/dynamicpowermanagement.html options nvidia NVreg_DynamicPowerManagement=0x02 EOF

If you enable it, your nvidia card will work in differents modes according demanded load and it will use automatically different profiles low/medium charge/permormance etc. Like a normal GPU without take hand of your CPU+GPU integrated.

Edit1: but if you play CS:GO maybe you don’t want enable dynamic power management due some users did comment that sometimes while running the game it doesn’t called to performance mode in dynamic state and they have lag and tearing, in this case you can just delete the file than you did create or just don’t enable this mode dynamic power management.

Another thing is that if you use KDE desktop you can want uncheck the option of V-Sync to windows in full-screen mode in the window compositor of KDE. to don’t limite the fps at the refresh rate of your monitor if it is one of 60 Hz, but if you have tearing just enable again.

Regards.