Trying to set up openvpn fedora 33 - DNS and ipv6 issues

Where you able to use openvpn with an other OS but same ISP?

Yes I was using windows, and just disabled ipv6, changed dns, all works normally with the same ISP.

I checked the router from my ISP, in firewall there is no rules configured, do I have to configure some rule?

If it worked with windows it will work with Fedora too, but as mentioned above, Fedora has a own firewall.

If you are more comfortable with a GUI look for firewall under applications or type in terminal firewall-config , activate the service openvpn and restart the firewall firewall-cmd --reload

firewall-cmd --list-all shows you witch services are allowed pass the firewall.

Sorry, I was wrong about windows. I tested my girlfriend’s windows laptop and didn’t work, when I disabled ipv6 in control panel the DNS stopped too…

I don’t know what could be, but I recently changed my router, I put a second router in my home network, I think that is something wrong in the configuration of one of the routers… before, with my other windows PC I didn’t had problems :frowning:

1 Like

Recent changes should always be looked at first. Additionally, multiple routers, one behind another often introduce glitches that need ironed out to keep operations painless. Routing, dns, and other network related things can be affected.

Yes, I’ll try to reconfigure my router, unfortunately I need the second router, I live in another room ,outside the house, and need a cable connection for desktop and Wi-Fi for laptops and smartphones…
My router is a Asus router and I used auto configuration, I’ll try to set up manually. Thank you for all the help you guys gave me :wink:

1 Like

Try to upgrade the router firmware and/or reset the router settings to factory defaults.
The nslookup command should not fail no matter the OS you are using.

That arrangement might be simpler with a single cable from the router to the other room then a switch/access point to allow all the other devices to connect. It does not necessarily require a router depending on your personal usage. If using a router there for the AP it is possible to put it in bridged mode so it all becomes part of the one network already in the house.

1 Like

I think I did something like this, I just bring a cable from the “main” router (router from isp) and plugged in a Lan port, in Asus menu I select auto configuration for access point.

I will try to investigate. I do not know yet what could cause this (disable ipv6 and dns does not work)

Guys, I do not know actually what I did but all the things are working perfectly now.
I have two routers as I said, I entered my second router, and there was three options access point, (ap that was selected), default router mode and repeater.

I just thought “will try to switch to default mode”, when I switched the router said that I will could access just the main router, I clicked yes and all the things works ok.

I know now that all is configured by the “main” router, and to access the second one I need to reset to factory again.

But its all working, anyone with knowledge in networks knows whether is a problem to leave this way? :smiley:

here are a random print from the software to exemplify:

I select default to make the things work

and the dns is not leaking anymore, it is using the vpn dns

1 Like

If it is working the way it needs to then that is good.