Unable to boot to GUI but can boot to ttr after update in Fedora34

After doing update in Fedora 34 and finishing installation after rebooting I can’t get into login screen even when it prompt me disk decryption password and i can go to ttr mode but unable to get into the GUI. I use KDE Plasma as Desktop Environment. It does the same even when I boot into previous verison in the boot menu. How can I boot into the Desktop Environment and not getting black screen?

Which graphic processor you are using?

The below issue is radeon driver + GDM, so you can investigate if there are new issues with your graphic processor with your Desktop Environment.

I use AMD Radeon for the graphics but the solution doesn’t work

Try using older versions of kernel.

Or switch to GNOME or other Desktop environment until a fix is available.

You tried startx in ttr mode?

1 - From the Grub boot menu try booting to the old kernel listed. There would be at least 3 kernels.
If you are able to get GUI reinstall the current kernel using command
sudo dnf reinstall kernel

2 - If that wont work try adding nomodeset parameter to kernel arguments in grub menu.
that is on the grub screen press key “E” to edit.
under the category linux, add the word nomodeset at the end.

refer below link of how to add nomodeset in another distro but it is same for Fedora as well as it use Grub2

https://www.dell.com/support/kbdoc/en-in/000123893/manual-nomodeset-kernel-boot-line-option-for-linux-booting

If solution 2 is working you need to update the grub once back to GUI with the nomodeset parameter added in Grub.

3 - if none works try changing the display manager to Gnome or Light display manager.

HI. I think I have a variant of the display problem. It showed up on F33 when the nouveau driver couldn’t read my terminal anymore. I switched to the nvidia 390xx legacy driver ( I have the NVIDIA GeForce GT 555M graphics card) on a 2 terminal system (1 new nvidia LG monitor plus native labtop screen). It would boot up to grey screen. But if I pressed enter and gave password, it logged me in and displayed usual logged in screens (ladybug picts for me). So screen didn’t display, but I was there as far as computer input was concerned. I went to F34 in hopes bug is fixed. Same problem occurs. The fix you mention here was already in the version of F34 I downloaded.

Also my gpu is being driven hard. I know because fan is on pretty hard, and no regular cpu or disk or network activity happening.

when I do a ‘loginctl session-status’

I get the following:

2 - bert (1000)
Since: Sun 2021-06-06 21:32:17 PDT; 11min ago
Leader: 1984 (gdm-session-wor)
Seat: seat0; vc2
TTY: tty2
Service: gdm-password; type x11; class user
State: active
Unit: session-2.scope
├─1984 gdm-session-worker [pam/gdm-password]
├─2023 /usr/bin/gnome-keyring-daemon --daemonize --login
├─2030 /usr/libexec/gdm-x-session --run-script /usr/bin/gnome-session
├─2034 /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -backgroun>
├─2100 /usr/libexec/gnome-session-binary
└─2281 /usr/bin/ssh-agent /bin/sh -c exec -l /bin/bash -c “/usr/bin/gnome-session”

Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2855]: Errors from xkbcomp are not fatal to the X server
Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2856]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2856]: > Warning: Could not resolve keysym XF86FullScreen
Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2856]: Errors from xkbcomp are not fatal to the X server
Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2857]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2857]: > Warning: Could not resolve keysym XF86FullScreen
Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2857]: Errors from xkbcomp are not fatal to the X server
Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2858]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2858]: > Warning: Could not resolve keysym XF86FullScreen
Jun 06 21:32:32 BDevL /usr/libexec/gdm-x-session[2858]: Errors from xkbcomp are not fatal to the X server

Any suggestions ?

So I think I fixed my problem. When I did an xranhr -q , it showed a vga monitor was connected, even though it wasn’t the case (“VGA-0”). So I installed an x config file:

/usr/share/X11/xorg.conf.d/80-disablevga.conf

which contains the following:

Section “Monitor”
Identifier “VGA-0”
Option “Ignore” “true”
Option “Enable” “false”
EndSection

And it worked. Now when I boot up, it displays the login screen on my main monitor. I got the idea from:

It didn’t work for them, but it did for me.

2 Likes