Unable to boot with a new motherboard

I have upgraded the motherboard in a computer. I used the same SATA hard disk that had a working installation of Fedora 30 installed. The old motherboard was an ASUS P9X79 Deluxe. The new motherboard is an ASUS Prime Z390-A.

The BIOS reports that no bootable drives can be found. However, the BIOS shows the hard disk as a SATA drive.

I am able to boot with a Fedora 30 Live DVD, and the hard disk is mounted and I can see the files in the root and home directories.

Any suggestions to get the BIOS to recognize the hard disk as bootable?

Or do I need to do a new install?

As suggested in other posts, try to change SATA mode to AHCI in the BIOS/EFI. In addition, try to disable fast boot.

2 Likes

The SATA mode is set to AHCI, but fast boot was enabled. I disabled fast boot, but the BOIS is still reporting that no bootable drive was found.

1 Like

Do you have recent BIOS/FIRMWARE as per PRIME-Z390-A?. Do you have other Drives in the box? Was the previous installation UEFI bootable (GPT Partitioning) or was it based on MBR? If it was MBR, is your current BIOS set to Legacy Boot?

4 Likes

I’d say the most probable cause for this behavior (from what already was asked and said above) is your new MB’s bios configured to boot from UEFI devices with legacy boot disabled (as pointed by @twohot). Fedora Live DVD is able to boot in both modes – so it works. If your Fedora 30 installation was done in a legacy (non-UEFI) mode, it can’t be booted in UEFI mode – and so bios doesn’t see it.

The option on ASUS motherboards is usually called Launch CMS, you need to set this to enabled, and please check the submenu there if any. And it should be in the Boot section of bios settings. If you still can’t find it, i’ll recheck my own for more detailed instructions.

If the legacy boot is enabled already, try setting Secure boot to “Other OSes” or maybe even to “Disabled”. It’s usually right next to Launch CMS option. I think “Other OSes” should be sufficient. I’m 100% sure I’ve booted my Fedora machines with Secure boot enabled (and even set to “Windows blah-blah” mode, the strictest one.

Then again, if you’re planning on using some proprietary / additional drivers for devices – such as NVidia GPUs or some WiFis – you can just as well disable Secure boot right away, it’ll interfere with such drivers.


P.S. From my experience having latest or older bios shouldn’t affect visibility of boot devices. It’s still a good idea to have it updated, as BIOS updates can contain some bugfixes, performance and even security fixes.

4 Likes

Thanks to all that replied. The Fedora 30 installation was non-UEFI.

I looked for the “Launch CMS” option in the BIOS, but was not able to locate it. Using the BIOS search function, I found it and set it to enabled. The computer was able to boot Fedora. The problem is solved.

Thanks again for the support.

2 Likes

Nice to know @craig48 :+1: :slightly_smiling_face:
Please mark the appropriate post as the solution.

If your motherboard’s BIOS/UEFI settings is like mine’s (and most ASUS’s consumer motherboards I’ve seen are alike in this respect), then you start from sort of overview screen with time, temperature, voltage and fan speed displayed.

You first have to press [F7] to go to Advanced mode where all the real setting are (there’s a hint in the lower part of the screen indicating that).

The Advanced mode consists of a few tabs, and one of them (second to last usually) is Boot. You go there, scroll a bit lower, and there you’ll see two options: CMS (Compatibility Mode Support) and Secure boot right underneath it. You need to enter CMS (Compatibility Mode Support), and the first option there if Launch CMS.

In case you need to find it again. )

Also I’ve seen one ASUS motherboard recently that had it’s BIOS/UEFI settings presented differently.

1 Like