Unable to download updates | error running transaction

2 Likes

I’ve also tried dnf update

dnf and packagekit are two different tools.
Try this in terminal:
pkcon refresh force

1 Like

please show us the complete output from sudo dnf update, pasted as “Formatted Text” here.

output from Gnome Software is not clear, almost useless.
It’s saying “Unable to download” but when you look at it, it seems like being unable to install, hitting a package conflict.

Apperantly its a problem with mesa. Someone else on the fedora reddit had the exact same problem. Link: https://www.reddit.com/r/Fedora/comments/10276xn/after_dnf_upgrade_today_this_error_displayed/

1 Like
sudo dnf upgrade --exclude=mesa-va-drivers
1 Like

That seems to indicate that you may have mesa-va-drivers-freeworld installed and the upgrade is trying to install mesa-va-drivers.
Since those packages conflict (one from rpmfusion and one from fedora) you should only have one or the other installed.
If I were to need mesa I would select to remove mesa-va-drivers and have only the mesa-va-drivers-freeworld package installed.
I currently see this.

# dnf list mesa-va-drivers*
Last metadata expiration check: 2:56:09 ago on Tue 03 Jan 2023 04:51:38 AM CST.
Installed Packages
mesa-va-drivers.i686                                               22.3.2-1.fc37                                   @updates              
mesa-va-drivers.x86_64                                             22.3.2-1.fc37                                   @updates              
Available Packages
mesa-va-drivers-freeworld.i686                                     22.3.1-1.fc37                                   rpmfusion-free-updates
mesa-va-drivers-freeworld.x86_64                                   22.3.1-1.fc37                                   rpmfusion-free-updates

Should be fixed now! Run sudo dnf upgrade --refresh. If it doesn’t work you may need to wait a bit longer for your local repos to get the update

For me, this isn’t actually fixed but appeared today in the repos (stable).

Delta RPMs reduced 153.0 MB of updates to 61.9 MB (59.6% saved)
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction test error:
  file /usr/lib64/dri/nouveau_drv_video.so from install of mesa-va-drivers-22.3.3-1.fc37.x86_64 conflicts with file from package mesa-va-drivers-freeworld-22.3.2-1.fc37.x86_64
  file /usr/lib64/dri/r600_drv_video.so from install of mesa-va-drivers-22.3.3-1.fc37.x86_64 conflicts with file from package mesa-va-drivers-freeworld-22.3.2-1.fc37.x86_64
  file /usr/lib64/dri/radeonsi_drv_video.so from install of mesa-va-drivers-22.3.3-1.fc37.x86_64 conflicts with file from package mesa-va-drivers-freeworld-22.3.2-1.fc37.x86_64
  file /usr/lib64/dri/virtio_gpu_drv_video.so from install of mesa-va-drivers-22.3.3-1.fc37.x86_64 conflicts with file from package mesa-va-drivers-freeworld-22.3.2-1.fc37.x86_64
sudo dnf list mesa-va-drivers*
Last metadata expiration check: 0:02:32 ago on Fri 13 Jan 2023 10:12:29 AM CET.
Installed Packages
mesa-va-drivers-freeworld.x86_64      22.3.2-1.fc37      @rpmfusion-free-updates
Available Packages
mesa-va-drivers.i686                  22.3.3-1.fc37      updates                
mesa-va-drivers.x86_64                22.3.3-1.fc37      updates                
mesa-va-drivers-freeworld.i686        22.3.2-1.fc37      rpmfusion-free-updates

So I only have mesa-va-drivers-freeworld installed, some package in that update seems to pull a weak dependency on mesa-va-drivers, not taking into account that mesa-va-drivers-freeworld do provide that.

Dependencies resolved.
================================================================================
 Package                         Arch      Version             Repository  Size
================================================================================
Upgrading:
 cargo                           x86_64    1.66.1-1.fc37       updates    4.7 M
 grub2-common                    noarch    1:2.06-75.fc37      updates    917 k
 grub2-efi-ia32                  x86_64    1:2.06-75.fc37      updates    2.1 M
 grub2-efi-ia32-cdboot           x86_64    1:2.06-75.fc37      updates    2.1 M
 grub2-efi-x64                   x86_64    1:2.06-75.fc37      updates    2.2 M
 grub2-efi-x64-cdboot            x86_64    1:2.06-75.fc37      updates    2.2 M
 grub2-pc                        x86_64    1:2.06-75.fc37      updates     18 k
 grub2-pc-modules                noarch    1:2.06-75.fc37      updates    958 k
 grub2-tools                     x86_64    1:2.06-75.fc37      updates    1.8 M
 grub2-tools-efi                 x86_64    1:2.06-75.fc37      updates    558 k
 grub2-tools-extra               x86_64    1:2.06-75.fc37      updates    864 k
 grub2-tools-minimal             x86_64    1:2.06-75.fc37      updates    623 k
 gst-editing-services            x86_64    1.20.5-1.fc37       updates    653 k
 gstreamer1                      i686      1.20.5-1.fc37       updates    1.5 M
 gstreamer1                      x86_64    1.20.5-1.fc37       updates    1.4 M
 gstreamer1-plugins-bad-free     x86_64    1.20.5-1.fc37       updates    2.9 M
 gstreamer1-plugins-base         x86_64    1.20.5-1.fc37       updates    2.2 M
 gstreamer1-plugins-good         x86_64    1.20.5-1.fc37       updates    2.2 M
 gstreamer1-plugins-good-gtk     x86_64    1.20.5-1.fc37       updates     33 k
 gstreamer1-plugins-ugly-free    x86_64    1.20.5-1.fc37       updates    156 k
 mesa-dri-drivers                i686      22.3.3-1.fc37       updates     18 M
 mesa-dri-drivers                x86_64    22.3.3-1.fc37       updates     17 M
 mesa-filesystem                 i686      22.3.3-1.fc37       updates     18 k
 mesa-filesystem                 x86_64    22.3.3-1.fc37       updates     18 k
 mesa-libEGL                     i686      22.3.3-1.fc37       updates    142 k
 mesa-libEGL                     x86_64    22.3.3-1.fc37       updates    131 k
 mesa-libGL                      i686      22.3.3-1.fc37       updates    187 k
 mesa-libGL                      x86_64    22.3.3-1.fc37       updates    177 k
 mesa-libgbm                     i686      22.3.3-1.fc37       updates     47 k
 mesa-libgbm                     x86_64    22.3.3-1.fc37       updates     45 k
 mesa-libglapi                   i686      22.3.3-1.fc37       updates     55 k
 mesa-libglapi                   x86_64    22.3.3-1.fc37       updates     57 k
 mesa-libxatracker               x86_64    22.3.3-1.fc37       updates    2.1 M
 mesa-vulkan-drivers             i686      22.3.3-1.fc37       updates    8.1 M
 mesa-vulkan-drivers             x86_64    22.3.3-1.fc37       updates    7.5 M
 nspr                            i686      4.35.0-3.fc37       updates    147 k
 nspr                            x86_64    4.35.0-3.fc37       updates    135 k
 nss                             i686      3.87.0-1.fc37       updates    748 k
 nss                             x86_64    3.87.0-1.fc37       updates    694 k
 nss-softokn                     i686      3.87.0-1.fc37       updates    408 k
 nss-softokn                     x86_64    3.87.0-1.fc37       updates    382 k
 nss-softokn-freebl              i686      3.87.0-1.fc37       updates    356 k
 nss-softokn-freebl              x86_64    3.87.0-1.fc37       updates    326 k
 nss-sysinit                     x86_64    3.87.0-1.fc37       updates     18 k
 nss-util                        i686      3.87.0-1.fc37       updates     89 k
 nss-util                        x86_64    3.87.0-1.fc37       updates     86 k
 python3-rpmautospec             noarch    0.3.1-1.fc37        updates     66 k
 rpmautospec-rpm-macros          noarch    0.3.1-1.fc37        updates    8.8 k
 rust                            x86_64    1.66.1-1.fc37       updates     27 M
 rust-analysis                   x86_64    1.66.1-1.fc37       updates    3.3 M
 rust-src                        noarch    1.66.1-1.fc37       updates    2.7 M
 rust-std-static                 x86_64    1.66.1-1.fc37       updates     30 M
Installing weak dependencies:
 mesa-va-drivers                 x86_64    22.3.3-1.fc37       updates    3.4 M

I went back to mesa-va-drivers for now, but I think some package needs fixing there. Ofc, rpmfusion is not supported by fedora, so they may ignore that va-drivers-freeworld do provide va-drivers. We’ll see.

1 Like

I have the same issue. I follow this solution in order to have the harware acceleration :
Hardware acceleration

and now I have this :

Erreur : Erreur de la transaction de test :
  le fichier /usr/lib64/dri/nouveau_drv_video.so de l'installation de mesa-va-drivers-22.3.3-1.fc37.x86_64 entre en conflit avec le fichier du paquet mesa-va-drivers-freeworld-22.3.2-1.fc37.x86_64
  le fichier /usr/lib64/dri/r600_drv_video.so de l'installation de mesa-va-drivers-22.3.3-1.fc37.x86_64 entre en conflit avec le fichier du paquet mesa-va-drivers-freeworld-22.3.2-1.fc37.x86_64
  le fichier /usr/lib64/dri/radeonsi_drv_video.so de l'installation de mesa-va-drivers-22.3.3-1.fc37.x86_64 entre en conflit avec le fichier du paquet mesa-va-drivers-freeworld-22.3.2-1.fc37.x86_64
  le fichier /usr/lib64/dri/virtio_gpu_drv_video.so de l'installation de mesa-va-drivers-22.3.3-1.fc37.x86_64 entre en conflit avec le fichier du paquet mesa-va-drivers-freeworld-22.3.2-1.fc37.x86_64

is there a solution or I have to wait ?

Thanks

For me it looks also as a mix of two different sources.

My system has both mesa-va-drivers.x86_64 and mesa-va-drivers.i686 installed. The one shown is missing the mesa-va-drivers-freeworld.i686 and I would suspect that since one of the mesa packages being installed has the i686 package as a dependency it is trying to install the mesa-va-drivers.i686 package which then causes a conflict with the mesa-va-drivers-freeworld.x86_64 package that is already installed.

My suggestion:
swap both the i686 and the x86_64 packages so you have matching packages on the drivers.
You could also, as noted above, add --exclude=mesa-va-drivers* into your dnf upgrade command.

Note that I do not use the mesa drivers so cannot test this theory.
Note also that the freeworld version is one step behind the fedora version and that could possibly also be the cause.

2 Likes

From the RPMFusion Guide:

sudo dnf swap mesa-va-drivers mesa-va-drivers-freeworld
sudo dnf swap mesa-vdpau-drivers mesa-vdpau-drivers-freeworld
2 Likes

What is the difference between normal and -freeworld drivers?

Is freeworld coming just with free-opensource dirvers?

freeworld includes proprietary codecs for vaapi

2 Likes
sudo dnf swap mesa-va-drivers mesa-va-drivers-freeworld
sudo dnf swap mesa-vdpau-drivers mesa-vdpau-drivers-freeworld
sudo dnf distro-sync 
#check what packages are in conflict, these will be removed on the next command so ensure that this output seems correct
sudo dnf distro-sync --allowerasing #this will erase the packages in conflict but may allow erase some other packages, be careful!
sudo dnf remove mesa-va-drivers.i686

Did the trick for me, after this the update ran through without errors

2 Likes