Unable To Install kde-desktop-environment on Fedora 30

I previously had KDE installed on my system but got rid of it. Since then, I’ve seen a few things and wanted to give it another try. When I try to install now, I get quite a few errors back from DNF. I don’t know what could have changed that’s blocking the installation now.

Anyone know what might be doing this?

fuzzball][~]>sudo dnf group install kde-desktop-environment
Last metadata expiration check: 0:02:30 ago on Wed 03 Jul 2019 05:53:48 PM -03.
No match for group package “libva-vaapi-driver”
No match for group package “xorg-x11-drv-omap”
No match for group package “xorg-x11-drv-armsoc”
No match for group package “powerpc-utils”
No match for group package “lsvpd”
Error:
Problem: conflicting requests

  • package kdeplasma-addons-5.15.5-1.fc30.x86_64 requires libQt5WebEngineCore.so.5()(64bit), but none of the providers can be installed
  • package kdeplasma-addons-5.15.5-1.fc30.x86_64 requires libQt5WebEngineCore.so.5(Qt_5)(64bit), but none of the providers can be installed
  • package kdeplasma-addons-5.15.5-1.fc30.x86_64 requires libQt5WebEngine.so.5()(64bit), but none of the providers can be installed
  • package kdeplasma-addons-5.15.5-1.fc30.x86_64 requires libQt5WebEngine.so.5(Qt_5)(64bit), but none of the providers can be installed
  • package kdeplasma-addons-5.15.4-1.fc30.x86_64 requires libQt5WebEngineCore.so.5()(64bit), but none of the providers can be installed
  • package kdeplasma-addons-5.15.4-1.fc30.x86_64 requires libQt5WebEngineCore.so.5(Qt_5)(64bit), but none of the providers can be installed
  • package kdeplasma-addons-5.15.4-1.fc30.x86_64 requires libQt5WebEngine.so.5()(64bit), but none of the providers can be installed
  • package kdeplasma-addons-5.15.4-1.fc30.x86_64 requires libQt5WebEngine.so.5(Qt_5)(64bit), but none of the providers can be installed
  • package kdeplasma-addons-5.15.5-1.fc30.i686 requires libQt5WebEngineCore.so.5, but none of the providers can be installed
  • package kdeplasma-addons-5.15.5-1.fc30.i686 requires libQt5WebEngineCore.so.5(Qt_5), but none of the providers can be installed
  • package kdeplasma-addons-5.15.5-1.fc30.i686 requires libQt5WebEngine.so.5, but none of the providers can be installed
  • package kdeplasma-addons-5.15.5-1.fc30.i686 requires libQt5WebEngine.so.5(Qt_5), but none of the providers can be installed
  • package kdeplasma-addons-5.15.4-1.fc30.i686 requires libQt5WebEngineCore.so.5, but none of the providers can be installed
  • package kdeplasma-addons-5.15.4-1.fc30.i686 requires libQt5WebEngineCore.so.5(Qt_5), but none of the providers can be installed
  • package kdeplasma-addons-5.15.4-1.fc30.i686 requires libQt5WebEngine.so.5, but none of the providers can be installed
  • package kdeplasma-addons-5.15.4-1.fc30.i686 requires libQt5WebEngine.so.5(Qt_5), but none of the providers can be installed
  • nothing provides qt5-qtwebengine(x86-64) = 5.12.3 needed by qt5-qtwebengine-freeworld-5.12.3-1.fc30.x86_64
  • nothing provides libQt5Gui.so.5(Qt_5.11.3_PRIVATE_API)(64bit) needed by qt5-qtwebengine-freeworld-5.12.2-1.fc30.x86_64
  • nothing provides qt5-qtbase(x86-64) = 5.11.3 needed by qt5-qtwebengine-freeworld-5.12.2-1.fc30.x86_64
    (try to add ‘–skip-broken’ to skip uninstallable packages)
1 Like

Duplicate of Can't install kde-desktop-environment on F30

A post was merged into an existing topic: Can’t install kde-desktop-environment on F30

Hi there,

I have a similar problem but with XFCE (installing it on a KDE Spin).

Installing by excluding the qt5-qtwebengine-freeworld worked for me. I have KDE running smoothly.