Unable to load swrast and iris

I’m running Anaconda Spyder on Fedora 34. When I run spyder I get the following error:

No QCoreApplication instance found. Application patches not applied. You have to call load_stylesheet function after instantiation of QApplication to take effect. 
libGL error: MESA-LOADER: failed to open iris: /home/ted/anaconda3/lib/python3.8/site-packages/zmq/backend/cython/../../../../.././libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/dri/iris_dri.so) (search paths /usr/lib64/dri)
libGL error: failed to load driver: iris
libGL error: MESA-LOADER: failed to open swrast: /home/ted/anaconda3/lib/python3.8/site-packages/zmq/backend/cython/../../../../.././libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/dri/swrast_dri.so) (search paths /usr/lib64/dri)
libGL error: failed to load driver: swrast
libpng warning: bKGD: invalid
libpng warning: bKGD: invalid

I can see that libstdc++.so.6 is in /usr/lib64, but the search seems to be path is /usr/lib64/dri
Creating a symlink didn’t work.

How can I get iris and swrast to search /usr/lib64 for the driver?

2 Likes

That looks to me like it is complaining about GLIBCXX_3.4.29.

Any ideas on how to resolve it?

mv ~/anaconda3/lib/libstdc++.so.6{,.bak}

Does this change anything?

Yes it does thank you, so I guess it was using the wrong version of libstdc++.so.6, instead of using the system version…

1 Like