Unable to Run 4K 60HZ Except on Fedora Gnome

Hello,

I have tried installing Fedora KDE, Ubuntu, and Mint and for some reason only Fedora Gnome allows me to use 4K 60HZ on my TCL 50" TV. Every other distro/desktop it is locked at 30HZ unless I bump it down to 1080p. Is there a reason why only Fedora Gnome will let me use 4k 60hz and is there anything I can do to get it working on alternative desktops/distros? Any info is greatly appreciated as I’m new to Linux and dipping my toes in the water.

System Info:
OS: Fedora 33
CPU: Ryzen 3600
GPU: AMD Rx 5700
Display: 50" TCL TV w/ HDMI 2.0 Cable (Display shows up as “Technical Concepts Ltd 50” HDMI-A-0

Welcome to the community @jake51261

Fedora uses newest Kernels, for this newer devices are better recognized by fedora.
Just make a uname -a in Fedora gnome-terminal and try to install the same kernel in the alternative distros.

Keep in mind, LTS (Long Term Support) versions generally use older Kernel versions.

Hi ilikelinux,

I greatly appreciate the prompt suggestions! I actually found the source of the issue to be a display setting which was set to “auto hmdi mode” this was toggling between HDMI 2.0 (4k 60hz) and HDMI 1.4 (4k 30HZ). I want to give a shoutout to the Linux community for willingness to help! It makes the transition away from Windows so much easier.

2 Likes

Most of us went somehow thru this. A good community indeed is a big help.
There are also quite a lot of IRC chanels from fedora if you like to chat online. I got this way a lot of good information.
Communicating and getting help - Fedora Project Wiki

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.