Unable to run update after installing Fedora 36 on Parrallels

I’m running Fedora on an M1 Mac in Parallels. Each time I install Fedora as soon as I try to run the the updates I get a large error message. I’ve tried to install via dnf and received the same error messages.
Screen Shot 2022-08-16 at 11.31.36 AM

That message clearly says that there is a conflict between grubby-deprecated and grubby.

I see this

# dnf list grubby*
Last metadata expiration check: 2:11:06 ago on Tue 16 Aug 2022 09:57:18 AM CDT.
Installed Packages
grubby.x86_64                                                                   8.40-64.fc36                                                        @updates
Available Packages
grubby-deprecated.x86_64                                                        8.40-57.fc36                                                        fedora  

It would appear you need to fix that problem first, and it may be easily done with dnf update grubby. If that fails then show us the message you receive and we can dig a bit deeper. Maybe even add the --allowerasing option to the dnf command.

In the future, when posting messages from your screen please use the Preformatted text </> tags on the toolbar above to copy&paste text into the message instead of images. That makes it easier for us to read and respond to what is posted.

3 Likes

I was unable to copy the text when updating from the Software center so that’s why I gave you the pic.

I just tried

sudo dnf update grubby

and got this message:

Error: Transaction test error:
file /usr/sbin/grubby from install of grubby-8.40-64.fc36.aarch64 conflicts with file from package grubby-deprecated-8.40-57.fc36.aarch64
file /usr/sbin/installkernel from install of grubby-8.40-64.fc36.aarch64 conflicts with file from package grubby-deprecated-8.40-57.fc36.aarch64
file /usr/share/man/man8/grubby.8.gz from install of grubby-8.40-64.fc36.aarch64 conflicts with file from package grubby-deprecated-8.40-57.fc36.aarch64

I don’t know if mine ever had the grubby-deprecated package installed.

I also suggested you might try adding the --allowerasing option to that command.

An additional suggestion may be to try dnf swap grubby-deprecated grubby --allowerasing to remove the older grubby-deprecated package and install in its place the newer grubby, or just remove the older package with dnf remove grubby-deprecated --noautoremove followed by dnf install grubby to install the newer package.

1 Like

Thank you. That seemed to have fixed it.

1 Like