Unable to upgrade to Fedora 35 (from Fedora 34)

https://docs.fedoraproject.org/en-US/quick-docs/dnf-system-upgrade/

I’ve followed the instructions, when running sudo dnf system-upgrade download --releasever=35:

No match for group package "xorg-x11-drv-armsoc"
No match for group package "reiserfs-utils"
No match for group package "intel-media-driver"
No match for group package "drehatlas-warender-bibliothek-fonts"
No match for group package "iptables"
No match for group package "kanjistrokeorders-fonts"
No match for group package "google-noto-sans-syriac-estrangela-fonts"
No match for group package "tlomt-junction-fonts"
No match for group package "google-noto-sans-syriac-western-fonts"
No match for group package "google-noto-sans-syriac-eastern-fonts"
No match for group package "polarsys-b612-sans-fonts"
No match for group package "drehatlas-xaporho-fonts"
No match for group package "xorg-x11-utils"
No match for group package "google-noto-sans-tibetan-fonts"
No match for group package "bcm283x-firmware"
No match for group package "culmus-shofar-fonts"
No match for group package "vollkorn-fonts"
No match for group package "yanone-tagesschrift-fonts"
No match for group package "ubuntu-title-fonts"
No match for group package "khmer-os-fasthad-fonts"
Error: 
 Problem: package rpmfusion-nonfree-release-34-1.noarch requires system-release(34), but none of the providers can be installed
  - fedora-release-workstation-34-39.noarch does not belong to a distupgrade repository
  - problem with installed package rpmfusion-nonfree-release-34-1.noarch
(try to add '--skip-broken' to skip uninstallable packages)

intel-media-driver is the name of a proprietary driver I had installed when still running Intel hardware, but I made sure to remove the package afterwards. The others I don’t really recognize.

I don’t use the proprietary rpmfusion-nonfree repository anymore, all traces can be removed without worry.

This looks like the rpmfusion-nonfree was not implemented properly, and it keeps looking for Fedora 34 packages only. If you don’t use it anymore, simply remove it with dnf remove rpmfusion-nonfree-release.

Then do first dnf updateand then try again to upgrade.

If the problem persists, try to remove the packages that are no longer needed (this will include unused rpmfusion-nonfree packages): dnf autoremove but check the list that is marked for remove before autoremoving. You will see which of the autoremoval-marked packages are of rpmfusion-non-free in the “Repository” column if there are still some installed. This will not help if rpmfusion-non-free packages are still a dependency of something you intentionally installed (including the packages you intentionally installed from that repo), but then we will know that this is the case.

After that, dnf update and then try again to upgrade. Let me know if that does not work :slight_smile:

Supplement: you can in the end verify that everything from rpmfusion-nonfree is removed with dnf list all | grep rpmfusion-nonfree → This would be the next step anyway if autoremove does not solve the problem.

3 Likes

Alternatively, you can intentionally remove all packages from that specific repo:
first, get a repo list with the IDs:
dnf repolist
Then remove all packages using the ID of rpmfusion-nonfree:
dnf repository-packages <repo ID> remove
e.g., dnf repository-packages rpmfusion-nonfree remove

The removal list will also show you packages from other repostories if they still depend on rpmfusion-non-free packages.

Then again, dnf update to ensure all is fine and then try again to upgrade.

But the above solution is more suitable I think, cleaning your system of unneeded packages.

2 Likes

still outputs the same ‘group packages’

No match for group package "reiserfs-utils"
No match for group package "xorg-x11-drv-armsoc"
No match for group package "intel-media-driver"
No match for group package "iptables"
No match for group package "ubuntu-title-fonts"
No match for group package "tlomt-junction-fonts"
No match for group package "google-noto-sans-syriac-western-fonts"
No match for group package "google-noto-sans-syriac-eastern-fonts"
No match for group package "bcm283x-firmware"
No match for group package "yanone-tagesschrift-fonts"
No match for group package "kanjistrokeorders-fonts"
No match for group package "drehatlas-warender-bibliothek-fonts"
No match for group package "polarsys-b612-sans-fonts"
No match for group package "khmer-os-fasthad-fonts"
No match for group package "google-noto-sans-syriac-estrangela-fonts"
No match for group package "google-noto-sans-tibetan-fonts"
No match for group package "culmus-shofar-fonts"
No match for group package "drehatlas-xaporho-fonts"
No match for group package "vollkorn-fonts"
No match for group package "xorg-x11-utils"
Dependencies resolved.

But aside from the following error, the installer would allow proceeding:

Problem: package qt5-qtwebengine-freeworld-5.15.6-1.fc35.x86_64 requires qt5-qtwebengine(x86-64) = 5.15.6, but none of the providers can be installed
  - cannot install both qt5-qtwebengine-5.15.8-2.fc35.x86_64 and qt5-qtwebengine-5.15.6-1.fc35.x86_64
  - cannot install the best update candidate for package qt5-qtwebengine-freeworld-5.15.5-1.fc34.x86_64
  - cannot install the best update candidate for package qt5-qtwebengine-5.15.5-1.fc34.x86_64

dnf autoremove lists about 200 packages (some are likely user-installed Python package dependencies):

======================================================================================================================
 Package                                       Arch      Version                                   Repository    Size
======================================================================================================================
Removing:
 GConf2                                        x86_64    3.2.6-30.fc34                             @fedora      6.4 M
 ImageMagick-c++                               x86_64    1:6.9.12.32-1.fc34                        @updates     685 k
 apache-commons-logging                        noarch    1.2-25.fc34                               @fedora      179 k
 bridge-utils                                  x86_64    1.7.1-1.fc34                              @fedora       64 k
 capstone                                      x86_64    4.0.2-4.fc34                              @fedora       11 M
 corosynclib                                   x86_64    3.1.6-1.fc34                              @updates     158 k
 cyrus-sasl                                    x86_64    2.1.27-8.fc34                             @fedora      143 k
 edk2-ovmf                                     noarch    20200801stable-4.fc34                     @fedora      6.8 M
 f33-backgrounds-base                          noarch    33.0.8-2.fc34                             @fedora       30 M
 f33-backgrounds-gnome                         noarch    33.0.8-2.fc34                             @fedora      1.5 k
 flashrom                                      x86_64    1.2-6.fc34                                @fedora      1.8 M
 frei0r-plugins                                x86_64    1.7.0-12.fc34                             @fedora      5.9 M
 fwupd                                         x86_64    1.7.3-1.fc34                              @updates     6.9 M
 fwupd-efi                                     x86_64    1.1-1.fc34                                @updates     154 k
 fwupd-plugin-flashrom                         x86_64    1.7.3-1.fc34                              @updates      36 k
 fwupd-plugin-modem-manager                    x86_64    1.7.3-1.fc34                              @updates     101 k
 fwupd-plugin-uefi-capsule-data                x86_64    1.7.3-1.fc34                              @updates     1.8 M
 gavl                                          x86_64    1.4.0-18.fc34                             @fedora      4.2 M
 genisoimage                                   x86_64    1.1.11-47.fc34                            @fedora      1.1 M
 glusterfs                                     x86_64    9.5-1.fc34                                @updates     2.8 M
 glusterfs-cli                                 x86_64    9.5-1.fc34                                @updates     493 k
 glusterfs-client-xlators                      x86_64    9.5-1.fc34                                @updates     3.8 M
 glusterfs-fuse                                x86_64    9.5-1.fc34                                @updates     564 k
 gnome-icon-theme                              noarch    3.12.0-15.fc34                            @fedora      9.9 M
 gnome-shell-extension-appindicator            noarch    41-1.fc34                                 @updates     176 k
 gnome-video-effects                           noarch    0.5.0-5.fc34                              @fedora      210 k
 gnutls-dane                                   x86_64    3.7.2-1.fc34                              @updates      49 k
 gnutls-utils                                  x86_64    3.7.2-1.fc34                              @updates     2.4 M
 gperftools-libs                               x86_64    2.9.1-1.fc34                              @fedora      1.4 M
 gtk-vnc2                                      x86_64    1.0.0-4.fc34                              @fedora      218 k
 guile                                         x86_64    5:2.0.14-24.fc34                          @fedora       12 M
 gvnc                                          x86_64    1.0.0-4.fc34                              @fedora      258 k
 iceauth                                       x86_64    1.0.8-2.fc34                              @fedora       47 k
 ilmbase                                       x86_64    2.3.0-6.fc34                              @fedora      512 k
 ipxe-roms-qemu                                noarch    20200823-7.git4bd064de.fc34               @updates     2.7 M
 isl                                           x86_64    0.16.1-13.fc34                            @fedora      3.1 M
 jasper-libs                                   i686      2.0.33-1.fc34                             @updates     346 k
 json-glib                                     i686      1.6.6-1.fc34                              @updates     554 k
 kbd-legacy                                    noarch    2.4.0-2.fc34                              @fedora      544 k
 khmeros-fonts-common                          noarch    5.0-30.fc33                               @anaconda    826  
 kyotocabinet-libs                             x86_64    1.2.78-1.fc33                             @updates     974 k
 lensfun                                       x86_64    0.3.2-31.fc34                             @fedora      1.9 M
 libFAudio                                     i686      21.11-2.fc34                              @updates     254 k
 libFAudio                                     x86_64    21.11-2.fc34                              @updates     243 k
 libatomic                                     x86_64    11.2.1-1.fc34                             @updates      32 k
 libavc1394                                    i686      0.5.4-15.fc34                             @fedora      132 k
 libcacard                                     x86_64    3:2.8.0-2.fc34                            @fedora      119 k
 libchamplain                                  x86_64    0.12.20-4.fc34                            @fedora      409 k
 libchamplain-gtk                              x86_64    0.12.20-4.fc34                            @fedora       25 k
 libdv                                         i686      1.0.0-33.fc34                             @fedora      181 k
 libdv                                         x86_64    1.0.0-33.fc34                             @fedora      180 k
 libfdt                                        x86_64    1.6.1-1.fc34                              @updates      58 k
 libffado                                      x86_64    2.4.4-3.fc34                              @fedora      2.6 M
 libftdi                                       x86_64    1.5-2.fc34                                @updates      90 k
 libgcab1                                      x86_64    1.4-4.fc34                                @fedora      207 k
 libgdither                                    x86_64    0.6-24.fc34                               @fedora       45 k
 libgdl                                        x86_64    1:3.40.0-1.fc34                           @updates     1.0 M
 libgfapi0                                     x86_64    9.5-1.fc34                                @updates     228 k
 libgfrpc0                                     x86_64    9.5-1.fc34                                @updates     242 k
 libgfxdr0                                     x86_64    9.5-1.fc34                                @updates      81 k
 libglusterd0                                  x86_64    9.5-1.fc34                                @updates      15 k
 libglusterfs0                                 x86_64    9.5-1.fc34                                @updates     971 k
 libgpod                                       x86_64    0.8.3-37.fc34                             @fedora      924 k
 libibumad                                     x86_64    37.0-1.fc34                               @updates      44 k
 libiec61883                                   i686      1.2.0-26.fc34                             @fedora       97 k
 libiec61883                                   x86_64    1.2.0-26.fc34                             @fedora       85 k
 libiscsi                                      x86_64    1.19.0-3.fc34                             @fedora      223 k
 libjaylink                                    x86_64    0.2.0-2.fc34                              @fedora       86 k
 libjcat                                       x86_64    0.1.9-1.fc34                              @updates     181 k
 liblrdf                                       x86_64    0.5.0-21.fc34                             @fedora       61 k
 libmcpp                                       x86_64    2.7.2-27.fc34                             @fedora      155 k
 libmodman                                     i686      2.0.1-24.fc34                             @fedora       62 k
 libmodman                                     x86_64    2.0.1-24.fc34                             @fedora       62 k
 libnfs                                        x86_64    4.0.0-4.fc34                              @fedora      435 k
 libnsl                                        x86_64    2.33-20.fc34                              @updates     104 k
 libphodav                                     x86_64    2.5-3.fc34                                @fedora      142 k
 libpmem                                       x86_64    1.10-3.fc34                               @fedora      412 k
 libpmemobj                                    x86_64    1.10-3.fc34                               @fedora      373 k
 libpng12                                      x86_64    1.2.57-13.fc34                            @fedora      447 k
 libportal                                     x86_64    0.4-1.fc34                                @updates     139 k
 libqb                                         x86_64    2.0.4-1.fc34                              @updates     212 k
 librados2                                     x86_64    2:16.2.7-2.fc34                           @updates      13 M
 libraw1394                                    i686      2.1.2-13.fc34                             @fedora      169 k
 librbd1                                       x86_64    2:16.2.7-2.fc34                           @updates      15 M
 librdmacm                                     x86_64    37.0-1.fc34                               @updates     151 k
 libreoffice-xsltfilter                        x86_64    1:7.1.8.1-1.fc34                          @updates     4.3 M
 libsmbios                                     x86_64    2.4.3-2.fc34                              @fedora      389 k
 libsysfs                                      x86_64    2.1.1-1.fc34                              @fedora       75 k
 libtar                                        x86_64    1.2.20-21.fc34                            @fedora       81 k
 libtpms                                       x86_64    0.8.6-0.20210910git7a4d46a119.fc34.0      @updates     982 k
 libusal                                       x86_64    1.1.11-47.fc34                            @fedora      469 k
 libvdpau                                      i686      1.4-4.fc34                                @fedora       20 k
 libvirt-daemon                                x86_64    7.0.0-8.fc34                              @updates     1.4 M
 libvirt-daemon-driver-interface               x86_64    7.0.0-8.fc34                              @updates     583 k
 libvirt-daemon-driver-network                 x86_64    7.0.0-8.fc34                              @updates     697 k
 libvirt-daemon-driver-nodedev                 x86_64    7.0.0-8.fc34                              @updates     624 k
 libvirt-daemon-driver-nwfilter                x86_64    7.0.0-8.fc34                              @updates     673 k
 libvirt-daemon-driver-qemu                    x86_64    7.0.0-8.fc34                              @updates     2.5 M
 libvirt-daemon-driver-secret                  x86_64    7.0.0-8.fc34                              @updates     575 k
 libvirt-daemon-driver-storage                 x86_64    7.0.0-8.fc34                              @updates       0  
 libvirt-daemon-driver-storage-core            x86_64    7.0.0-8.fc34                              @updates     757 k
 libvirt-daemon-driver-storage-disk            x86_64    7.0.0-8.fc34                              @updates      32 k
 libvirt-daemon-driver-storage-gluster         x86_64    7.0.0-8.fc34                              @updates      40 k
 libvirt-daemon-driver-storage-iscsi           x86_64    7.0.0-8.fc34                              @updates      24 k
 libvirt-daemon-driver-storage-iscsi-direct    x86_64    7.0.0-8.fc34                              @updates      32 k
 libvirt-daemon-driver-storage-logical         x86_64    7.0.0-8.fc34                              @updates      32 k
 libvirt-daemon-driver-storage-mpath           x86_64    7.0.0-8.fc34                              @updates      16 k
 libvirt-daemon-driver-storage-rbd             x86_64    7.0.0-8.fc34                              @updates      44 k
 libvirt-daemon-driver-storage-scsi            x86_64    7.0.0-8.fc34                              @updates      24 k
 libvirt-daemon-driver-storage-sheepdog        x86_64    7.0.0-8.fc34                              @updates      20 k
 libvirt-daemon-driver-storage-zfs             x86_64    7.0.0-8.fc34                              @updates      24 k
 libvirt-daemon-kvm                            x86_64    7.0.0-8.fc34                              @updates       0  
 libvirt-gconfig                               x86_64    4.0.0-1.fc34                              @fedora      387 k
 libvirt-glib                                  x86_64    4.0.0-1.fc34                              @fedora      117 k
 libvirt-gobject                               x86_64    4.0.0-1.fc34                              @fedora      238 k
 libvirt-libs                                  x86_64    7.0.0-8.fc34                              @updates      23 M
 libwsman1                                     x86_64    2.6.8-19.fc34                             @fedora      353 k
 libxml++                                      x86_64    2.42.1-1.fc34                             @updates     307 k
 libxmlb                                       x86_64    0.3.6-1.fc34                              @updates     288 k
 libzapojit                                    x86_64    0.0.3-20.fc34                             @updates     120 k
 lttng-ust                                     x86_64    2.12.0-4.fc34                             @fedora      1.1 M
 luajit                                        x86_64    2.1.0-0.19beta3.fc34                      @fedora      1.3 M
 lzop                                          x86_64    1.04-6.fc34                               @fedora      107 k
 mcpp                                          x86_64    2.7.2-27.fc34                             @fedora       59 k
 mozjs68                                       x86_64    68.12.0-2.fc34                            @fedora       23 M
 netcf-libs                                    x86_64    0.2.8-18.fc34                             @fedora      195 k
 numad                                         x86_64    0.5-34.20150602git.fc34                   @fedora       60 k
 pipewire0.2-libs                              x86_64    0.2.7-5.fc34                              @fedora      1.4 M
 python3-beaker                                noarch    1.10.0-10.fc34                            @fedora      394 k
 python3-crypto                                x86_64    2.6.1-34.fc34                             @fedora      2.0 M
 python3-cryptography                          x86_64    3.4.6-1.fc34                              @fedora      7.0 M
 python3-mako                                  noarch    1.1.4-3.fc34                              @fedora      534 k
 python3-paste                                 noarch    3.5.0-3.fc34                              @fedora      2.6 M
 python3-pyOpenSSL                             noarch    21.0.0-1.fc34                             @updates     389 k
 python3-requests-download                     noarch    0.1.2-5.fc34                              @fedora       12 k
 python3-sssdconfig                            noarch    2.5.2-2.fc34                              @updates     244 k
 python3-tempita                               noarch    0.5.1-29.fc34                             @fedora      113 k
 qemu-audio-alsa                               x86_64    2:5.2.0-8.fc34                            @updates      29 k
 qemu-audio-oss                                x86_64    2:5.2.0-8.fc34                            @updates      21 k
 qemu-audio-pa                                 x86_64    2:5.2.0-8.fc34                            @updates      25 k
 qemu-audio-sdl                                x86_64    2:5.2.0-8.fc34                            @updates      16 k
 qemu-audio-spice                              x86_64    2:5.2.0-8.fc34                            @updates      16 k
 qemu-block-curl                               x86_64    2:5.2.0-8.fc34                            @updates      33 k
 qemu-block-dmg                                x86_64    2:5.2.0-8.fc34                            @updates      16 k
 qemu-block-gluster                            x86_64    2:5.2.0-8.fc34                            @updates      41 k
 qemu-block-iscsi                              x86_64    2:5.2.0-8.fc34                            @updates      47 k
 qemu-block-nfs                                x86_64    2:5.2.0-8.fc34                            @updates      34 k
 qemu-block-rbd                                x86_64    2:5.2.0-8.fc34                            @updates      37 k
 qemu-block-ssh                                x86_64    2:5.2.0-8.fc34                            @updates      39 k
 qemu-char-baum                                x86_64    2:5.2.0-8.fc34                            @updates      20 k
 qemu-char-spice                               x86_64    2:5.2.0-8.fc34                            @updates      21 k
 qemu-common                                   x86_64    2:5.2.0-8.fc34                            @updates      13 M
 qemu-device-display-qxl                       x86_64    2:5.2.0-8.fc34                            @updates      89 k
 qemu-device-display-virtio-gpu                x86_64    2:5.2.0-8.fc34                            @updates      71 k
 qemu-device-display-virtio-gpu-pci            x86_64    2:5.2.0-8.fc34                            @updates      16 k
 qemu-device-display-virtio-vga                x86_64    2:5.2.0-8.fc34                            @updates      17 k
 qemu-device-usb-redirect                      x86_64    2:5.2.0-8.fc34                            @updates      70 k
 qemu-device-usb-smartcard                     x86_64    2:5.2.0-8.fc34                            @updates      34 k
 qemu-img                                      x86_64    2:5.2.0-8.fc34                            @updates     5.7 M
 qemu-kvm                                      x86_64    2:5.2.0-8.fc34                            @updates       0  
 qemu-system-x86                               x86_64    2:5.2.0-8.fc34                            @updates       0  
 qemu-system-x86-core                          x86_64    2:5.2.0-8.fc34                            @updates      30 M
 qemu-ui-curses                                x86_64    2:5.2.0-8.fc34                            @updates      48 k
 qemu-ui-egl-headless                          x86_64    2:5.2.0-8.fc34                            @updates      16 k
 qemu-ui-gtk                                   x86_64    2:5.2.0-8.fc34                            @updates      75 k
 qemu-ui-opengl                                x86_64    2:5.2.0-8.fc34                            @updates      33 k
 qemu-ui-sdl                                   x86_64    2:5.2.0-8.fc34                            @updates      45 k
 qemu-ui-spice-app                             x86_64    2:5.2.0-8.fc34                            @updates      16 k
 qemu-ui-spice-core                            x86_64    2:5.2.0-8.fc34                            @updates      69 k
 radvd                                         x86_64    2.19-2.fc34                               @fedora      174 k
 rdma-core                                     x86_64    37.0-1.fc34                               @updates     119 k
 rest                                          i686      0.8.1-9.fc34                              @fedora      193 k
 seabios-bin                                   noarch    1.14.0-4.fc34                             @updates     917 k
 seavgabios-bin                                noarch    1.14.0-4.fc34                             @updates     325 k
 sessreg                                       x86_64    1.1.2-2.fc34                              @fedora       20 k
 sg3_utils-libs                                x86_64    1.45-4.fc34                               @fedora      273 k
 sgabios-bin                                   noarch    1:0.20180715git-6.fc34                    @fedora      4.0 k
 sheepdog                                      x86_64    1.0.1-14.fc34                             @fedora      732 k
 spice-glib                                    x86_64    0.39-3.fc34                               @updates     1.2 M
 spice-gtk3                                    x86_64    0.39-3.fc34                               @updates     299 k
 spice-server                                  x86_64    0.14.3-3.fc34                             @fedora      1.2 M
 swtpm                                         x86_64    0.6.0-1.20210607gitea627b3.fc34           @updates     214 k
 swtpm-libs                                    x86_64    0.6.0-1.20210607gitea627b3.fc34           @updates      87 k
 swtpm-tools                                   x86_64    0.6.0-1.20210607gitea627b3.fc34           @updates     261 k
 systemd-container                             x86_64    248.10-1.fc34                             @updates     1.3 M
 texttopaps                                    x86_64    0.7.1-2.fc34                              @fedora       91 k
 usbredir                                      x86_64    0.12.0-1.fc34                             @updates     115 k
 vim-common                                    x86_64    2:8.2.4068-1.fc34                         @updates      31 M
 vim-enhanced                                  x86_64    2:8.2.4068-1.fc34                         @updates     4.2 M
 virglrenderer                                 x86_64    0.8.2-3.20200212git7d204f39.fc34          @fedora      429 k
 xen-libs                                      x86_64    4.14.3-3.fc34                             @updates     1.8 M
 xen-licenses                                  x86_64    4.14.3-3.fc34                             @updates     454 k
 xgamma                                        x86_64    1.0.6-2.fc34                              @fedora       20 k
 xinput                                        x86_64    1.6.3-2.fc34                              @fedora       70 k
 xisxwayland                                   x86_64    1-1.fc34                                  @fedora       17 k
 xkill                                         x86_64    1.0.5-2.fc34                              @fedora       19 k
 xorg-x11-font-utils                           x86_64    1:7.5-51.fc34                             @fedora      221 k
 xrefresh                                      x86_64    1.0.6-3.fc34                              @updates      37 k
 xset                                          x86_64    1.2.4-2.fc34                              @fedora       42 k
 xsetroot                                      x86_64    1.1.2-2.fc34                              @fedora       23 k
 xstdcmap                                      x86_64    1.0.4-4.fc34                              @updates      37 k
 zfs-fuse                                      x86_64    0.7.2.2-18.fc34                           @fedora      6.0 M

Transaction Summary
======================================================================================================================
Remove  202 Packages

Freed space: 341 M

Don’t ever do the dnf autoremove - it is likely gonna kill your system. Never!

No match group xy can be ignored. Forget about it.

Your issue is the following:

Problem: package qt5-qtwebengine-freeworld-5.15.6-1.fc35.x86_64 requires qt5-qtwebengine(x86-64) = 5.15.6, but none of the providers can be installed
  - cannot install both qt5-qtwebengine-5.15.8-2.fc35.x86_64 and qt5-qtwebengine-5.15.6-1.fc35.x86_64
  - cannot install the best update candidate for package qt5-qtwebengine-freeworld-5.15.5-1.fc34.x86_64
  - cannot install the best update candidate for package qt5-qtwebengine-5.15.5-1.fc34.x86_64

My advice: Just remove those two packages that give you unsolvable errors, and install them again after the dist-upgrade:

 sudo dnf remove qt5-qtwebengine-freeworld qt5-qtwebengine

Alternatively you can add a --allowerasing to your upgrade command, make sure you read and understand what dnf suggest then, but in the end it will remove the conflicting packages just as if you would remove them manually.

The group package issue on itself is no problem. You can ignore that.

The rpmfusion package has a dependency in the Fedora repo, but the rpmfusion package needs an older version of that dependency and thus, wants to downgrade it. Definitely nothing system critical. If it was my system, I would check if dnf remove qt5-qtwebengine-freeworld would affect other packages and if not, I would remove the freeworld package. If you need it, do the upgrade. It is not critical to the system and is likely to be solved in future updates.

If you are unsure, don’t do it - it will not harm the upgrade to not do autoremove. The issue seems to be already solved by the removal of the non-free repo. Nevertheless, I suggest to do the dnf list all | grep rpmfusion-nonfree and then remove the remaining packages of rpmfusion-nonfree (if there are any) as these will no longer get updates.

4 posts were split to a new topic: Use of dnf autoremove

A post was merged into an existing topic: Use of dnf autoremove

@grass We have started another topic to discuss the future use of dnf autoremove. For now, your original issue is solved and as already stated, the remaining issue is not related to autoremove and does not need it anyway. So forget it for now.

So focus on the freeworld thing: remove it as suggested above if you don’t need it. If you need it, just start the upgrade as this package will not hurt and is likely to be solved in future updates. If the upgrade process does not want to start because of the freeworld package, add the --allowerasing that @augenauf already suggested. It will end up in a temporarily downgrade of the related package - but of course always read what dnf is suggesting before doing y. --allowerasing can be powerful.

And as this is an issue others may also experience (I don’t know how your rpmfusion-nonfree config could end up that way), feel free to mark the post which you used to solve the original rpmfusion-nonfree problem as solution.