Unable to use Headset after upgrading to fedora34

I have upgraded from fedora33 to fedora34 Workstation. I found that my USB headset is not working.

These are few findings from my side:-

After connecting to the headset the system recognises it, but there is no sound output from the device.

  1. Screenshot of sound setting

  2. output of #lsusb command

Please help me with this.

All suggestions are welcomed.

Could this be your case:
Audio may not work after upgrade to Fedora 34 if pipewire was previously installed

1 Like

ok I will try that, and will update here. But just to clarify: Audio is working fine. i.e. laptop inbuilt speakers, only when I connect to my usb headphones it’s not working.

I have tried this, but it’s still not working. I have removed (copied to some other location) the files inside /etc/udev/rules.d/ after the reboot laptop doesn’t shows-up any volume icon. As a result, I had to copy those configuration files back to /etc/udev/rules.d/.

Any other suggestion ?

Update 1.

I also upgraded my computer from Fedora 33 Workstation Xfce to Fedora 34 Workstation Xfce.

There the same USB Headset is working after I select the “Headset [PC 8] Analog Stereo” option under the Volume icon (screenshot attached)

But here in GNOME, this is not the case, even when selecting the “Headphones - Headset [PC 8]” option from SettingsSound, it’s not working. (screenshot attached).

Please help.

I meant you should do this:

If you had pipewire installed in Fedora 32 or 33, it may stop working on upgrade to Fedora 34. If this happens to you, we recommend moving all *.conf files out of /etc/pipewire and reinstalling pipewire with sudo dnf reinstall pipewire pipewire-pulseaudio . You will then need to re-apply any customizations you had made to the configuration files.

did you?

I am also facing issues with Fedora 34 Workstation edition and my usb headsets. But my headset works for sometime after a reboot. I think it keeps working as long as it is in use by some application but if it is left idle for some time it stops working. Restarting the pipewire service fixes it, as suggested by @ankursinha in reply to my question.

systemctl --user restart pipewire.service

1 Like

Yes, you are right, I also observed it. Thank you :slight_smile:

Thank you to all for helping :slight_smile: I love Fedora community :smiley:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.