Unreliable connection to my phone's WiFi hotspot

Hello everyone,

I’m having issues connecting to the WiFi hotspot created by my phone (running LineageOS) with my laptop (running Fedora 35 Xfce spin).

The weird thing is that it’s not impossible to connect to the hotspot, just that it’s kind of random every time, so it’s hard to pinpoint what the specific problem is.

Most times, the behavior is as follows: first, I see the NetworkManager applet in my “task bar” trying to connect to my hotspot. It’ll display the “loading” icon for a few seconds, then stops, then display that it’s not connected. I can try again by opening the nm applet and clicking on my phone’s hotspot. It’ll probably repeat the same process (trying to connect then failing) a few more times, and then it might connect. At this point, if I try to load a webpage, there’s a fairly high chance that it won’t work. I’m thus back at step 1, opening nm applet, clicking on my phone’s hotspot etc. After 2 or 3 cycles of that, if it doesn’t work, I try restarting my laptop. It may or may not work, and I might have to do that 2 or 3 times.

Most times, it takes me at least 10 minutes to connect to that hotspot, which is obviously very frustrating. Some days, I can try for an hour straight without any success. That’s what happened to me today, which finally prompted me to make this post.

Connecting on my home router never has this problem, it always works flawlessly.

I’ve found this thread which might be close to what I’m experiencing, but without the randomness.

Let me try to address some of the points made in that thread so we can find a solution faster:

  • As far as I understand, MAC address randomization is not activated on my phone
  • I can include the contents of journalctl --system --since today
    but you’d have to specify what’s interesting to include or what I should look for because there’s a lot of info on there, obviously.
  • The security of my phone hotspot is WPA2 PSK (the only other option being “None”).
  • I haven’t tried sudo update-crypto-policies --set LEGACY yet because, obviously, now that I’m trying to debug, my laptop keeps connecting flawlessly to the hotspot.

Any suggestions? Thanks for your help!

Sorry, this almost surely isn’t it, but just in case - have you disabled Wi-Fi Powersave on your laptop? When I had issues with my Wi-Fi on Pop!_OS, it didn’t manifest as high latency as this post described, it caused periods of constant dropped connections like you’re describing, so I thought I’d just mention.