Unstable experience in the past few kernel releases

I am currently on kernel 5.2.17. Since the past few releases there is something weird. Sometimes when I open Firefox for example, GNOME shows me the loading icon. It would spin for sometime and nothing would happen. I would want to start System Monitor to find out what’s happening like is there a Firefox process thats already running or something like that but I at times even System Monitor will now show up. The mouse would show the spinning animation for sometime and nothing would happen.

VS Code will crash at times as soon as you open it and force quit would do nothing. Neither does killing it using kill or killall command work. And whenever something like this happens, fedora would take extremely long time to shut down. Also, sudo would take about a minute to prompt for password which would otherwise be immediate

Anyone else experienced this issue or is it just me?

P.S. Things will normally work after a reboot but this has happened enough times that I need help

Hey there, welcome to Ask Fedora! Please check out #start-here to learn your way around the community.

At a glance, this is pretty interesting, and there could be several things causing this, so we’ve got to narrow it down a bit more:

  • If you run VS Code from the terminal, do you see any errors? If it crashes, could you try running dmesg and look for errors around the bottom?
  • Could you check dmesg as mentioned above but after using sudo and it hangs, and check for any errors? How about journalctl -e?
  • When Fedora takes a long time to shut down, could you press the Escape key to show the systemd logs and see what service it says it’s stuck waiting for on shutdown?
1 Like

I checkout the #start-here page before posting this question. I did it again. I don’t know what you want me to read. Due to exams, I have not gotten to use my computer yesterday. Today, it is working fine as of now. In case that error occurs, I will check dmesg and journatctl

@rahem027, there is nothing related to your question in the category that @refi64 invited you to read.
Such statement is simply a welcome message :slight_smile: we usually send here to people that write a post in this forum for the first time.

1 Like

This is a suggestion, it may or may not be applicable in your case.
I have noticed something somewhat similar. In my case there are a couple of factors that have changed before I started to notice things were not as usual.
To begin with I have a recently purchased a Lenovo Ideapad S145. The CPU is AMD A9. From what I have read about the A9, it tend to be I/O intensive. Furthermore I upgraded from Fedora 30 KDE to Fedora 31 KDE beta.
Since Installing Fedora 31 beta, I noticed high memory and swap usage. After 1 or 2 days, I would be forced to reboot because the laptop would begin to slowdown. To mitigate this, I have added options to control swappiness;

create a file named /etc/sysctl.d/99-vmswap.conf

sudo nano /etc/sysctl.d/99-vmswap.conf
and put in the file:

vm.swappiness=10
vm.vfs_cache_pressure=50
vm.dirty_background_ratio=10
vm.dirty_ratio=15

and reload the changes with

sudo systemctl restart systemd-sysctl.service
Experiment with these values for your use case.

I am hoping that this will quiet down with the release of Fedora 31.

As I said, you may or may not find this useful.

Cheers.

I don’t think I am low on resources @cristobal. This is a new PC Ryzen 3 2200G, 16GB RAM and 480GB SSD. The system has become a lot more stable recently and I don’t know why. But we are programers. It is working and I am not touching it :stuck_out_tongue_winking_eye:

I don’t know what happened. But its a lot better now. sudo is quick (yay!) and the system is more stable

happy to hear that all’s well on your side. With the changes to swappiness, I can go 3 days before it begins to slow down. Ram and swap get filled and I have to reboot to regain some semblance of sanity.

Sudo sometimes isn’t prompt after kernel was updated to 5.3.5. Output of journalctl -r shows this when sudo does not work as expected:

pam_unix(sudo:auth): auth could not identify password for [Hemil]
pam_unix(sudo:auth): conversation failed

P.S. If I restart the terminal and try again, it works

Also something that I noted recently was the fact that after every kernel update, for the first few times after I log into fedora, for a few seconds, there is no display output (according to my monitor). But as time passes by, gnome just launches in a flash and there is no delay

Just updated to kernel 5.3.7 and this issue is gone.

fedora uses akmod packages to update kernel module packages and these updates have to be compiled and then loaded into the kernel with the first boot after there is an update. Subsequent boots just have to load the new module so it goes much quicker.

I have had some video driver updates that hung during the first boot/compile procedure and a simple reboot fixed that.

I suspect the new modules may be part of the reason for the occasional slow boots after a kernel upgrade.

Just for people who experiencing slow boot times, upon inspection, I found out that httpd was timing out during every boot. Which increased the boot time from 1 min to 3 min. Maybe its a bug or something, disabling httpd helped. Though you might want to check which component is taking so long to boot