Update nodejs checksum error

Trying to update my system, I am getting the following error:

[MIRROR] nodejs-10.16.0-1nodesource.x86_64.rpm: Downloading successful, but checksum doesn't match. Calculated: 242e908bd3683963b102e0768665d4240472e316(sha1)  Expected: 6e9c47bd1f97275c175ec9bbf1faf6c33b2a7bf1(sha1) 
[FAILED] nodejs-10.16.0-1nodesource.x86_64.rpm: No more mirrors to try - All mirrors were already tried without success
(3-4/114): kernel-de  3% [-                   ] 6.9 MB/s |  20 MB     01:27 ETA
Error: Error downloading packages:
  Cannot download nodejs-10.16.0-1nodesource.x86_64.rpm: All mirrors were tried

Can I exclude this specific package until the problem is solved? If yes, How?

Then where should I notify this error? On a NodeJS forum or…?

Cheers

Yes of course you can, just follow this guide:

Regards.,

Thanks, that did it.

Do you know by any chance I should report this bug?

Yes you can report in RedHat bugzilla with your FAS account, follow this procedure

https://docs.fedoraproject.org/en-US/quick-docs/howto-file-a-bug/

Regards.,

Hey, but this package comes from a third party repository, isn’t it?

1 Like

Yes I think so. Your message made me realize the repo was for Fedora 29 (I just updated to Fedora 30).
After I changed the repo it now works fine, thanks all for your help!

1 Like