Updating GNOME causes User Account to go "all black"

Whilst doing some OS update in the Software Store (I hate that app), it updated and pootched my user account.

Logging into either GNOME and GNOME Classic gets me a BLACK SCREEN, but I can move the mouse. Oh joy.

I can log into Root, no issues.

I created a second account, logged in, NO ISSUES.

Therefore, this issue is limited to only this user account.

So, I’d like to fix it.

I’d like to log in using a non-graphic shell

systemctl set-default multi-user.target

reboot

and then perform some command line magic to fix it.

I just don’t know what magic will work. Please suggest some magic.

Thank you.

2 Likes

Hello @thebigduck! Welcome to Fedora!

Can you look at your logs to see if there’s anything that suggests what the issue may be?

journalctl -b

More information on viewing logs is here on the quick-docs: https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

Given that it works in a new user, it could be a gnome-shell-extension. You can use the gnome-shell-extension-tool to disable them and test this. Please use gnome-shell-extension-tool --help to see how to use it. You can get the names of the extensions from their installation folder names:

ls ~/.local/share/gnome-shell/extensions/
1 Like

Thanks.
I’ll keep this info for future reference.
For now, I found a ISO for F29 and I re-installed it and my system is rock solid again.

I’ll consider F30 in a few months after the issues have been worked out. While I understand that many people had a flawless update experience, mine (and many others) were a nightmare.

I can wait.

If it’s a gnome-shell-extension that is breaking it, it’ll remain broken until the issue is reported and the developer fixes it. Theres nothing Fedora or GNOME can do about it, unfortunately. It isnt related to the Fedora upgrade process or release, it is basically the extension developer not updating the extension to follow the new API :slightly_frowning_face: