Upgrade from Fedora 34 to Fedora 35 failing due to LaTeX incompatibility

Hi everyone,
I hope you’re fine.
I used the GUI to upgrade Fedora from 34 to 35, but just before reaching the end of the progress bar (downloading the new packages), I get the following error:
image
According to the message, there is a package conflict between the old texlive-hyperxmp-doc-9 package and the new (Fedora 35) texlive-hyperxmp-9 package. I don’t remember having installed any of these packages.
How to solve this?
Thanks

2 Likes

Remove the old package sudo dnf remove texlive-hyperxmp-doc-9 in Terminal.

3 Likes

It is not installed:
image

You could have installed it with othet software.
Open terminal and do cd /usr/share/texlive/texmf-dist/doc/latex/

The last digit is not part of the package name, but is part of its version.
You can simply omit the version when addressing the package with DNF.

2 Likes

You were right @vgaetera thanks, it work removing it without the last digit in the name.

2 Likes