Upgrade to Fedora 33 breaks down

Hello,

I am trying to update from Fedora 32 to 33. First I tried to make it via command line version, as it was running at previous updates. However, now it breaks down claiming that something from python package were missing. I have tried to install the missing packages manually, but dnf has responded that the packages were already installed.

Then I have tried to make it via the Software utility of Fedora. Software downloads the Fedora 33 package, but when I tried to run the update, it broke down becuase of another package missing from python. I have tried to installed the package mentioned there, but dnf responded again that hte module were installed.

Could you please help forward with the issue?

Istvan

Try to upgrade from CLI and post exact error messages.

Hello,

please find below the error message.

 ~  sudo dnf system-upgrade download --releasever=33                                         2.8m  Mon 09 Nov 2020 07:40:01 PM CET
[sudo] password for sztyopa: 
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Adobe Systems Incorporated                                                                          6.5 kB/s | 2.9 kB     00:00    
created by dnf config-manager from https://brave-browser-rpm-release.s3.brave.com/x86_64/            21 kB/s | 3.3 kB     00:00    
CERT Forensics Tools Repository                                                                     1.1 kB/s | 3.0 kB     00:02    
CERT Forensics Tools Repository - Splunk                                                            498  B/s | 3.0 kB     00:06    
etcher-rpm                                                                                          1.7 kB/s | 1.3 kB     00:00    
Fedora 33 openh264 (From Cisco) - x86_64                                                            378  B/s | 543  B     00:01    
Fedora Modular 33 - x86_64                                                                           39 kB/s |  23 kB     00:00    
Fedora Modular 33 - x86_64 - Updates                                                                 44 kB/s |  22 kB     00:00    
Fedora 33 - x86_64 - Updates                                                                         40 kB/s |  20 kB     00:00    
Fedora 33 - x86_64 - Updates                                                                        546 kB/s | 1.9 MB     00:03    
Fedora 33 - x86_64                                                                                  130 kB/s |  24 kB     00:00    
google-chrome                                                                                       8.2 kB/s | 1.3 kB     00:00    
google-chrome                                                                                        18 kB/s | 3.6 kB     00:00    
repo for iridium-browser-project                                                                     16 kB/s | 3.0 kB     00:00    
Node.js Packages for Fedora Linux 32 - x86_64                                                       2.4 kB/s | 2.5 kB     00:01    
NordVPN YUM repository - x86_64                                                                     485  B/s | 2.5 kB     00:05    
NordVPN YUM repository - noarch                                                                     9.0 kB/s | 2.5 kB     00:00    
Opera packages                                                                                       12 kB/s | 2.9 kB     00:00    
RPM Fusion for Fedora 33 - Free - Updates                                                            11 kB/s | 6.9 kB     00:00    
RPM Fusion for Fedora 33 - Free - Updates                                                           140 kB/s | 212 kB     00:01    
RPM Fusion for Fedora 33 - Free                                                                      56 kB/s | 7.5 kB     00:00    
RPM Fusion for Fedora 33 - Nonfree - NVIDIA Driver                                                   21 kB/s | 7.3 kB     00:00    
RPM Fusion for Fedora 33 - Nonfree - Steam                                                          5.0 kB/s | 7.0 kB     00:01    
RPM Fusion for Fedora 33 - Nonfree - Updates                                                         19 kB/s | 7.1 kB     00:00    
RPM Fusion for Fedora 33 - Nonfree - Updates                                                         66 kB/s |  65 kB     00:00    
RPM Fusion for Fedora 33 - Nonfree                                                                   62 kB/s | 7.6 kB     00:00    
skype (stable)                                                                                       11 kB/s | 2.9 kB     00:00    
vivaldi                                                                                              17 kB/s | 2.9 kB     00:00    
Yarn Repository                                                                                      13 kB/s | 2.9 kB     00:00    
No match for group package "xorg-x11-drv-armsoc"
No match for group package "powerpc-utils"
No match for group package "lsvpd"
No match for group package "wallpoet-fonts"
No match for group package "oflb-roadstencil-fonts"
No match for group package "senamirmir-washra-yigezu-bisrat-gothic-fonts"
No match for group package "astloch-fonts"
No match for group package "dwm"
No match for group package "kranky-fonts"
No match for group package "google-noto-sans-balinese-fonts"
No match for group package "tlomt-orbitron-fonts"
No match for group package "pagul-fonts"
No match for group package "scim-chewing"
No match for group package "moyogo-molengo-fonts"
No match for group package "labelleaurore-fonts"
No match for group package "google-croscore-cousine-fonts"
No match for group package "scim-tables-chinese-extra"
No match for group package "oflb-icelandic-fonts"
No match for group package "senamirmir-washra-jiret-fonts"
No match for group package "senamirmir-washra-wookianos-fonts"
No match for group package "mph-2b-damase-fonts"
No match for group package "min12xxw"
No match for group package "monofett-fonts"
No match for group package "kexec-tools-anaconda-addon"
No match for group package "reeniebeanie-fonts"
No match for group package "cf-sorts-mill-goudy-fonts"
No match for group package "xorg-x11-drv-geode"
No match for group package "typemade-josefinsansstd-light-fonts"
No match for group package "ht-alegreya-smallcaps-fonts"
No match for group package "vt323-fonts"
No match for group package "google-croscore-arimo-fonts"
No match for group package "shadowsintolight-fonts"
No match for group package "senamirmir-washra-yigezu-bisrat-goffer-fonts"
No match for group package "carterone-fonts"
No match for group package "oflb-brett-fonts"
No match for group package "phetsarath-fonts"
No match for group package "apanov-edrip-fonts"
No match for group package "senamirmir-washra-zelan-fonts"
No match for group package "smc-raghumalayalam-fonts"
No match for group package "google-droid-kufi-fonts"
No match for group package "ecolier-court-lignes-fonts"
No match for group package "cyreal-wireone-fonts"
No match for group package "isight-firmware-tools"
No match for group package "google-croscore-tinos-fonts"
No match for group package "totem-nautilus"
No match for group package "WritRecogn"
No match for group package "paratype-pt-sans-caption-fonts"
No match for group package "fedora-user-agent-chrome"
No match for group package "trabajo-fonts"
No match for group package "scim-array"
No match for group package "senamirmir-washra-fantuwua-fonts"
No match for group package "google-croscore-symbolneu-fonts"
No match for group package "senamirmir-washra-tint-fonts"
No match for group package "senamirmir-washra-yebse-fonts"
No match for group package "tuladha-jejeg-fonts"
No match for group package "senamirmir-washra-hiwua-fonts"
No match for group package "impallari-lobster-fonts"
No match for group package "aldusleaf-crimson-text-fonts"
No match for group package "almas-mongolian-title-fonts"
No match for group package "tharlon-fonts"
No match for group package "smc-kalyani-fonts"
No match for group package "kinput2"
No match for group package "bcm283x-firmware"
No match for group package "inkboy-fonts"
No match for group package "sarai-fonts"
No match for group package "scim-tables-chinese"
No match for group package "specialelite-fonts"
No match for group package "deepin-screen-recorder"
No match for group package "uim-canna"
No match for group package "stix-math-fonts"
No match for group package "xorg-x11-drv-omap"
No match for group package "tangerine-fonts"
No match for group package "scim-tables-additional"
No match for group package "google-noto-sans-ui-fonts"
No match for group package "oflb-sportrop-fonts"
Error: 
 Problem 1: package PackageKit-gtk3-module-1.1.13-3.fc32.i686 requires PackageKit-glib(x86-32) = 1.1.13-3.fc32, but none of the providers can be installed
  - PackageKit-glib-1.1.13-3.fc32.i686 does not belong to a distupgrade repository
  - problem with installed package PackageKit-gtk3-module-1.1.13-3.fc32.i686
 Problem 2: package gufw-19.10.0-1.noarch requires python(abi) = 3.8, but none of the providers can be installed
  - python3-3.8.6-1.fc32.x86_64 does not belong to a distupgrade repository
  - problem with installed package gufw-19.10.0-1.noarch
(try to add '--skip-broken' to skip uninstallable packages)

1 Like

Also list your repositories:

dnf -q repolist

Hello,

thanks for your support! The repos are the following:

repo id                                        repo name
adobe-linux-x86_64                             Adobe Systems Incorporated
brave-browser-rpm-release.s3.brave.com_x86_64_ created by dnf config-manager from https://brave-browser-rpm-release.s3.brave.com/x86_64/
etcher-rpm                                     etcher-rpm
fedora                                         Fedora 32 - x86_64
fedora-cisco-openh264                          Fedora 32 openh264 (From Cisco) - x86_64
fedora-modular                                 Fedora Modular 32 - x86_64
forensics                                      CERT Forensics Tools Repository
forensics-splunk                               CERT Forensics Tools Repository - Splunk
google-chrome                                  google-chrome
iridium-browser-project                        repo for iridium-browser-project
nodesource                                     Node.js Packages for Fedora Linux 32 - x86_64
nordvpn                                        NordVPN YUM repository - x86_64
nordvpn-noarch                                 NordVPN YUM repository - noarch
opera                                          Opera packages
rpmfusion-free                                 RPM Fusion for Fedora 32 - Free
rpmfusion-free-updates                         RPM Fusion for Fedora 32 - Free - Updates
rpmfusion-nonfree                              RPM Fusion for Fedora 32 - Nonfree
rpmfusion-nonfree-nvidia-driver                RPM Fusion for Fedora 32 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                        RPM Fusion for Fedora 32 - Nonfree - Steam
rpmfusion-nonfree-updates                      RPM Fusion for Fedora 32 - Nonfree - Updates
skype-stable                                   skype (stable)
updates                                        Fedora 32 - x86_64 - Updates
updates-modular                                Fedora Modular 32 - x86_64 - Updates
vivaldi                                        vivaldi
yarn                                           Yarn Repository
1 Like

Check the available package versions:

dnf -q --showduplicates list python3

Try to remove this package:

sudo dnf remove PackageKit-glib.i686
1 Like

Hello,

I have executed both commands, however the upgrade is still not running. Please, find the response below. Thanks for your support!

Istvan

dnf -q --showduplicates list python3                                                    33.4m  Wed 11 Nov 2020 06:52:33 PM CET
Importing GPG key 0x12C944D0:
 Userid     : "Fedora (32) <fedora-32-primary@fedoraproject.org>"
 Fingerprint: 97A1 AE57 C3A2 372C CA3A 4ABA 6C13 026D 12C9 44D0
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-32-x86_64
Is this ok [y/N]: y
Installed Packages
python3.x86_64                                                 3.8.6-1.fc32                                                 @updates
Available Packages
python3.i686                                                   3.8.2-2.fc32                                                 fedora  
python3.x86_64                                                 3.8.2-2.fc32                                                 fedora  
python3.i686                                                   3.8.6-1.fc32                                                 updates 
python3.x86_64                                                 3.8.6-1.fc32                                                 updates 
 ~  sudo dnf remove PackageKit-glib.i686                                                     2.5m  Wed 11 Nov 2020 06:55:22 PM CET
Dependencies resolved.
====================================================================================================================================
 Package                                  Architecture           Version                           Repository                  Size
====================================================================================================================================
Removing:
 PackageKit-glib                          i686                   1.1.13-3.fc32                     @updates                   526 k
Removing dependent packages:
 PackageKit-gtk3-module                   i686                   1.1.13-3.fc32                     @updates                    34 k

Transaction Summary
====================================================================================================================================
Remove  2 Packages

Freed space: 560 k
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                            1/1 
  Erasing          : PackageKit-gtk3-module-1.1.13-3.fc32.i686                                                                  1/2 
  Erasing          : PackageKit-glib-1.1.13-3.fc32.i686                                                                         2/2 
  Running scriptlet: PackageKit-glib-1.1.13-3.fc32.i686                                                                         2/2 
  Verifying        : PackageKit-glib-1.1.13-3.fc32.i686                                                                         1/2 
  Verifying        : PackageKit-gtk3-module-1.1.13-3.fc32.i686                                                                  2/2 

Removed:
  PackageKit-glib-1.1.13-3.fc32.i686                            PackageKit-gtk3-module-1.1.13-3.fc32.i686                           

Complete!


 ~  sudo dnf system-upgrade download --releasever=33                                         6.2s  Wed 11 Nov 2020 07:05:17 PM CET
.....
No match for group package "oflb-brett-fonts"
No match for group package "tangerine-fonts"
Error: 
 Problem: package gufw-19.10.0-1.noarch requires python(abi) = 3.8, but none of the providers can be installed
  - python3-3.8.6-1.fc32.x86_64 does not belong to a distupgrade repository
  - problem with installed package gufw-19.10.0-1.noarch
(try to add '--skip-broken' to skip uninstallable packages)

1 Like

It seems to be a blocker, so let’s try to remove it and try again:

sudo dnf remove gufw

@ebedli: please use the formatting tools to make your posts more readable. I’ve edited them now.

If you’ve not had a chance yet, please go through the introductory posts in the #start-here category. They explain how to do this and more.

1 Like

Hi,
thanks for the suggestion, it has solved the problem!
Best regards,
Istvan

1 Like