Upgraded to 36 Workstation and enabled dark mode, some programs don't run in dark mode

While on 35, I had adwaita-dark set through gnome-tweaks.
Before upgrading to 36, reset that to light mode and uninstalled gnome-tweaks.

After upgrading to 36, I chose to enable dark mode.

I should expect programs like Thunderbird, firewall-config, AisleRiot to be in dark mode as well, right? They seem to have remained in light mode, and I don’t know what to do to make them follow the system theme.

First comment https://bugzilla.redhat.com/show_bug.cgi?id=2073674#c1 in this bug report might relate to this.

Many apps set their own themes and do not follow the system themes.

Some apps are still GTK3 and wont use libadwaita. One option is to install the adw-gtk3 theme https://github.com/lassekongo83/adw-gtk3 and reinstall gnome-tweaks and set legacy-theme to adw-gtk ( dark or light ). There is also a flatpak theme to theme those too

1 Like

Install gnome-tweak-tool, then set adwaita-dark as the theme for legacy apps

1 Like

Yeah, hiding the issue won’t do for me. User experience can be better when there’s no need for extra steps.

I’ll keep it as is and try to get the apps ported to GTK4, or adapted to use the system preference.

1 Like

Right now I’m not exactly in love with GTK4 font rendering (everything’s a little blurry), so I’m happy to have some GTK3 apps on my system.

In which directory of the user’s is the dark mode set for individual apps?

Your question might warrant its own topic to increase the chances of being seen and getting good responses, don’t you agree?

Yes, I agree. Thank you.

Gnome 42: I'm .. freaking out about color scheme consistency, I just want this to work - #2 by blueshurricane4