Upgrading from 30 to 31 does not go through

HI, I am following I think the right procedure to upgrade my fedora 30 to 31, steps followed
dnf upgrade --refresh
sudo dnf system-upgrade download --releasever=31

Ignoring repositories: mysql56-community
Error:
Problem 1: package spambayes-1.1-0.10.b1.fc21.noarch requires python-lockfile, but none of the providers can be installed

  • python2-lockfile-1:0.11.0-13.fc30.noarch does not belong to a distupgrade repository
  • problem with installed package spambayes-1.1-0.10.b1.fc21.noarch

Problem 2: package system-config-kickstart-2.10.0-1.fc28.noarch requires python2-kickstart, but none of the providers can be installed

  • python2-kickstart-3.20-2.fc30.noarch does not belong to a distupgrade repository
  • problem with installed package system-config-kickstart-2.10.0-1.fc28.noarch
    (try to add ‘–skip-broken’ to skip uninstallable packages)

Then I issued
sudo dnf system-upgrade --allowerasing download --releasever=3 --best --skip-broken

I started getting errors related to fedora_modular module as follows

Fedora Modular 3 - x86_64 26 kB/s | 63 kB 00:02
Errors during downloading metadata for repository ‘fedora-modular’:

  • Status code: 404 for …mirrors.fedoraproject.org/metalink?repo=fedora-modular-3&arch=x86_64 (IP: 85.236.55.6)
  • Status code: 404 for …mirrors.fedoraproject.org/metalink?repo=fedora-modular-3&arch=x86_64 (IP: 2001:4178:2:1269::fed2)
  • Status code: 404 for …mirrors.fedoraproject.org/metalink?repo=fedora-modular-3&arch=x86_64 (IP: 2620:52:3:1:dead:beef:cafe:fed7)
    Error: Failed to download metadata for repo ‘fedora-modular’: Cannot prepare internal mirrorlist: Status code: 404 for …mirrors.fedoraproject.org/metalink?repo=fedora-modular-3&arch=x86_64 (IP: 2620:52:3:1:dead:beef:cafe:fed7)

I followed instructions here at thread

added fastmirror = false and zchcunk as indicated , I get the exact same error. Am I missing something?

Do you mean --releasever=31?

1 Like

Yes this is a typo sorry for it

And what happens then?

florian all details in my initial post

The initial post shows that it failed because you typed 3 instead of 31.

Did it work when you tried 31? If not, can you share those errors?

1 Like

In fact, I rebooted the VM, I started to get errors for a couple of packages (mysql56-community & gimp)
I did

sudo dnf config-manager --set-disabled mysql56-community
sudo dnf module reset gimp
then the
system-upgrade --allowerasing download --releasever=31 --best --skip-broken

went through
Thanks for your help

1 Like

Coming back to the original Problems that dnf complained about. To avoid problems for future updates and/or system-upgrades, it would be good to search for the old .fc21, .fc28, and .fc30 packages and remove them.