Upgrading from 30 to 33 - gpg / curl error

I am trying to upgrade to 33, but the command :

sudo dnf system-upgrade download --refresh --releasever=33 --skip-broken --allowerasing

gives me the following errors :

warning: /var/lib/dnf/system-upgrade/updates-f882f705d68c7676/packages/alsa-sof-firmware-1.6-1.fc33.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 9570ff31: NOKEY
Fedora 33 - x86_64 - Updates                                      0.0  B/s |   0  B     00:00    
Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-33-x86_64 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-33-x86_64]

I’ve tried with v32, and I’m getting this errors instead :

warning: /var/lib/dnf/system-upgrade/fedora-6463db1a10fa578d/packages/c-ares-1.15.0-5.fc32.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 12c944d0: NOKEY
Fedora 32 - x86_64                                                143 kB/s | 1.6 kB     00:00    
Importing GPG key 0x12C944D0:
 Userid     : "Fedora (32) <fedora-32-primary@fedoraproject.org>"
 Fingerprint: 97A1 AE57 C3A2 372C CA3A 4ABA 6C13 026D 12C9 44D0
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-32-x86_64
Is this ok [y/N]: y
Key imported successfully
warning: /var/lib/dnf/system-upgrade/remi-modular-3cc3da1e83f386c0/packages/php-pecl-imagick-3.4.4-9.fc32.remi.7.4.x86_64.rpm: Header V4 RSA/SHA256 Signature, key ID 4c21a808: NOKEY
Remi's Modular repository - Fedora 32 - x86_64                    0.0  B/s |   0  B     00:00    
Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi-32 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-remi-32]

I’m not sure what to do here…
I’ve tried the suggestion from this : I cant update fedora 32, curl error 37
But it did not solve my problem.

I’m willing to remove any problematic package in order to upgrade… cheers !

1 Like

You can fetch the keys here:

But upgrading across multiple releases can be problematic.

1 Like

Hi and thanks for your answer.
I’m only trying to upgrade to 33.

Sorry but could you be more precise on what I have to do exactly to solve my issue? I don’t how to start about it with what you gave me…

Skipping releases is the problem.
It might be easier to upgrade consecutively.

curl KEY_URL | gpg --import
gpg --list-keys
gpg --armor --export KEY_ID | sudo tee /path/to/file
1 Like

Thanks for your help.
I thought that when upgrading from 30 to 33, the installation process would go through 31 and 32…

In the end, I had to disable some problematic module (php-remi), but upgrading first to 31, then to 32, then to 33, everything went smoothly !

1 Like