Upgrading to F34: iptables issues

Has anybody found solution to the following problems?

 Problem: cannot install both iptables-libs-1.8.7-6.fc34.x86_64 and iptables-libs-1.8.7-3.fc34.x86_64
  - package iptables-1.8.7-3.fc34.x86_64 requires iptables-libs(x86-64) = 1.8.7-3.fc34, but none of the providers can be installed
  - cannot install the best update candidate for package iptables-libs-1.8.5-6.fc33.x86_64
  - cannot install the best update candidate for package iptables-1.8.5-6.fc33.x86_64

And

No match for group package "scim-tables-chinese"
No match for group package "scim-tables-nepali"
No match for group package "scim-tables-arabic"
No match for group package "authconfig"
No match for group package "scim-tables-vietnamese"
No match for group package "kexec-tools-anaconda-addon"
No match for group package "scim-chewing"
No match for group package "scim-tables-amharic"
No match for group package "isdn4k-utils"
No match for group package "scim-tables-thai"
No match for group package "fedora-release-notes"
No match for group package "plasma-workspace-drkonqi"
No match for group package "scim-tables-ukrainian"
No match for group package "scim-tables"
No match for group package "plasma-user-manager"
No match for group package "system-config-users"
No match for group package "dnf-yum"
No match for group package "kipi-plugins"
No match for group package "scim-tables-chinese-extra"
No match for group package "scim-tables-additional"
No match for group package "scim-tables-russian"
No match for group package "iok"
No match for group package "ibus-pygtk2"
No match for group package "coolkey"
No match for group package "phonon-backend-gstreamer"
No match for group package "ibus-xkbc"
No match for group package "scim-array"
No match for group package "system-config-services"
No match for group package "ibus-py2override"
No match for group package "paratype-pt-sans-fonts"
1 Like

Remove the problematic package:

sudo rpm --nodeps -e iptables

Proceed with upgrade by adding the --skip-broken key.

https://bugzilla.redhat.com/show_bug.cgi?id=1953178

https://fedoraproject.org/wiki/Common_F34_bugs#Upgrade_does_not_install_latest_version_of_iptables.2C_or_fails_on_iptables_if_--best_is_used

1 Like

I’ve split your question to a new topic now. Please do not use other topics for queries—it’s best to start new topics so that topics and their solutions match.

2 Likes

at least it’s a known bug, it’s already that. thanks

1 Like

It should be fixed already:
https://bodhi.fedoraproject.org/updates/FEDORA-2021-aa7ad6f57f

2 Likes

I had the same problem, but I solved it that way!
after run: dnf --refresh upgrade
add --allowerasing: dnf system-upgrade download --refresh --releasever=34 --allowerasing

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.