Upgrading to Fedora 32 network resets

I am upgrading from 31 to 32 using the MATE Spin. My network devices (wired and wireless) keep resetting.

PCI 10ec:8168:1179:f920 »
/ 02-00 Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller network r8169 detected
PCI 8086:08b3:8086:8170 »
/ 02-80 Intel Corporation Wireless 3160 network iwlwifi works

Could you go into detail? What do you mean by “reset”?

  • They keep shutting off and then coming back on.
  • The configuration keeps changing.
  • etc

Hi, yes, so the connection to my wifi AND wired connection both are shutting off or disabling and then turning back on or re-enabling.

The configuration hasn’t changed at all.
I wasn’t having this issue with F31.

Thanks!

That’s very strange. Can you give some output information about your machine?

  1. $ fpaste --sysinfo
  2. $ rpm -qa | fpaste
  3. $ ps aux | fpaste

Now that I think about it, it started with a recent version of the 5.6 kernel on F31.

https://paste.centos.org/view/7ae0cfcc
https://paste.centos.org/view/efe2f497

https://paste.centos.org/view/1aa5189b

So, I don’t see anything really wrong. There’s a network-manager-applet installed that /might/ be sending some irregular “commands” to NetworkManager. However, I wouldn’t say 100% for sure that is the issue.

Let’s do this: Print out the journalctl logs from the current boot and see if we can find out what’s triggering the network to restart:

$ sudo journalctl -d | fpaste

There is no -d. Did you mean -xe?

Sorry, no - I mean’t -b.

asm-junk-fedora1 :slight_smile: > sudo journalctl -b | fpaste
[sudo] password for ameyer:
WARNING: your paste size (2259.0KiB) is very large and may be rejected by the server. A pastebin is NOT a file hosting service!
Uploading (2259.0KiB)…
Error Uploading: Internal Server Error

There’s too much data for fpaste. Can you output it to a text file and upload that file somewhere?

$ sudo journalctl -b | fpaste > /tmp/journalctl-from-last-boot.out

https://drive.google.com/file/d/14YLOF0oe6bPJrEnYSomsLwN7oH9xZMdA/view?usp=sharing

Sorry, I do not have a Google account to request access to that link.

If I didn’t know any better, I’d say that the NetworkManager dispatch service is experiencing a bug.

Try this:

$ sudo systemctl stop NetworkManager-dispatcher
$ sudo systemctl disable NetworkManager-dispatcher
$ sudo systemctl mask NetworkManager-dispatcher

Afterwards, monitor and see if the constant disconnect and reconnect continues happening.

On an unrelated note, you may want to check out the variety process, as it looks to be coredumping:

May 26 08:44:00 asm-junk-fedora1.meyer.local systemd-coredump[24816]: Process 1997 (variety) of user 1000 dumped core.

1 Like

That seems to have fixed it.
Thank you!

1 Like

This is worth reporting. Could you please install abrt if it isn’t installed and use it to report the bug?

https://docs.fedoraproject.org/en-US/quick-docs/howto-file-a-bug/

1 Like

As soon as I get time I will.

2 Likes

And its doing it again with the most recent round of updates…

1 Like