User Logon Does not complete

I have been migrating from SLED 15 to F32. I have /home on a RAID1 set and can see it from F32. Got the F32 install done and have applied updates to it. And I pulled in KUser.

So still with root, I defined my ID (as it was with SLED 15) and told the system do not create a /home directory (so it saw and used my old /home/uid). So far so good.

Dolphin (?) I selected my directory and set it all to be owned by my id and “users” (which was true of SLED 15).

And I set my password and then logged out of root.

So the logon screen comes up (and since I did a KDE install, I’m assuming a KDM manager) with my userid, and so I put in the password. It rejected it. Ok, must of fat fingered that so back to root, slam the password and back to user…

So put in the password and it accepts it. 10 minutes later I still have a mouse pointer, some disk activity of some kind and I do not have a KDE environment.

Could someone point me in the right direction? What could I have mangled that F32 can see /home using the raid1, mount shows it mounted to /home, etc. But when I attempt to long on the userid, I do not get into a KDE environment (actually I just have a black screen with a mouse and you can’t type on/or in it, and I can’t get to a text console either).

I know enough to be dangerous. I think I’ve proven this a few times now.

1 Like

When you say “still with root”, is this after the installation?

Generally, the best way to re-use a /home partition is to select it during installation. That also updates the permissions/selinux contexts as required.

I would think the issue here is with permissions and selinux too. Could you look at the journal to see if there are any errors there? A chown -R /home/... may be needed, along with a restorecon to fix things.

Yes. And I was trying to avoid any ambiguity as to the situation. In otherwords, I was not using some authorized ID to do the work, I was root in this case.

So, in using Dolphin and setting permissions, I assume it did the chown under the covers as it were (I’ve done this with openSuse 11.x, Lindows, and one other distro).

And I absolutely agree that /home needs to be done during the installation. That’s why I did it that way. And so I assumed that when I built the userid using the line command, and the options to say use the existing /home/userid, that, as you say, should have all been handled at that those points (the mount and processing of /home during the install, the setting of the userid to that /home/userid entry, etc.).

The problem appears to me to be the lack of a Display Manager. And I did not see where Kuser would take/accept a request for a display manager.

Now, if you want a journal entry, please tell me how to get to what you want. And the next time around, I’ll do my best to capture it and post it here (and if I do this under F32, that will mean I actually got in, otherwise I will be posting here from SLED15).

Also, restorecon, isn’t that really for a webpage/site restore of files? Is that how a Display Manager operates – via HTML?

I said, I know enough to be dangerous.

Thanks for the ideas.
Wylbur

1 Like

The ideal place to look would be in the journal logs when you fail to login. You can switch to a tty using ctrl + alt + f3. That’ll get you to a terminal where you can look at the logs. More information here:

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

No, restorecon restores the selinux context for files. If the selinux context is wrong, you’ll get permission denied errors even if the file ownership etc is correct.

https://man7.org/linux/man-pages/man8/restorecon.8.html

You can set selinux to permissive mode on boot to work around this for the time being. If that lets you login, we know that you need to fix your selinux contexts:

https://docs.fedoraproject.org/en-US/quick-docs/changing-selinux-states-and-modes/#selinux-Enabling_and_Disabling_SELinux-Dracut-parameters

Update: I found that my user account did not include “user” and upon getting that done, I now get the logon display, and it takes the password, and a few moments later puts the logon display back up. So that is progress.

The links for logs failed. I got 404 errors. But I was able to work a bit more on this last night (I’m time constrained). So I have been looking at how to get log info… I’ll eventually get back here.

1 Like