Using multiple languages on Fedora 32 xfce4

I use multiple languages in my daily work. I can not find any input switcher to switch from one keyboard layout to another. No program exists, as far as I can tell, that will undertake to implement this switch.

And yet, I seem to remember an Icon in the upper panel that would, for example, display “PT”, indicating that my keyboard was in Portuguese mode. A hot-key combination would switch this back to “EN” (English) or “JA” for Japanese. Yet I can’t find anything like that in in the xfce desktop.

It’s possible that I am remembering this display from the Cinnamon desktop, which I used before I switched to xfce.

I have searched with dnf, I have used man -k, info, scoured the menus, but I have gotten nowhere.

Please tell me what I am missing.

1 Like

I’m not an XFCE4 expert but a quick search I found this for you:

Is this doesn’t help just tell us.

Regards.,

2 Likes

10 years later, still the same package…

1 Like

I tried setxkbmap, and I am sure I got the options right, but now my Japanese input in Emacs no longer works (it was the only place I could type in Japanese). My keyboard seems to be in an unknown state. I tried to reset the keyboard to its former state using setxkbmap, but I got an error message. Also, I used to be able to switch input methods using Left Alt + Right Alt, but that no longer works.

Any suggestions on how to reset my keyboard to defaults, or to input text in Japanese, Brazilian Portuguese, and English(US)?

Thanks,

BryGuy

Did you have a backup before the changes?

With the latest versions of fedora most of the user configurations are stored under the users home directory.
Try looking under the ~/.config or ~/.local/share directories.

Here is one other possibility, although there is a price.
If you are using a logitech keyboard with the universal receiver (wireless) you could maybe get a different keyboard for each language that has its own keyboard and pair them all to the same receiver. That would mean you would only need to switch the keyboard you were using for each language and that might help fix the issue

From your description about japanese and emacs I would suspect that emacs itself was doing the mapping for that which could mean that any change in keyboard input might break the mapping.

Try Typing booster. https://mike-fabian.github.io/ibus-typing-booster/ I use it for BG and NL and US languages and keyboards. its in Fedora Packages. Just do sudo dnf install ibus-typing-booster
in Terminal.