Vdpau with nvidia optimus - prime offload rendering

Hi,

Does anyone knows if vdpau is supported with nvidia optimus card prime offload rendering?

My laptop has an Intel Graphics Card and a GeForce GTX 960M.
I have the nvidia drivers installed (from repo negativo17 - Nvidia), everything works fine, i can run games and most applications using the nvidia card with __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia, but mpv,mplayer,vlc can’t use hardware acceleration video decoding:

export VDPAU_DRIVER=nvidia
export LIBVA_DRIVER_NAME=vdpau
__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia vdpauinfo

display: :0 screen: 0
Error creating VDPAU device: 1

Anyone has any idea?

Hi, maybe you could read here on part Configruing VDPAU. On there also mentioning PRIME on note section.

It is possible the driver you have installed from negativo17 is not the same as the driver that has been tweaked specifically for fedora at rpmfusion. I don’t know if it will make a difference but you may want to enable the rpmfusion repo and install the drivers from there instead.

If you are using fedora 34 or older the rpmfusion repos can be enabled as shown here. If running fedora 35 the appropriate rpmfusion repo can be enabled in the gnome software center then selecting to enable 3rd party repos.

You can then use dnf to install the appropriate akmod-nvidia package which will also pull in all needed dependencies. (it may also be necessary to disable the negativo17 repo when doing so.)

1 Like

Hi,

I just removed the negativo17 packages, and installed from rpmfusion, still same problem.

There is what seems a similar problem with hardware gpu acceleration discussed and maybe solved here.