VLC player installed from RPMFusion crashes with all videos

Hello,
Suddenly VIDEOLAN stopped working. The program opens normally but when I try to play a video the program crashes and closes.
I am using Fedora 30 and when I try to play a video these messages appear on the console:

    000056471e79d670] main audio output error: too low audio sample frequency (0)
    [00007f4354d048a0] main decoder error: failed to create audio output
    [000056471e79d670] vlcpulse audio output error: digital pass-through stream connection failure
    : Não suportado
    [000056471e79d670] main audio output error: module not functional
    [00007f4354d048a0] main decoder error: failed to create audio output
    uint DBusMenuExporterDBus::GetLayout(int, int, const QStringList&, DBusMenuLayoutItem&): Condi
    tion failed: menu
    uint DBusMenuExporterDBus::GetLayout(int, int, const QStringList&, DBusMenuLayoutItem&): Condi
    tion failed: menu
    libva info: VA-API version 1.4.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
    libva info: va_openDriver() returns -1
    [00007f4340004f90] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error
    libva info: VA-API version 1.4.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
    libva info: va_openDriver() returns -1
    [00007f4340004f90] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
    libva info: VA-API version 1.4.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
    libva info: va_openDriver() returns -1
    [00007f4340004f90] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
    libva info: VA-API version 1.4.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/nouveau_drv_video.so
    libva info: Found init function __vaDriverInit_1_4
    KCrash: Application 'vlc' crashing...

Thanks so much for any help

I would file an issue or bug with the developers at Videolan

Hello @bionan2017.
Just to have more information.
Did you install VLC from rpmfusion?
Did you update it recently?
The issue arise playing any video?

Hello, alciregi
yes I installed the program through the rpmfusion.
yes, the issue arise playing any video
No, I haven’t updated the program recently

Thank you.

Similar issue. Crashes almost every video in every player (VLC, xine, …).
I did some updates yesterday. Looked at them, I downgraded all mesa* packages and the problem has gone.

I just hit the same issue on VLC. I followed @ludvahomolka advice and I downgraded all mesa-* packages. Now VLC is fine.

1 Like

Hi, i have the same issue too with a fresh install, even with multimedia codecs not installed.

Hi @ludvahomolka, @musuruan @nideto! Welcome to the community! Please have a look at the introductory posts in the #start-here category if you’ve not yet had a chance to do so.

Could you please give us the details of the dnf transaction so we know what versions of packages were installed/downgraded? (feel free to edit your post and add the info there)

sudo dnf history list  # will list all transactions with their ids
sudo dnf history info <transaction id>     # will provide complete details about the transaction

Everyone experiencing the issue, please tell us the version of vlc that you are running:

rpm -q vlc

Then, please run vlc from the terminal and tell us what the output is. Maybe that’ll provide some information on the crash:

vlc --verbose=2 /path/to/file

If you can also go through the system logs and see what is added after the crash, that would also be helpful

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

Edit: there’s a thread on the RPMFusion mailing list about this, but it wasn’t solved. Maybe worth bumping too:

https://lists.rpmfusion.org/archives/list/rpmfusion-users@lists.rpmfusion.org/thread/USIQI6ITEQWN3PYUEW7MA5FGZ35YBHYM/

I was also hitting this error - the mesa downgrade fixed things for me as well. dmesg was reporting the crash occurred in nouveau_drv_video.so .

Updates applied:

[code] Packages Altered:

Install  kernel-5.1.20-300.fc30.x86_64                        @updates
Install  kernel-core-5.1.20-300.fc30.x86_64                   @updates
Install  kernel-modules-5.1.20-300.fc30.x86_64                @updates
Install  kernel-modules-extra-5.1.20-300.fc30.x86_64          @updates
Install  libssh-config-0.9.0-5.fc30.noarch                    @updates
Upgrade  Thunar-1.8.8-1.fc30.x86_64                           @updates
Upgraded Thunar-1.8.7-1.fc30.x86_64                           @@System
Upgrade  container-selinux-2:2.111.0-1.fc30.noarch            @updates
Upgraded container-selinux-2:2.107-1.git453b816.fc30.noarch   @@System
Upgrade  dnf-4.2.7-2.fc30.noarch                              @updates
Upgraded dnf-4.2.5-2.fc30.noarch                              @@System
Upgrade  dnf-automatic-4.2.7-2.fc30.noarch                    @updates
Upgraded dnf-automatic-4.2.5-2.fc30.noarch                    @@System
Upgrade  dnf-data-4.2.7-2.fc30.noarch                         @updates
Upgraded dnf-data-4.2.5-2.fc30.noarch                         @@System
Upgrade  dnf-yum-4.2.7-2.fc30.noarch                          @updates
Upgraded dnf-yum-4.2.5-2.fc30.noarch                          @@System
Upgrade  flatpak-1.4.2-3.fc30.x86_64                          @updates
Upgraded flatpak-1.4.2-2.fc30.x86_64                          @@System
Upgrade  flatpak-libs-1.4.2-3.fc30.x86_64                     @updates
Upgraded flatpak-libs-1.4.2-2.fc30.x86_64                     @@System
Upgrade  flatpak-selinux-1.4.2-3.fc30.x86_64                  @updates
Upgraded flatpak-selinux-1.4.2-2.fc30.x86_64                  @@System
Upgrade  flatpak-session-helper-1.4.2-3.fc30.x86_64           @updates
Upgraded flatpak-session-helper-1.4.2-2.fc30.x86_64           @@System
Upgrade  glib2-2.60.6-1.fc30.x86_64                           @updates
Upgraded glib2-2.60.5-1.fc30.x86_64                           @@System
Upgrade  gnome-getting-started-docs-3.32.2-1.fc30.noarch      @updates
Upgraded gnome-getting-started-docs-3.32.1-1.fc30.noarch      @@System
Upgrade  gnome-user-docs-3.32.3-1.fc30.noarch                 @updates
Upgraded gnome-user-docs-3.32.2-1.fc30.noarch                 @@System
Upgrade  highlight-3.52-2.fc30.x86_64                         @updates
Upgraded highlight-3.50-1.fc30.x86_64                         @@System
Upgrade  ibus-typing-booster-2.6.4-1.fc30.noarch              @updates
Upgraded ibus-typing-booster-2.6.2-1.fc30.noarch              @@System
Upgrade  kernel-headers-5.1.20-300.fc30.x86_64                @updates
Upgraded kernel-headers-5.1.19-300.fc30.x86_64                @@System
Upgrade  libdnf-0.35.1-2.fc30.x86_64                          @updates
Upgraded libdnf-0.31.0-3.fc30.x86_64                          @@System
Upgrade  libhandy-0.0.9-2.fc30.x86_64                         @updates
Upgraded libhandy-0.0.9-1.fc30.x86_64                         @@System
Upgrade  libldb-1.5.5-1.fc30.x86_64                           @updates
Upgraded libldb-1.5.4-1.fc30.x86_64                           @@System
Upgrade  libmediainfo-19.07-1.fc30.x86_64                     @updates
Upgraded libmediainfo-19.04-1.fc30.x86_64                     @@System
Upgrade  libsmbclient-2:4.10.6-0.fc30.x86_64                  @updates
Upgraded libsmbclient-2:4.10.5-1.fc30.x86_64                  @@System
Upgrade  libssh-0.9.0-5.fc30.x86_64                           @updates
Upgraded libssh-0.8.7-1.fc30.x86_64                           @@System
Upgrade  libwbclient-2:4.10.6-0.fc30.x86_64                   @updates
Upgraded libwbclient-2:4.10.5-1.fc30.x86_64                   @@System
Upgrade  libwebp-1.0.3-1.fc30.x86_64                          @updates
Upgraded libwebp-1.0.2-2.fc30.x86_64                          @@System
Upgrade  mediainfo-19.07-1.fc30.x86_64                        @updates
Upgraded mediainfo-19.04-1.fc30.x86_64                        @@System
Upgrade  mesa-dri-drivers-19.1.3-1.fc30.x86_64                @updates
Upgraded mesa-dri-drivers-19.0.8-1.fc30.x86_64                @@System
Upgrade  mesa-filesystem-19.1.3-1.fc30.x86_64                 @updates
Upgraded mesa-filesystem-19.0.8-1.fc30.x86_64                 @@System
Upgrade  mesa-libEGL-19.1.3-1.fc30.x86_64                     @updates
Upgraded mesa-libEGL-19.0.8-1.fc30.x86_64                     @@System
Upgrade  mesa-libGL-19.1.3-1.fc30.x86_64                      @updates
Upgraded mesa-libGL-19.0.8-1.fc30.x86_64                      @@System
Upgrade  mesa-libOpenCL-19.1.3-1.fc30.x86_64                  @updates
Upgraded mesa-libOpenCL-19.0.8-1.fc30.x86_64                  @@System
Upgrade  mesa-libgbm-19.1.3-1.fc30.x86_64                     @updates
Upgraded mesa-libgbm-19.0.8-1.fc30.x86_64                     @@System
Upgrade  mesa-libglapi-19.1.3-1.fc30.x86_64                   @updates
Upgraded mesa-libglapi-19.0.8-1.fc30.x86_64                   @@System
Upgrade  mesa-libxatracker-19.1.3-1.fc30.x86_64               @updates
Upgraded mesa-libxatracker-19.0.8-1.fc30.x86_64               @@System
Upgrade  mesa-vulkan-drivers-19.1.3-1.fc30.x86_64             @updates
Upgraded mesa-vulkan-drivers-19.0.8-1.fc30.x86_64             @@System
Upgrade  oniguruma-6.9.2-2.fc30.x86_64                        @updates
Upgraded oniguruma-6.9.2-1.fc30.x86_64                        @@System
Upgrade  openssh-8.0p1-5.fc30.x86_64                          @updates
Upgraded openssh-8.0p1-4.fc30.x86_64                          @@System
Upgrade  openssh-clients-8.0p1-5.fc30.x86_64                  @updates
Upgraded openssh-clients-8.0p1-4.fc30.x86_64                  @@System
Upgrade  openssh-server-8.0p1-5.fc30.x86_64                   @updates
Upgraded openssh-server-8.0p1-4.fc30.x86_64                   @@System
Upgrade  perl-threads-shared-1.59-3.fc30.x86_64               @updates
Upgraded perl-threads-shared-1.59-2.fc30.x86_64               @@System
Upgrade  python3-3.7.4-1.fc30.x86_64                          @updates
Upgraded python3-3.7.3-3.fc30.x86_64                          @@System
Upgrade  python3-dnf-4.2.7-2.fc30.noarch                      @updates
Upgraded python3-dnf-4.2.5-2.fc30.noarch                      @@System
Upgrade  python3-hawkey-0.35.1-2.fc30.x86_64                  @updates
Upgraded python3-hawkey-0.31.0-3.fc30.x86_64                  @@System
Upgrade  python3-libdnf-0.35.1-2.fc30.x86_64                  @updates
Upgraded python3-libdnf-0.31.0-3.fc30.x86_64                  @@System
Upgrade  python3-libs-3.7.4-1.fc30.x86_64                     @updates
Upgraded python3-libs-3.7.3-3.fc30.x86_64                     @@System
Upgrade  qscintilla-qt5-2.11.2-2.fc30.x86_64                  @updates
Upgraded qscintilla-qt5-2.11.1-1.fc30.x86_64                  @@System
Upgrade  qt5-qtbase-5.12.4-4.fc30.x86_64                      @updates
Upgraded qt5-qtbase-5.12.4-3.fc30.x86_64                      @@System
Upgrade  qt5-qtbase-common-5.12.4-4.fc30.noarch               @updates
Upgraded qt5-qtbase-common-5.12.4-3.fc30.noarch               @@System
Upgrade  qt5-qtbase-gui-5.12.4-4.fc30.x86_64                  @updates
Upgraded qt5-qtbase-gui-5.12.4-3.fc30.x86_64                  @@System
Upgrade  samba-client-2:4.10.6-0.fc30.x86_64                  @updates
Upgraded samba-client-2:4.10.5-1.fc30.x86_64                  @@System
Upgrade  samba-client-libs-2:4.10.6-0.fc30.x86_64             @updates
Upgraded samba-client-libs-2:4.10.5-1.fc30.x86_64             @@System
Upgrade  samba-common-2:4.10.6-0.fc30.noarch                  @updates
Upgraded samba-common-2:4.10.5-1.fc30.noarch                  @@System
Upgrade  samba-common-libs-2:4.10.6-0.fc30.x86_64             @updates
Upgraded samba-common-libs-2:4.10.5-1.fc30.x86_64             @@System
Upgrade  samba-common-tools-2:4.10.6-0.fc30.x86_64            @updates
Upgraded samba-common-tools-2:4.10.5-1.fc30.x86_64            @@System
Upgrade  samba-libs-2:4.10.6-0.fc30.x86_64                    @updates
Upgraded samba-libs-2:4.10.5-1.fc30.x86_64                    @@System
Upgrade  sane-backends-1.0.27-24.fc30.x86_64                  @updates
Upgraded sane-backends-1.0.27-23.fc30.x86_64                  @@System
Upgrade  sane-backends-drivers-cameras-1.0.27-24.fc30.x86_64  @updates
Upgraded sane-backends-drivers-cameras-1.0.27-23.fc30.x86_64  @@System
Upgrade  sane-backends-drivers-scanners-1.0.27-24.fc30.x86_64 @updates
Upgraded sane-backends-drivers-scanners-1.0.27-23.fc30.x86_64 @@System
Upgrade  sane-backends-libs-1.0.27-24.fc30.x86_64             @updates
Upgraded sane-backends-libs-1.0.27-23.fc30.x86_64             @@System
Upgrade  selinux-policy-3.14.3-42.fc30.noarch                 @updates
Upgraded selinux-policy-3.14.3-41.fc30.noarch                 @@System
Upgrade  selinux-policy-targeted-3.14.3-42.fc30.noarch        @updates
Upgraded selinux-policy-targeted-3.14.3-41.fc30.noarch        @@System
Upgrade  sqlite-3.26.0-6.fc30.x86_64                          @updates
Upgraded sqlite-3.26.0-5.fc30.x86_64                          @@System
Upgrade  sqlite-libs-3.26.0-6.fc30.x86_64                     @updates
Upgraded sqlite-libs-3.26.0-5.fc30.x86_64                     @@System
Upgrade  switcheroo-control-1.3.1-1.fc30.x86_64               @updates
Upgraded switcheroo-control-1.1-7.fc30.x86_64                 @@System
Upgrade  tpm2-abrmd-2.2.0-1.fc30.x86_64                       @updates
Upgraded tpm2-abrmd-2.1.1-1.fc30.x86_64                       @@System
Upgrade  vid.stab-1.1.0-11.20190213gitaeabc8d.fc30.x86_64     @updates
Upgraded vid.stab-1.1.0-10.20180529git38ecbaf.fc30.x86_64     @@System
Upgrade  vim-minimal-2:8.1.1749-1.fc30.x86_64                 @updates
Upgraded vim-minimal-2:8.1.1713-1.fc30.x86_64                 @@System
Upgrade  google-chrome-stable-76.0.3809.87-1.x86_64           @google-chrome
Upgraded google-chrome-stable-75.0.3770.142-1.x86_64          @@System
Upgrade  slack-4.0.1-0.1.fc21.x86_64                          @slack
Upgraded slack-4.0.0-0.1.fc21.x86_64                          @@System
Removed  kernel-5.1.16-300.fc30.x86_64                        @@System
Removed  kernel-core-5.1.16-300.fc30.x86_64                   @@System
Removed  kernel-modules-5.1.16-300.fc30.x86_64                @@System
Removed  kernel-modules-extra-5.1.16-300.fc30.x86_64          @@System[/code]

Scriptlet output:
1 Redirecting to /bin/systemctl start atd.service

VLC version:

vlc-3.0.7.1-3.fc30.x86_64

Crash found in the logs:

[ 59.550875] vlc[3788]: segfault at 38 ip 00007f9784a96e6f sp 00007f9797b3e3d0 error 4 in nouveau_drv_video.so[7f97847f9000+485000]
[ 59.550878] Code: 89 f3 31 f6 48 83 ec 08 e8 3e 00 01 00 48 8b 40 08 48 8b 50 40 48 83 c0 40 48 39 c2 0f 84 4f 87 d6 ff 48 8b 42 10 48 8b 68 10 45 38 ff ff 10 00 75 08 8b 45 28 39 45 24 74 10 48 83 c4 08 5b

1 Like

Thanks for that. Unfortunately, this bug doesn’t seem to be reported. Could someone report it please?

https://apps.fedoraproject.org/packages/mesa/bugs/all

https://docs.fedoraproject.org/en-US/quick-docs/howto-file-a-bug/

1 Like

Some good soul has now reported the bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1736814

Anyway, I had the same version installed:

$ sudo dnf history info 700
Transaction ID : 700
Begin time     : Wed 31 Jul 2019 09:54:23 PM CEST
Begin rpmdb    : 3638:95b0a136667748e1791c35e0bf1c9d7774c53290
End time       : Wed 31 Jul 2019 09:54:45 PM CEST (22 seconds)
End rpmdb      : 3638:aa3a23d0a1aa0320c113783bd1fcd9a4eae3a9aa
User           : Andrea <andrea>
Return-Code    : Success
Releasever     : 30
Command Line   : downgrade mesa-*
Packages Altered:
    Downgrade  mesa-dri-drivers-19.0.2-3.fc30.x86_64    @fedora
    Downgraded mesa-dri-drivers-19.1.3-1.fc30.x86_64    @@System
    Downgrade  mesa-filesystem-19.0.2-3.fc30.x86_64     @fedora
    Downgraded mesa-filesystem-19.1.3-1.fc30.x86_64     @@System
    Downgrade  mesa-khr-devel-19.0.2-3.fc30.x86_64      @fedora
    Downgraded mesa-khr-devel-19.1.3-1.fc30.x86_64      @@System
    Downgrade  mesa-libEGL-19.0.2-3.fc30.x86_64         @fedora
    Downgraded mesa-libEGL-19.1.3-1.fc30.x86_64         @@System
    Downgrade  mesa-libEGL-devel-19.0.2-3.fc30.x86_64   @fedora
    Downgraded mesa-libEGL-devel-19.1.3-1.fc30.x86_64   @@System
    Downgrade  mesa-libGL-19.0.2-3.fc30.x86_64          @fedora
    Downgraded mesa-libGL-19.1.3-1.fc30.x86_64          @@System
    Downgrade  mesa-libGL-devel-19.0.2-3.fc30.x86_64    @fedora
    Downgraded mesa-libGL-devel-19.1.3-1.fc30.x86_64    @@System
    Downgrade  mesa-libGLES-19.0.2-3.fc30.x86_64        @fedora
    Downgraded mesa-libGLES-19.1.3-1.fc30.x86_64        @@System
    Downgrade  mesa-libGLES-devel-19.0.2-3.fc30.x86_64  @fedora
    Downgraded mesa-libGLES-devel-19.1.3-1.fc30.x86_64  @@System
    Downgrade  mesa-libOSMesa-19.0.2-3.fc30.x86_64      @fedora
    Downgraded mesa-libOSMesa-19.1.3-1.fc30.x86_64      @@System
    Downgrade  mesa-libOpenCL-19.0.2-3.fc30.x86_64      @fedora
    Downgraded mesa-libOpenCL-19.1.3-1.fc30.x86_64      @@System
    Downgrade  mesa-libgbm-19.0.2-3.fc30.x86_64         @fedora
    Downgraded mesa-libgbm-19.1.3-1.fc30.x86_64         @@System
    Downgrade  mesa-libglapi-19.0.2-3.fc30.x86_64       @fedora
    Downgraded mesa-libglapi-19.1.3-1.fc30.x86_64       @@System
    Downgrade  mesa-libxatracker-19.0.2-3.fc30.x86_64   @fedora
    Downgraded mesa-libxatracker-19.1.3-1.fc30.x86_64   @@System
    Downgrade  mesa-vulkan-drivers-19.0.2-3.fc30.x86_64 @fedora
    Downgraded mesa-vulkan-drivers-19.1.3-1.fc30.x86_64 @@System


$ rpm -q vlc
vlc-3.0.7.1-3.fc30.x86_64

1 Like

Please drop comments on the bug if you can. That tells the maintainer that the issue is affecting multiple users and increases its severity.

In general, discussing things on forums is good for tweaks/workarounds, but bugs can only be fixed by the developers/maintainers. So, the more we keep them aware of issues and help them fix them by providing information, the more likely it is for a bug to be fixed quickly.

3 Likes

I had the same issue, I fixed and I also downgrade mesa-* packages now it’s work perfectly

1 Like

Downgrade mesa only for Vlc?
Anybody are tested the vlc from UnitedRPMs?

Interesting suggestion. If it’s a mesa issue, why would vlc from elsewhere work, though :thinking: ?

1 Like

Because the problem should first be reported in the appropriate channels; first in vlc with the minimals things for them to update their code to the current “mesa”. Second, as the report is using rpmfusion vlc; This would be the second channel (bugzilla rpmfusion). I ask you why mesa should fix vlc errors?; other, I am using vlc 3.0.8 (current commits and others minors changes) vrs 3.0.7 in rpmfusion f30 … And if exist the same issue with UnitedRPMs report here. :wink:

Another interim solution is changing the video output to avoid the corrupted library. “XVideo output (XCB)” works well on my host (Fedora 30, using vlc from rpmfusion). This solution is less invasive and does not affect other parts of the system until the issue has been solved.

1 Like