Vnc displays a blank blue screen

Hi All,
I need some help with getting vnc running om my laptop.
Config : HP Probook Dualboot Win10 Pro / Manjaro Linux 18.1 with KVM

Guest OS Fedora Server 31 with GUI Xfce Desktop
1 ) dnf install tigervnc-server tigervnc-server-module xorg-x11-fonts-Type1

I followed the instruction mentioned in /lib/systemd/system/vncserver@.service
The result is OK as you can see below [code]
From my laptop using Manjaro with the Remmina client, I connect to the server and get
the vnc password screen. Typed the password / confirmed it and the result is a blue screen. I also amended the config file in my home folder .vnc “uncomment geometry” and changed the value to 1920 x 1080

On other support forum I found some potential solutions but I did not try them because it was Centos 6 (change / add exec gnome-session or startkde) and vnc with systemd is a “new” solution.
Can you advise on this ? much appreciate !

Br,

[arthur@fintst0315 .vnc]$ systemctl status vncserver@\:1.service 
● vncserver@:1.service - Remote desktop service (VNC)
   Loaded: loaded (/etc/systemd/system/vncserver@.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2020-01-06 19:28:57 -03; 56min ago
  Process: 1139 ExecStartPre=/bin/sh -c /usr/bin/vncserver -kill :1 > /dev/null 2>&1 || : (code=exited, status=0/SUCCESS)
 Main PID: 1156 (vncserver_wrapp)
    Tasks: 2 (limit: 9503)
   Memory: 5.3M
      CPU: 2.358s
   CGroup: /system.slice/system-vncserver.slice/vncserver@:1.service
           ├─1156 /usr/bin/sh /usr/bin/vncserver_wrapper arthur :1
           └─2479 sleep 5

Jan 06 19:28:56 fintst0315 systemd[1]: Starting Remote desktop service (VNC)...
Jan 06 19:28:57 fintst0315 systemd[1]: Started Remote desktop service (VNC).
Jan 06 19:29:01 fintst0315 vncserver_wrapper[1156]: New 'fintst0315:1 (arthur)' desktop is fintst0315:1
Jan 06 19:29:01 fintst0315 vncserver_wrapper[1156]: Starting applications specified in /home/arthur/.vnc/xstartup
Jan 06 19:29:01 fintst0315 vncserver_wrapper[1156]: Log file is /home/arthur/.vnc/fintst0315:1.log
Jan 06 19:29:06 fintst0315 vncserver_wrapper[1156]: 'vncserver :1' has PID 1279, waiting until it exits ...
Xvnc TigerVNC 1.10.0 - built Dec 20 2019 00:00:00
Copyright (C) 1999-2019 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.
Underlying X server release 12006000, The X.Org Foundation


Mon Jan  6 19:28:58 2020
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5901
 vncext:      created VNC server for screen 0

Mon Jan  6 19:31:00 2020
 Connections: accepted: 192.168.122.1::47254
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VeNCrypt(19)
 SVeNCrypt:   Client requests security type TLSVnc (258)

Mon Jan  6 19:31:07 2020
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 8 (8bpp) bgr233

Mon Jan  6 20:35:13 2020
 VNCSConnST:  closing 192.168.122.1::47254: Clean disconnection
 EncodeManager: Framebuffer updates: 2
 EncodeManager:   Tight:
 EncodeManager:     Solid: 1 rects, 2.0736 Mpixels
 EncodeManager:            14 B (1:148115 ratio)
 EncodeManager:   Total: 1 rects, 2.0736 Mpixels
 EncodeManager:          14 B (1:148115 ratio)
 TLS:         TLS session wasn't terminated gracefully
 TcpSocket:   unable to get peer name for socket
 Connections: closed: ::0
 ComparingUpdateTracker: 0 pixels in / 0 pixels out
 ComparingUpdateTracker: (1:-nan ratio)

Mon Jan  6 20:36:11 2020
 Connections: accepted: 192.168.122.1::47470
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VeNCrypt(19)
 SVeNCrypt:   Client requests security type TLSVnc (258)

Mon Jan  6 20:36:20 2020
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 8 (8bpp) bgr233

https://wiki.archlinux.org/index.php/TigerVNC

" Warning: The default’s TigerVNC security method is not secure, it lacks identity verification and will not prevent man-in-the-middle attack during the connection setup. Make sure you understand the security settings of your server and do not connect insecurely to a vncserver outside of a trusted LAN."


I've no idea about your trouble, but:

1 -- Formatting

`dnf install` == dnf install
`0 O. 1 I l` == 0 O. 1 I l

```
hello    == (see below)
```

hello    ! i use spaces instead of  
      also my lines can be scrolled, and will not be line-breaked

2 -- Make it easy

Your said, that Fedora is a guest OS, but:

Your rather need to bring the less ambiguous formatting to your post.

Ok thanks for security warning.
I meant that I installed Fedora 31 server as a KVM guest
Sorry about that I was not clear enough …

I have found the solution on a recent website and it is working

Solution
1 ) Make a backup of xstartup in your home folder /.vnc
2) Amend the xstartup file and it should like this:

unset SESSION_MANAGER unset DBUS_SESSION_BUS_ADDRESS # exec /etc/X11/xinit/xinitrc

xrdb $HOME/.Xresources
startxfce4 &

  1. Restart the KVM guest

This works for me

source : https://www.techrepublic.com/article/how-to-install-a-vnc-server-on-linux/

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.