Volume Control not working (only mute or max volume) after fresh install of Fedora 34 / Gnome 40

Hello,

I have done a fresh install of Fedora 34 with Gnome 40 on my Asus Zenbook 3 (UX390) and everything works nice and smoothly except for the audio volume control. The audio is either maxed (no matter the position of the slider) or muted (slider all to the left).

I had this problem with Fedora 33 as well, but there I could easily apply this fix: https://askubuntu.com/a/1091197

But now with the new audio subsystem implemented, that fix is of no use anymore and I couldn’t come across a fix. So I was wondering if maybe somebody could help me here on the forum.

Thanks for any advice and help!

2 Likes

Same here.

Make sure to install all updates and reboot, then post the output:

uname -a; rpm -q -a kernel pipewire | sort
1 Like

I’ve updated the OS to the latest, even performed a fresh installation (of F34) but it didn’t help … Had to re-install F33 eventually.
I beleive it’s a global concern, hopefully to be solved soon to re-upgrade.
Note: I’m using HP ProBook 450 G5
Note 2: The sound (along with the volume controllers) worked fine only after the fresh installation for a while before I update the OS (using dnf update I mean) … Then the sound output device disappeared again.

Hi Vladislav,

Thanks for your help!

I have just updated my computer, rebooted it and this is the requested output of the command:

[geoffrey@fedora ~]$ uname -a; rpm -q -a kernel pipewire | sort
Linux fedora 5.11.17-300.fc34.x86_64 #1 SMP Wed Apr 28 14:21:28 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
kernel-5.11.12-300.fc34.x86_64
kernel-5.11.15-300.fc34.x86_64
kernel-5.11.17-300.fc34.x86_64
pipewire-0.3.26-4.fc34.x86_64
1 Like

Did somebody maybe got a solution for this problem? :slight_smile: