Wacom tablet no longer working as a mouse in Fedora 32

Up through Fedora 31, my Wacom tablet worked wonderfully as my mouse. I use the pen with the tablet as a mouse because of carpel tunnel issues.
When I upgraded to Fedora 32, the tablet only works as a drawing graphics tablet which no longer works as a mouse (very slow movement, cross instead of mouse pointer, etc.) This may be great for artist, but not for those of us that need the mouse emulation.
Is this a Fedora 32 issue or a Gnome issue? Is there some way to switch back to mouse mode? Do I need to downgrade to Fedora 32 to get Wacom to act like a mouse again?

Thank you for any answers I get.
Don D

You could compare the boot logs between Fedora 32 and 31 and check for failures and/or differences. Or check for .conf files in /etc/X11/xorg.conf.d/ which maybe configure your tablet and/or mouse.
Assuming you are running Gnome under X and not Wayland, you could check and filter the boot log with:
sudo journalctl -b _COMM=gdm-x-session

With sudo journalctl --list-boots you will see a list of boot ID’s and time of boot. This number, in this example 10, you can use again to check an older boot log messages with sudo journalctl -b -10 _COMM=gdm-x-session
https://fedoraproject.org/wiki/How_to_debug_Xorg_problems
https://fedoraproject.org/wiki/How_to_debug_Wayland_problems

You could send the output to https://paste.centos.org/ and share it here with
sudo journalctl -b -10 --no-hostname --no-pager _COMM=gdm-x-session | fpaste

I’m having a similar problem:
Fedora 32, KDE 5.18.5, Kernel 5.6.19-300
Wacom Bamboo tablet was working fine yesterday as mouse & graphic device. Today, the system knows it’s there, it but it doesn’t work at all. I don’t recall doing any system updates yesterday.

I tried running the commands for journaling but got nothing - apparently journaling is not enabled.
There is no Wacom config file under /etc/X11/xorg.conf.d. I thought that was deprecated some time back.
I’d try going back to an earlier kernel, but Grub is broken and doesn’t give me any choices.

I rebooted the system - the tablet works again

You could try this to fix your Grub.

@ddorris I forgot about that, did your problem start after a kernel update? Perhaps, you could try what @neverknew could not do.

Thanks for the tip but it didn’t seem to work.
The problem started after a clean install of F30. Still a problem with F31 and F32. The boot screen appears once in a while, about every 100-200 restarts.

The Wacom tablet is being weird. One startup it works fine, the next it doesn’t work at all. Then the next time it works for a few minutes then stops working. I don’t know if I’m chasing hardware or software problems.

The Wacom Tablet finder utility sees the tablet but doesn’t want to recognize the stylus. Changing from “Normal tablet” to “Multi-device table, pen sensor” doesn’t seem to be saving.

Thanks to everyone that responded on my issue with my Wacom Tablet. About a week ago, I did an update to Fedora 32, which updated the kernel. After the update, I noticed the Wacom Tablet and pen were again working as a mouse and not as only a drawing device. Although it not as responsive as a mouse as it was before, it’s working pretty well.

I noticed @neverknew was talking about a Wacom Tablet finder. I’m not familiar with it. Is it available for Fedora 32? If so, how is it loaded?
Thanks again,
Don D

Wacom Tablet Finder and Wacom Tablet configuration are included with Fedora and most other Linux distros. I think they’re available under Gnome and KDE though they work differently
You should be able to find them in Software or under DNFdragora. Search on “wacom” and just select to install.

The actual drivers are now part of the Linux kernel.

Thank you, @neverknew.

I found the Wacom Tablet Finder using dnfdragora. It doesn’t provide much more than what’s already in the kernel, but it does show me how the system sees the tablet and my pen.

I really appreciate your help.
Thanks
Don D.