Wayland on double graphics cards setup

I use intel integrated card 530 and nvidia 1060. Monitor is connected on intel. In this setup fedora 33 is using X11 server. I want to use wayland and commended the # WaylandEnable=false option on /etc/gdm/custom.conf but system still insists to use X11. How i can enable Wayland in this setup?

my grub configuration (if this is related):
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="(sed 's, release .*,g’ /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT=“console”
GRUB_CMDLINE_LINUX=“rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=/dev/mapper/fedora_localhost–live-swap rd.lvm.lv=fedora_localhost-live/root rd.luks.uuid=luks-cbe4c254-d5d8-4ae1-a2e9-f4fa9145247a rd.lvm.lv=fedora_localhost-live/swap rhgb quiet”
GRUB_DISABLE_RECOVERY=“true”
GRUB_ENABLE_BLSCFG=true
GRUB_CMDLINE_LINUX_DEFAULT=‘quiet splash’
GRUB_GFXMODE=auto
GRUB_GFXPAYLOAD_LINUX=keep

Did you select GNOME from the gdm login screen by clicking the gear icon?

yes, GNOME is selected, i checked that

OK, I solved this. Was my mistake, i had previously (when i was using only nvidia) disabled Wayland on /usr/lib/udev/rules.d/61-gdm.rules.
Edited the file and i enabled again Wayland.

1 Like