Wayland session is unavailable with vendor-provided NVIDIA driver

Problem

In Fedora 37, when using an NVIDIA driver provided directly from the vendor, the GNOME login screen doesn’t allow the user to select a Wayland session, only an X11 session.

Cause

The vendor driver provided directly from NVIDIA fails to suspend and resume out of the box in Wayland sessions without manual configuration from the user. As such, in Fedora 37, Wayland based sessions are filtered from the login screen when a non-working configuration is detected.

Related Issues

Bug 2128910 - NVIDIA Wayland Session Not Available in GDM 43

Workarounds

Option A)
The simplest workaround is to avoid installing (or uninstall) the NVIDIA driver provided by the vendor, and install NVIDIA driver from RPMFusion instead. (If you enable the corresponding repository in GNOME Software → Fedora Repositories → Fedora Third Party Repositories, the driver can then be easily found through GNOME Software).

Option B)
If you need to use the driver provided by NVIDIA directly, it should be sufficient to edit /etc/modprobe.d/nvidia.conf, add the following line at the end of the file:

options nvidia "NVreg_PreserveVideoMemoryAllocations=1"

and reboot. If that doesn’t help, read through the related NVIDIA documentation carefully and configure your system accordingly.

3 Likes

An update has been released to fix this issue.

After you update your system in your usual way (and possibly reboot), you should no longer be affected by this problem. If the problem persists, please start a new discussion topic and we’ll help figure out what’s still wrong.

(Please ignore out little bot here, it is confused. The issue is not fixed, because we can’t fix it. We can only provide a decent workaround, as documented above).